summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-14 11:33:15 +0100
committerDavid Seifert <soap@gentoo.org>2021-02-14 11:33:15 +0100
commitb66a8e0cd0b407057cbe8d3e5da354640c59d43b (patch)
treef3c88984f8c403a9e6ad86b49475b284af1f8feb /sci-libs
parentsci-libs/openlibm: Remove old (diff)
downloadgentoo-b66a8e0cd0b407057cbe8d3e5da354640c59d43b.tar.gz
gentoo-b66a8e0cd0b407057cbe8d3e5da354640c59d43b.tar.bz2
gentoo-b66a8e0cd0b407057cbe8d3e5da354640c59d43b.zip
sci-libs/libecpint: Bump to 1.0.5
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libecpint/Manifest1
-rw-r--r--sci-libs/libecpint/libecpint-1.0.5.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/sci-libs/libecpint/Manifest b/sci-libs/libecpint/Manifest
index b8a71480926f..53231659574e 100644
--- a/sci-libs/libecpint/Manifest
+++ b/sci-libs/libecpint/Manifest
@@ -1 +1,2 @@
DIST libecpint-1.0.4.tar.gz 1313698 BLAKE2B 63f7ce2001ae9bdc975af083735f82fd03e133e880061d3c8659bf18d8236d09a7337049977cea6867a4e0e586d4112ccef6a8ee098903869111551364f614fb SHA512 ff38b598351e4499cd2d270a15e8c2dedcb0a6bc6aafcfc7a88ed8053199356e209bdb630713370aacbc3bba2a169050520405f7003feea7b064140d6d5337b6
+DIST libecpint-1.0.5.tar.gz 1313876 BLAKE2B 279618262bc32928964d559bda3f2d6235340bf807abb755c676a20ea6712d36d80a84a2522dd16d19290f5d622e47c4c0a34b549ffdb628f6c07372a5109981 SHA512 ad68599c1a220556ebb265968da6701596cf2388aa422100b80863bd8f73eaa1be5a2349c0db8c8864c3c8cf57151fe3d4520a3670f3b40ce147195079886d86
diff --git a/sci-libs/libecpint/libecpint-1.0.5.ebuild b/sci-libs/libecpint/libecpint-1.0.5.ebuild
new file mode 100644
index 000000000000..47004ee7019c
--- /dev/null
+++ b/sci-libs/libecpint/libecpint-1.0.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Efficient evaluation of integrals over ab initio effective core potentials"
+HOMEPAGE="https://github.com/robashaw/libecpint"
+SRC_URI="https://github.com/robashaw/libecpint/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-libs/pugixml"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DLIBECPINT_BUILD_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}