summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-08-11 10:39:37 +0200
committerAlfredo Tupone <tupone@gentoo.org>2023-08-11 10:40:05 +0200
commit71578f583267ca3847dab44526e40eb0ca171dec (patch)
tree858335cda78fb66785fcf4fa248e9a633268fb95 /sci-libs
parentdev-ruby/rails: add 7.0.7 (diff)
downloadgentoo-71578f583267ca3847dab44526e40eb0ca171dec.tar.gz
gentoo-71578f583267ca3847dab44526e40eb0ca171dec.tar.bz2
gentoo-71578f583267ca3847dab44526e40eb0ca171dec.zip
sci-libs/caffe2: build nvfuser for cuda users
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/caffe2/caffe2-2.0.1-r4.ebuild (renamed from sci-libs/caffe2/caffe2-2.0.1-r3.ebuild)4
1 files changed, 3 insertions, 1 deletions
diff --git a/sci-libs/caffe2/caffe2-2.0.1-r3.ebuild b/sci-libs/caffe2/caffe2-2.0.1-r4.ebuild
index 29087a44643f..67ab76e8ed76 100644
--- a/sci-libs/caffe2/caffe2-2.0.1-r3.ebuild
+++ b/sci-libs/caffe2/caffe2-2.0.1-r4.ebuild
@@ -136,7 +136,7 @@ src_configure() {
-DUSE_CUDNN=$(usex cuda)
-DUSE_FAST_NVCC=$(usex cuda)
-DTORCH_CUDA_ARCH_LIST="${TORCH_CUDA_ARCH_LIST:-3.5 7.0}"
- -DBUILD_NVFUSER=OFF
+ -DBUILD_NVFUSER=$(usex cuda)
-DUSE_DISTRIBUTED=$(usex distributed)
-DUSE_MPI=$(usex mpi)
-DUSE_FAKELOWP=OFF
@@ -196,6 +196,8 @@ src_configure() {
src_install() {
cmake_src_install
+ use cuda && dolib.so "${BUILD_DIR}"/lib/libnvfuser_codegen.so
+
insinto "/var/lib/${PN}"
doins "${BUILD_DIR}"/CMakeCache.txt