summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-03-06 11:20:55 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-03-06 12:09:46 +0100
commit4cd1c13c41ae437acff1ee44811365d2b61f3b5c (patch)
tree1d30cb2d04e079999b4003a25ffdddae204d41c9 /sci-libs/voro++/voro++-0.4.6-r1.ebuild
parentsci-libs/lmfit: Use cmake.eclass/EAPI-7, fix patch, fix HOMEPAGE (diff)
downloadgentoo-4cd1c13c41ae437acff1ee44811365d2b61f3b5c.tar.gz
gentoo-4cd1c13c41ae437acff1ee44811365d2b61f3b5c.tar.bz2
gentoo-4cd1c13c41ae437acff1ee44811365d2b61f3b5c.zip
sci-libs/voro++: EAPI-7 bump, use cmake.eclass, use GNUInstallDirs
Raise cmake minimum to 3.0 for future compatibility. Rename duplicate 'help' custom target to fix build with ninja. Drop wholly unnecessary uninstall part from CMakeLists.txt. Simplify ebuild. ...45 lines saved! Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-libs/voro++/voro++-0.4.6-r1.ebuild')
-rw-r--r--sci-libs/voro++/voro++-0.4.6-r1.ebuild15
1 files changed, 4 insertions, 11 deletions
diff --git a/sci-libs/voro++/voro++-0.4.6-r1.ebuild b/sci-libs/voro++/voro++-0.4.6-r1.ebuild
index b1fa72623758..a2ab69b03aa5 100644
--- a/sci-libs/voro++/voro++-0.4.6-r1.ebuild
+++ b/sci-libs/voro++/voro++-0.4.6-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils
+inherit cmake
-DESCRIPTION="A 3D Voronoi cell software library"
+DESCRIPTION="3D Voronoi cell software library"
HOMEPAGE="http://math.lbl.gov/voro++/"
SRC_URI="http://math.lbl.gov/voro++/download/dir/${P}.tar.gz"
@@ -15,10 +15,3 @@ KEYWORDS="amd64 x86"
IUSE=""
PATCHES=( "${FILESDIR}/${P}-cmake.patch" )
-
-src_configure() {
- local mycmakeargs=(
- -DLIB=$(get_libdir)
- )
- cmake-utils_src_configure
-}