summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYiyangWu <xgreenlandforwyy@gmail.com>2022-05-02 18:35:02 +0800
committerBenda Xu <heroxbd@gentoo.org>2022-05-03 13:41:34 +0800
commitf1fe0cd02be99ed18b07c5ba1ab6e6b913948a3d (patch)
tree6014a4a713351717627d09e4f2820b3ca6e12e94 /sci-libs/rocSPARSE/files
parentsci-libs/rocRAND: bump to version 5.0.2 (diff)
downloadgentoo-f1fe0cd02be99ed18b07c5ba1ab6e6b913948a3d.tar.gz
gentoo-f1fe0cd02be99ed18b07c5ba1ab6e6b913948a3d.tar.bz2
gentoo-f1fe0cd02be99ed18b07c5ba1ab6e6b913948a3d.zip
sci-libs/rocSPARSE: bump to 5.0.2
Enable navy_flounder cards via rocSPARSE-5.0.2-enable-gfx1031.patch Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Yiyang Wu <xgreenlandforwyy@gmail.com> Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'sci-libs/rocSPARSE/files')
-rw-r--r--sci-libs/rocSPARSE/files/rocSPARSE-5.0.2-enable-gfx1031.patch13
-rw-r--r--sci-libs/rocSPARSE/files/rocSPARSE-5.0.2-remove-matrices-unpacking.patch42
2 files changed, 55 insertions, 0 deletions
diff --git a/sci-libs/rocSPARSE/files/rocSPARSE-5.0.2-enable-gfx1031.patch b/sci-libs/rocSPARSE/files/rocSPARSE-5.0.2-enable-gfx1031.patch
new file mode 100644
index 000000000000..fd44bb938406
--- /dev/null
+++ b/sci-libs/rocSPARSE/files/rocSPARSE-5.0.2-enable-gfx1031.patch
@@ -0,0 +1,13 @@
+Index: rocSPARSE-rocm-5.0.2/library/src/include/common.h
+===================================================================
+--- rocSPARSE-rocm-5.0.2.orig/library/src/include/common.h
++++ rocSPARSE-rocm-5.0.2/library/src/include/common.h
+@@ -167,7 +167,7 @@ __device__ __forceinline__ void rocspars
+ if(BLOCKSIZE > 1) { if(i < 1 && i + 1 < BLOCKSIZE) { data[i] = min(data[i], data[i + 1]); } __syncthreads(); }
+ }
+
+-#ifndef __gfx1030__
++#if !defined(__gfx1030__) && !defined(__gfx1031__)
+ // DPP-based wavefront reduction maximum
+ template <unsigned int WFSIZE>
+ __device__ __forceinline__ void rocsparse_wfreduce_max(int* maximum)
diff --git a/sci-libs/rocSPARSE/files/rocSPARSE-5.0.2-remove-matrices-unpacking.patch b/sci-libs/rocSPARSE/files/rocSPARSE-5.0.2-remove-matrices-unpacking.patch
new file mode 100644
index 000000000000..81d2b4ab1458
--- /dev/null
+++ b/sci-libs/rocSPARSE/files/rocSPARSE-5.0.2-remove-matrices-unpacking.patch
@@ -0,0 +1,42 @@
+Don't let cmake handle test data download, unpack and convert
+
+Index: rocSPARSE-rocm-5.0.2/clients/tests/CMakeLists.txt
+===================================================================
+--- rocSPARSE-rocm-5.0.2.orig/clients/tests/CMakeLists.txt
++++ rocSPARSE-rocm-5.0.2/clients/tests/CMakeLists.txt
+@@ -23,35 +23,6 @@
+
+ find_package(GTest 1.10.0 REQUIRED)
+
+-#
+-# Client matrices.
+-#
+-
+-if(NOT EXISTS "${CMAKE_MATRICES_DIR}")
+- #
+- # Download.
+- #
+- set(CMAKE_MATRICES_DIR ${PROJECT_BINARY_DIR}/matrices CACHE STRING "Matrices directory.")
+-
+- if(NOT TARGET rocsparse)
+- set(CONVERT_SOURCE ${CMAKE_SOURCE_DIR}/../deps/convert.cpp CACHE STRING "Convert tool mtx2csr.")
+- include(${CMAKE_SOURCE_DIR}/../cmake/ClientMatrices.cmake)
+- else()
+- set(CONVERT_SOURCE ${CMAKE_SOURCE_DIR}/deps/convert.cpp CACHE STRING "Convert tool mtx2csr.")
+- include(${CMAKE_SOURCE_DIR}/cmake/ClientMatrices.cmake)
+- endif()
+-
+-else()
+-
+- #
+- # Copy.
+- #
+- if(NOT CMAKE_MATRICES_DIR STREQUAL "${PROJECT_BINARY_DIR}/matrices")
+- execute_process(COMMAND cp -r ${CMAKE_MATRICES_DIR} ${PROJECT_BINARY_DIR}/matrices)
+- endif()
+-
+-endif()
+-
+ set(ROCSPARSE_TEST_SOURCES
+ test_axpby.cpp
+ test_axpyi.cpp