summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Petrina <jakov.petrina@sartura.hr>2021-10-11 16:57:37 +0200
committerJakov Smolić <jsmolic@gentoo.org>2021-10-12 11:09:07 +0200
commitc533eef97bbff34532198984a87c2e373faeaf9f (patch)
tree612b1482cbdc3cac0dd04c75ed3acadf65752a2e /sci-libs/openlibm/openlibm-0.8.0.ebuild
parentdev-libs/libnfc: Fix pcsc-lite support (diff)
downloadgentoo-c533eef97bbff34532198984a87c2e373faeaf9f.tar.gz
gentoo-c533eef97bbff34532198984a87c2e373faeaf9f.tar.bz2
gentoo-c533eef97bbff34532198984a87c2e373faeaf9f.zip
sci-libs/openlibm: bump to 0.8.0
Bump package to new upstream version 0.8.0. Update EAPI to latest version (8) as well. Signed-off-by: Jakov Petrina <jakov.petrina@sartura.hr> Closes: https://github.com/gentoo/gentoo/pull/22563 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'sci-libs/openlibm/openlibm-0.8.0.ebuild')
-rw-r--r--sci-libs/openlibm/openlibm-0.8.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-libs/openlibm/openlibm-0.8.0.ebuild b/sci-libs/openlibm/openlibm-0.8.0.ebuild
new file mode 100644
index 000000000000..ba45cbd625fb
--- /dev/null
+++ b/sci-libs/openlibm/openlibm-0.8.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="High quality system independent, open source libm"
+HOMEPAGE="https://github.com/JuliaLang/openlibm"
+SRC_URI="https://github.com/JuliaMath/openlibm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain MIT ISC BSD-2 LGPL-2.1+"
+# See https://abi-laboratory.pro/index.php?view=timeline&l=openlibm
+SLOT="0/4"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+src_prepare() {
+ default
+ sed -e "/^OLM_LIBS :=/s/^/#/" \
+ -e "/install: /s/install-static//" \
+ -i Makefile || die
+}
+
+src_configure() {
+ tc-export CC CXX FC AR LD
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" \
+ libdir="${EPREFIX}/usr/$(get_libdir)" install
+ dodoc README.md
+}