summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2022-06-19 00:44:15 -0700
committerSam James <sam@gentoo.org>2022-06-21 00:34:12 +0100
commita0b5349db89d992c59712c299fdad1c0fc65761f (patch)
tree0f3c7f57a43601c6d5b8401fa2510a14059ffeb9 /sci-libs/cqrlib/cqrlib-1.1.4.ebuild
parentdev-libs/libfstrcmp: Fix docdir (diff)
downloadgentoo-a0b5349db89d992c59712c299fdad1c0fc65761f.tar.gz
gentoo-a0b5349db89d992c59712c299fdad1c0fc65761f.tar.bz2
gentoo-a0b5349db89d992c59712c299fdad1c0fc65761f.zip
sci-libs/cqrlib: Added 1.1.4
Bug: https://bugs.gentoo.org/778911 Upstream-PR: https://github.com/yayahjb/cqrlib/pull/1 Signed-off-by: orbea <orbea@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/25971 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/cqrlib/cqrlib-1.1.4.ebuild')
-rw-r--r--sci-libs/cqrlib/cqrlib-1.1.4.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sci-libs/cqrlib/cqrlib-1.1.4.ebuild b/sci-libs/cqrlib/cqrlib-1.1.4.ebuild
new file mode 100644
index 000000000000..525ebb014f17
--- /dev/null
+++ b/sci-libs/cqrlib/cqrlib-1.1.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_PN=CQRlib
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Utility library for quaternion arithmetic / rotation math (ANSI C implemented)"
+HOMEPAGE="http://cqrlib.sourceforge.net/"
+SRC_URI="https://github.com/yayahjb/${PN}/archive/${MY_P}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-libs/cvector"
+DEPEND="${RDEPEND}"
+
+DOCS=( README_CQRlib.txt )
+HTML_DOCS=( README_CQRlib.html )
+
+S="${WORKDIR}"/${PN}-${MY_P}
+
+PATCHES=(
+ "${FILESDIR}/${PV}-libtool.patch" # 778911
+ "${FILESDIR}/${PV}-build.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ emake all
+}
+
+src_test() {
+ emake tests
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ einstalldocs
+ find "${D}" -name '*.la' -delete || die
+}