summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-11-23 23:03:07 +0100
committerDavid Seifert <soap@gentoo.org>2016-11-24 09:33:10 +0100
commit287901e0f3f506df519d13ddc0aaf5e927456c6f (patch)
tree9bf1018ad6bd39e457e6d19d23f7071264a3cb72 /sci-libs/arprec
parentsci-libs/qd: Remove old (diff)
downloadgentoo-287901e0f3f506df519d13ddc0aaf5e927456c6f.tar.gz
gentoo-287901e0f3f506df519d13ddc0aaf5e927456c6f.tar.bz2
gentoo-287901e0f3f506df519d13ddc0aaf5e927456c6f.zip
sci-libs/arprec: Version bump to 2.2.18
Gentoo-bug: 593872 * EAPI=6 * [QA] Replace EROOT by EPREFIX Package-Manager: portage-2.3.2
Diffstat (limited to 'sci-libs/arprec')
-rw-r--r--sci-libs/arprec/Manifest1
-rw-r--r--sci-libs/arprec/arprec-2.2.18.ebuild73
-rw-r--r--sci-libs/arprec/files/arprec-2.2.18-fix-c++14.patch13
3 files changed, 87 insertions, 0 deletions
diff --git a/sci-libs/arprec/Manifest b/sci-libs/arprec/Manifest
index 87356081d5b7..d8c1a833ebd7 100644
--- a/sci-libs/arprec/Manifest
+++ b/sci-libs/arprec/Manifest
@@ -1,2 +1,3 @@
DIST arprec-2.2.16.tar.gz 830227 SHA256 cf71f2a7f3530b57900e67d1282c4a114830d2c00a0fba90819aa8313f11653f SHA512 278bf96402179566d4f2b9a6d69e42d726c81c814f96cd31c19df2c3b61941f3a1858e4a56577548d0fcf526b7db7caca2b7ea7ec57e834e7768d21788e7e672 WHIRLPOOL c55a875af752dfe6700cd714e2d6d34d3100676b8c41d4271065ddb0e754b3c5333cffd7432b45f2dfa0efed8f93dfd3448ac87038b18941a27f6bed1468131c
DIST arprec-2.2.17.tar.gz 900043 SHA256 87977981c1145465da51f252d04f11d16ee009d9dc7e8d0da71e4ef56b9fc5eb SHA512 d10f7d3e3d61274a36d253d2b50004bbf15447be3ffbd37bb0334ba62bd624e27fb9e26364fa1b89c1d4dfbb4136ab93d865f990ce123ecf94d9614e3ac567d1 WHIRLPOOL 6daeff384cfc9dfbb5771a177166212370ba724850d27ae99de63d1e2f2bc5f76b2be5c28e1fa0bb1d407a29d46212b0896c5e7f6ba66f9c2830e3a53e3e8b31
+DIST arprec-2.2.18.tar.gz 1751743 SHA256 12bcbaabbbd475bdcd0f4983bc280bd3888972ed32bcc8fe5f09fb94b7a85ed5 SHA512 372eb0a0c3aceac0d222679058f47c4d1037b5a51524b752b87f1b61c1b25101c34d4e56d9da45b4075ea7040dd59a597e0add4f34be902955dcf209423a6579 WHIRLPOOL 41322123ca1e444dfea5d678fb435dede56ba9704fdec04a0ae3d98766cad431b350652babaa431d579fe7e9e611b8d2e4c60d70c82d38e8699d33c103ef2ac1
diff --git a/sci-libs/arprec/arprec-2.2.18.ebuild b/sci-libs/arprec/arprec-2.2.18.ebuild
new file mode 100644
index 000000000000..ef5837cd07ba
--- /dev/null
+++ b/sci-libs/arprec/arprec-2.2.18.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+FORTRAN_NEEDED=fortran
+FORTRAN_STANDARD=90
+
+inherit fortran-2
+
+DESCRIPTION="Arbitrary precision float arithmetics and functions"
+HOMEPAGE="http://crd-legacy.lbl.gov/~dhbailey/mpdist/"
+SRC_URI="http://crd.lbl.gov/~dhbailey/mpdist/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cpu_flags_x86_fma3 cpu_flags_x86_fma4 doc fortran qd static-libs"
+
+DEPEND="qd? ( sci-libs/qd[fortran=] )"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.2.18-fix-c++14.patch )
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ $(use_enable cpu_flags_x86_fma$(usex cpu_flags_x86_fma3 3 4) fma) \
+ $(use_enable fortran) \
+ $(use_enable qd)
+}
+
+src_compile() {
+ default
+
+ if use fortran; then
+ emake toolkit
+ cd toolkit || die
+ ./mathinit || die "mathinit failed"
+ fi
+}
+
+src_install() {
+ default
+
+ if use fortran; then
+ cd toolkit || die
+
+ exeinto /usr/libexec/${PN}
+ doexe mathtool
+
+ insinto /usr/libexec/${PN}
+ doins *.dat
+
+ cat > mathtool.exe <<- _EOF_ || die
+ #!/usr/bin/env sh
+ cd "${EPREFIX}/usr/libexec/${PN}" && exec ./mathtool
+ _EOF_
+
+ newbin mathtool.exe mathtool
+ newdoc README README.mathtool
+ fi
+
+ if ! use doc; then
+ rm "${ED%/}"/usr/share/doc/${PF}/*.pdf || die
+ fi
+
+ if ! use static-libs; then
+ find "${D}" -name '*.la' -delete || die
+ fi
+}
diff --git a/sci-libs/arprec/files/arprec-2.2.18-fix-c++14.patch b/sci-libs/arprec/files/arprec-2.2.18-fix-c++14.patch
new file mode 100644
index 000000000000..680e921d6807
--- /dev/null
+++ b/sci-libs/arprec/files/arprec-2.2.18-fix-c++14.patch
@@ -0,0 +1,13 @@
+Fix compiling with C++14, due to changed operator T* -> operator bool semantics.
+See also: https://bugs.gentoo.org/show_bug.cgi?id=593872
+
+--- a/src/write.cpp
++++ b/src/write.cpp
+@@ -196,6 +196,6 @@
+
+ string str = to_string(precision, width, expn_width,
+ fmt, showpos, uppercase, fill);
+- return (s << str) != 0;
++ return static_cast<bool>(s << str);
+ }
+