summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-03-10 17:24:21 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-03-10 17:47:55 +0100
commitfd6844e50f31693178a7c41561f28bdcaea2b4ab (patch)
treeb488125a39c28ee43d7a1d511c16a1d97801e827 /sci-geosciences
parentapp-pda/libimobiledevice: Stabilize 1.3.0-r4 x86, #926697 (diff)
downloadgentoo-fd6844e50f31693178a7c41561f28bdcaea2b4ab.tar.gz
gentoo-fd6844e50f31693178a7c41561f28bdcaea2b4ab.tar.bz2
gentoo-fd6844e50f31693178a7c41561f28bdcaea2b4ab.zip
sci-geosciences/GeographicLib: add 2.3
python bindings are now distributed separately Closes: https://bugs.gentoo.org/851612 Closes: https://bugs.gentoo.org/923314 Closes: https://bugs.gentoo.org/910022 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/GeographicLib/GeographicLib-2.3.ebuild48
-rw-r--r--sci-geosciences/GeographicLib/Manifest1
-rw-r--r--sci-geosciences/GeographicLib/metadata.xml3
3 files changed, 51 insertions, 1 deletions
diff --git a/sci-geosciences/GeographicLib/GeographicLib-2.3.ebuild b/sci-geosciences/GeographicLib/GeographicLib-2.3.ebuild
new file mode 100644
index 000000000000..007b8af4fdfa
--- /dev/null
+++ b/sci-geosciences/GeographicLib/GeographicLib-2.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_PN="${PN,,}"
+
+DESCRIPTION="C++ library for converting geographic coordinate systems"
+HOMEPAGE="https://sourceforge.net/projects/geographiclib/ https://github.com/geographiclib/geographiclib"
+SRC_URI="mirror://sourceforge/${MY_PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/26"
+KEYWORDS="~amd64 ~arm"
+IUSE="doc"
+
+BDEPEND="
+ doc? (
+ >=app-text/doxygen-1.8.7
+ >=dev-lang/perl-5.26.1-r1
+ >=dev-python/sphinx-1.6.3-r2
+ >=sys-apps/util-linux-2.31
+ )
+"
+
+src_configure() {
+ export GEODATAPATH="/usr/share/${MY_PN}"
+
+ local mycmakeargs=(
+ -DBUILD_DOCUMENTATION=$(usex doc)
+ -DDOCDIR="${EPREFIX}/usr/share/doc/${PF}"
+ -DEXAMPLEDIR="${EPREFIX}/usr/share/doc/${PF}/examples"
+ -DBUILD_SHARED_LIBS=ON
+ -DGEOGRAPHICLIB_DATA="${GEODATAPATH}"
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ insinto "/usr/share/maxima/${MY_PN}"
+ doins -r maxima/.
+
+ find "${D}" -name "*.la" -delete || die
+}
diff --git a/sci-geosciences/GeographicLib/Manifest b/sci-geosciences/GeographicLib/Manifest
index fb8fd5f02107..d0412af95773 100644
--- a/sci-geosciences/GeographicLib/Manifest
+++ b/sci-geosciences/GeographicLib/Manifest
@@ -1 +1,2 @@
DIST GeographicLib-1.52.tar.gz 2432658 BLAKE2B 87328de1774ab9aec05355362c9a1760cf62864135b97a3e9cb1382b0ec9825b032f6c67a5e02b762c3009a3876a9cd995e3a49a3ad3c051dcd36446b55d0191 SHA512 98a4d33764db4a4755851a7db639fd9e055dcf4f1f949258e112fce2e198076b5896fcae2c1ea36b37fe1000d28eec326636a730e70f25bc19a1610423ba6859
+DIST GeographicLib-2.3.tar.gz 1701815 BLAKE2B 5695c5edd5b674f26f2fa21a835b155bca4c33177177750670fdf19f95ccb6d37eb13493b754820ccb22c5a05c8dc554da134eef37947a1d261d4ec6f6ebbcbe SHA512 1a1bd0fc2dc3e1372cf22618af3a4340bbc6497f94c64226c97654dfff92a4bf3acf47d91592741fe0c643d401d9721f680bdb4974b8ee258fb09d525fbaec67
diff --git a/sci-geosciences/GeographicLib/metadata.xml b/sci-geosciences/GeographicLib/metadata.xml
index e2f2a267068d..44742be323e4 100644
--- a/sci-geosciences/GeographicLib/metadata.xml
+++ b/sci-geosciences/GeographicLib/metadata.xml
@@ -10,9 +10,10 @@
<email>charles@karney.com</email>
<name>Charles Karney</name>
</maintainer>
- <doc lang="en">https://geographiclib.sourceforge.io/html</doc>
+ <doc lang="en">https://geographiclib.sourceforge.io/html/</doc>
<bugs-to>https://sourceforge.net/p/geographiclib/bugs/</bugs-to>
<remote-id type="sourceforge">geographiclib</remote-id>
+ <remote-id type="github">geographiclib/geographiclib</remote-id>
</upstream>
<longdescription lang="en">
GeographicLib is a small set of C++ classes for converting between geographic, UTM, UPS, MGRS, and geocentric coordinates, for gravity (e.g., EGM2008), geoid, and geomagnetic field (e.g., WMM2010) calculations, and for solving geodesic problems.