summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2021-08-04 20:10:33 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-08-04 21:47:52 +0200
commit601826271ce63e94525c4b6157c09dcc20692ae4 (patch)
tree2e846a54859c8755caa337df3fa9e2df95e1e8fd /sci-geosciences
parentdev-util/pkgconf: sync live ebuild (diff)
downloadgentoo-601826271ce63e94525c4b6157c09dcc20692ae4.tar.gz
gentoo-601826271ce63e94525c4b6157c09dcc20692ae4.tar.bz2
gentoo-601826271ce63e94525c4b6157c09dcc20692ae4.zip
sci-geosciences/josm-bin: version bump to 18118
Signed-off-by: Henning Schild <henning@hennsch.de> Closes: https://github.com/gentoo/gentoo/pull/21882 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/josm-bin/Manifest1
-rw-r--r--sci-geosciences/josm-bin/josm-bin-18118.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/sci-geosciences/josm-bin/Manifest b/sci-geosciences/josm-bin/Manifest
index 412f76fab014..d9ec897abb1a 100644
--- a/sci-geosciences/josm-bin/Manifest
+++ b/sci-geosciences/josm-bin/Manifest
@@ -1 +1,2 @@
DIST josm-snapshot-18004.jar 15839807 BLAKE2B 4eed4c47f9a9df0e4dcd98cbe6a00793dc87359c1adad4a03a12e7b9207e5519c7570e1d3c3ba49464adf8fc191a0dc33acdf7c39a5db1c001b044ebf2ed0ce7 SHA512 9b66a4e6327008e24550464bc76c710ce0a99c39fb4fd83d99705f292b5d11203b96411eebb02c9ba8bb1dc28252a26787b5d83cc4f87cd89fc6294a3b8627c4
+DIST josm-snapshot-18118.jar 16005374 BLAKE2B 1b8d0b31adfaca4f0435719bac7258fe43bf78d078ce9cd46aa5e44bf7e4e69325f8675eede6f56ea0305bad57102bf5565a5ef38ca1b29b5f3e1fa889aceba5 SHA512 18e5f06c7eb52004617df23efaef85bf784d36b301cbc78b967a5ed91b684c9bc664424282b06278a109e88e2f72424c0b89fe447a06c7bb1a00edc12c1372a4
diff --git a/sci-geosciences/josm-bin/josm-bin-18118.ebuild b/sci-geosciences/josm-bin/josm-bin-18118.ebuild
new file mode 100644
index 000000000000..3d54799f8cdc
--- /dev/null
+++ b/sci-geosciences/josm-bin/josm-bin-18118.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop java-utils-2 xdg
+
+DESCRIPTION="Java-based editor for the OpenStreetMap project"
+HOMEPAGE="https://josm.openstreetmap.de/"
+SRC_URI="https://josm.openstreetmap.de/download/josm-snapshot-${PV}.jar"
+S="${WORKDIR}"
+
+LICENSE="Apache-2.0 GPL-2+ GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.8"
+
+src_install() {
+ java-pkg_newjar "${DISTDIR}/${A}" ${PN}.jar
+ java-pkg_dolauncher ${PN} --jar ${PN}.jar
+
+ local icon_size
+ for icon_size in 16 32 48; do
+ newicon -s ${icon_size} -t hicolor \
+ images/logo_${icon_size}x${icon_size}x32.png ${PN}.png
+ newicon -s ${icon_size} -t locolor \
+ images/logo_${icon_size}x${icon_size}x8.png ${PN}.png
+ done
+ make_desktop_entry ${PN} "Java OpenStreetMap Editor" ${PN} "Utility;Science;Geoscience"
+}