summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-geosciences/gmapcatcher
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-geosciences/gmapcatcher')
-rw-r--r--sci-geosciences/gmapcatcher/Manifest1
-rw-r--r--sci-geosciences/gmapcatcher/files/gmapcatcher-0.8.0.4-setuppy-docs.patch14
-rw-r--r--sci-geosciences/gmapcatcher/gmapcatcher-0.8.0.4.ebuild32
-rw-r--r--sci-geosciences/gmapcatcher/metadata.xml16
4 files changed, 63 insertions, 0 deletions
diff --git a/sci-geosciences/gmapcatcher/Manifest b/sci-geosciences/gmapcatcher/Manifest
new file mode 100644
index 000000000000..d55466b775ac
--- /dev/null
+++ b/sci-geosciences/gmapcatcher/Manifest
@@ -0,0 +1 @@
+DIST mapcatcher_0.8.0.4.tar.gz 441925 SHA256 9cc969e9c4fb7fe42e7afb33b5bf60a868c626e2ec957d3003daeecdaa1dae76 SHA512 9612df238fe2c723d4668a4587fbc2028b4c83e2d6372de4f03bf696a3900114a1b08352910c3ab2dc304eb694d2a5469441fbb35d9325750298c0cb02e40734 WHIRLPOOL 9bf330218c136a6d196ff7620e5983640114ecbbf98a611a1c19abe7faf93b1ee13fea0f09e7298f41c65ed08d79acab6e5aa95d11419a9c46e0524296a34839
diff --git a/sci-geosciences/gmapcatcher/files/gmapcatcher-0.8.0.4-setuppy-docs.patch b/sci-geosciences/gmapcatcher/files/gmapcatcher-0.8.0.4-setuppy-docs.patch
new file mode 100644
index 000000000000..35efed02a322
--- /dev/null
+++ b/sci-geosciences/gmapcatcher/files/gmapcatcher-0.8.0.4-setuppy-docs.patch
@@ -0,0 +1,14 @@
+Drop docs from setup.py, distutils-r1 takes care of it.
+
+--- setup.py.orig 2013-07-25 03:24:35.987668173 +0200
++++ setup.py 2013-07-25 03:24:51.770668448 +0200
+@@ -13,8 +13,7 @@
+ description = 'Offline Map Viewer',
+ version = VERSION,
+ url = WEB_ADDRESS,
+- data_files = [('share/doc/mapcatcher', ['README', 'changelog']),
+- ('share/applications', ['gmapcatcher.desktop']),
++ data_files = [('share/applications', ['gmapcatcher.desktop']),
+ ('share/man/man1',
+ ['man/mapcatcher.1.gz', 'man/mapdownloader.1.gz']),
+ ('share/pixmaps', ['images/mapcatcher.png']),
diff --git a/sci-geosciences/gmapcatcher/gmapcatcher-0.8.0.4.ebuild b/sci-geosciences/gmapcatcher/gmapcatcher-0.8.0.4.ebuild
new file mode 100644
index 000000000000..a5bb7e97c83c
--- /dev/null
+++ b/sci-geosciences/gmapcatcher/gmapcatcher-0.8.0.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1
+
+DESCRIPTION="An offline viewer for different map providers"
+HOMEPAGE="http://code.google.com/p/gmapcatcher/"
+SRC_URI="http://gmapcatcher.googlecode.com/files/mapcatcher_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ dev-python/pygtk[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/mapcatcher-${PV}
+PATCHES=("${FILESDIR}"/${P}-setuppy-docs.patch)
+
+src_prepare() {
+ sed -i -e "/Version=/d" -e "s/Application;//" gmapcatcher.desktop || die
+ distutils-r1_src_prepare
+}
diff --git a/sci-geosciences/gmapcatcher/metadata.xml b/sci-geosciences/gmapcatcher/metadata.xml
new file mode 100644
index 000000000000..1168f85ccde5
--- /dev/null
+++ b/sci-geosciences/gmapcatcher/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>god@politeia.in</email>
+ <name>Denis M.</name>
+ <description>Maintainer, assign bugs to him</description>
+ </maintainer>
+ <maintainer>
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ <description>Proxy-Maintainer, CC him on bugs</description>
+ </maintainer>
+</pkgmetadata>
+