summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-09-28 22:43:31 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-28 23:02:01 +0200
commitbf945baafb407fb516c304759df3e68fab26ce6e (patch)
tree636d488438d2dd53b869380d93e94ee5e9498878 /sci-electronics/freehdl/freehdl-0.0.8.ebuild
parentnet-misc/x2goclient: version bump to 0.4.5.2, add qt5 support (diff)
downloadgentoo-bf945baafb407fb516c304759df3e68fab26ce6e.tar.gz
gentoo-bf945baafb407fb516c304759df3e68fab26ce6e.tar.bz2
gentoo-bf945baafb407fb516c304759df3e68fab26ce6e.zip
sci-electronics/freehdl: Version bump to 0.0.8
Gentoo-bug: 594706 * EAPI=6 * [QA] fix printf format specifiers * [QA] fix assigning C-string literals to 'char*' * Remove .la files unconditionally * Disable building and installing of static libs Package-Manager: portage-2.3.1
Diffstat (limited to 'sci-electronics/freehdl/freehdl-0.0.8.ebuild')
-rw-r--r--sci-electronics/freehdl/freehdl-0.0.8.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-electronics/freehdl/freehdl-0.0.8.ebuild b/sci-electronics/freehdl/freehdl-0.0.8.ebuild
new file mode 100644
index 000000000000..c11e4d948e94
--- /dev/null
+++ b/sci-electronics/freehdl/freehdl-0.0.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="A free VHDL simulator"
+SRC_URI="mirror://sourceforge/qucs/${P}.tar.gz"
+HOMEPAGE="http://freehdl.seul.org/"
+LICENSE="GPL-2"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND=">=dev-scheme/guile-2.0:*"
+DEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.0.8-fix-c++14.patch"
+ "${FILESDIR}/${PN}-0.0.8-qa.patch"
+)
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+
+ # package provides .pc files
+ find "${D}" -name '*.la' -delete || die
+}