summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2021-03-19 13:34:40 -0600
committerChristoph Junghans <junghans@gentoo.org>2021-03-19 13:45:52 -0600
commitbd12ec48914fc73b18318814294bdde5c2253358 (patch)
treebf4a1c22e4dd85d8a5d906e676a2ddb50211cbd2 /sci-chemistry
parentdev-vcs/git: stable 2.26.3 for sparc, bug #774678 (diff)
downloadgentoo-bd12ec48914fc73b18318814294bdde5c2253358.tar.gz
gentoo-bd12ec48914fc73b18318814294bdde5c2253358.tar.bz2
gentoo-bd12ec48914fc73b18318814294bdde5c2253358.zip
sci-chemistry/votca-xtp: live ebuild updates
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Christoph Junghans <junghans@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/votca-xtp/votca-xtp-9999.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/sci-chemistry/votca-xtp/votca-xtp-9999.ebuild b/sci-chemistry/votca-xtp/votca-xtp-9999.ebuild
index d9f436b0316c..e4c0b6c8a536 100644
--- a/sci-chemistry/votca-xtp/votca-xtp-9999.ebuild
+++ b/sci-chemistry/votca-xtp/votca-xtp-9999.ebuild
@@ -19,19 +19,28 @@ HOMEPAGE="https://www.votca.org/"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE=""
+IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="
>=dev-cpp/eigen-3.3
~sci-chemistry/votca-csg-${PV}
sci-libs/hdf5[cxx]
+ sci-libs/libecpint
sci-libs/libxc
~sci-libs/votca-tools-${PV}
"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
-DOCS=( README.md NOTICE CHANGELOG.md )
+DOCS=( README.rst NOTICE.rst CHANGELOG.rst )
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_TESTING=$(usex test)
+ )
+ cmake_src_configure
+}
pkg_postinst() {
einfo