summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-09-17 16:25:59 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-17 19:43:55 +0200
commit2ea5b5d982ed56fcfa17d5c06c9f5a34fbaba727 (patch)
tree9739bad2ffa26636d01f3f6f53ee727f75c0fe0b /sci-chemistry/gelemental
parentmedia-sound/pamix: Added sys-devel/autoconf-archive to DEPEND (bug #593682). (diff)
downloadgentoo-2ea5b5d982ed56fcfa17d5c06c9f5a34fbaba727.tar.gz
gentoo-2ea5b5d982ed56fcfa17d5c06c9f5a34fbaba727.tar.bz2
gentoo-2ea5b5d982ed56fcfa17d5c06c9f5a34fbaba727.zip
sci-chemistry/gelemental: Allow for compiling with GCC 6
Gentoo-bug: 593994 Package-Manager: portage-2.3.0
Diffstat (limited to 'sci-chemistry/gelemental')
-rw-r--r--sci-chemistry/gelemental/files/gelemental-1.2.0-fix-c++14.patch14
-rw-r--r--sci-chemistry/gelemental/gelemental-1.2.0-r1.ebuild3
2 files changed, 16 insertions, 1 deletions
diff --git a/sci-chemistry/gelemental/files/gelemental-1.2.0-fix-c++14.patch b/sci-chemistry/gelemental/files/gelemental-1.2.0-fix-c++14.patch
new file mode 100644
index 000000000000..0965fe15b43e
--- /dev/null
+++ b/sci-chemistry/gelemental/files/gelemental-1.2.0-fix-c++14.patch
@@ -0,0 +1,14 @@
+Fix building with C++14, which errors out due to bool -> T* conversions
+See also: https://bugs.gentoo.org/show_bug.cgi?id=593994
+
+--- a/src/dialogs.cc
++++ b/src/dialogs.cc
+@@ -255,7 +255,7 @@
+ const Gtk::TreePath& tpath, bool)
+ {
+ Gtk::TreeIter iter = store->get_iter (tpath);
+- return iter ? iter->get_value (cols.property) : false;
++ return iter ? iter->get_value (cols.property) : NULL;
+ }
+
+
diff --git a/sci-chemistry/gelemental/gelemental-1.2.0-r1.ebuild b/sci-chemistry/gelemental/gelemental-1.2.0-r1.ebuild
index e85ddb0478b3..43e2cb8cb57d 100644
--- a/sci-chemistry/gelemental/gelemental-1.2.0-r1.ebuild
+++ b/sci-chemistry/gelemental/gelemental-1.2.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -40,6 +40,7 @@ PATCHES=(
"${WORKDIR}"/debian/patches/fix_zinc_german_translation.patch
"${WORKDIR}"/debian/patches/ftbfs_missing_limits.patch
"${WORKDIR}"/debian/patches/lp673285_link_in_about.patch
+ "${FILESDIR}"/${PN}-1.2.0-fix-c++14.patch
)
AUTOTOOLS_IN_SOURCE_BUILD=1