summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-02-25 21:18:05 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-25 21:35:08 +0100
commitb4e55ca62c37097321fa10649161d8718b15bdca (patch)
tree22916d4d96e21f0c17546fef8a4ab6da94a5cb05 /sci-biology/trf/trf-4.04-r1.ebuild
parentUpdate outdated copyright headers. (diff)
downloadgentoo-b4e55ca62c37097321fa10649161d8718b15bdca.tar.gz
gentoo-b4e55ca62c37097321fa10649161d8718b15bdca.tar.bz2
gentoo-b4e55ca62c37097321fa10649161d8718b15bdca.zip
sci-biology/trf: Modernise to EAPI 6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-biology/trf/trf-4.04-r1.ebuild')
-rw-r--r--sci-biology/trf/trf-4.04-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-biology/trf/trf-4.04-r1.ebuild b/sci-biology/trf/trf-4.04-r1.ebuild
new file mode 100644
index 000000000000..6ea8e1e0f24c
--- /dev/null
+++ b/sci-biology/trf/trf-4.04-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_P="${PN}404"
+
+DESCRIPTION="Tandem Repeats Finder"
+HOMEPAGE="http://tandem.bu.edu/trf/trf.html"
+SRC_URI="http://tandem.bu.edu/trf/downloads/${MY_P}.linux"
+
+LICENSE="trf" # http://tandem.bu.edu/trf/trf.license.html
+SLOT="0"
+KEYWORDS="amd64 x86"
+RESTRICT="mirror bindist"
+
+S=${WORKDIR}
+
+QA_PREBUILT="opt/${PN}/.*"
+
+src_unpack() {
+ cp "${DISTDIR}/${MY_P}.linux" "${S}/${MY_P}.linux.exe" || die
+}
+
+src_install() {
+ exeinto /opt/${PN}
+ doexe trf404.linux.exe
+ dosym /opt/${PN}/${MY_P}.linux.exe /opt/bin/trf
+}