summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-02-25 16:16:26 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-25 16:23:58 +0100
commitee8afc8624d23ec0bd41a5b63ca03ab40973af00 (patch)
tree18fb37b1e77d9f97c143a22e9b54305843e1ce25 /sci-biology/clustalw/clustalw-1.83-r4.ebuild
parentsci-biology/clustalw: Modernise to EAPI 6 (diff)
downloadgentoo-ee8afc8624d23ec0bd41a5b63ca03ab40973af00.tar.gz
gentoo-ee8afc8624d23ec0bd41a5b63ca03ab40973af00.tar.bz2
gentoo-ee8afc8624d23ec0bd41a5b63ca03ab40973af00.zip
sci-biology/clustalw: Modernise to EAPI 6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-biology/clustalw/clustalw-1.83-r4.ebuild')
-rw-r--r--sci-biology/clustalw/clustalw-1.83-r4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-biology/clustalw/clustalw-1.83-r4.ebuild b/sci-biology/clustalw/clustalw-1.83-r4.ebuild
new file mode 100644
index 000000000000..bf6e6a9c28c3
--- /dev/null
+++ b/sci-biology/clustalw/clustalw-1.83-r4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="General purpose multiple alignment program for DNA and proteins"
+HOMEPAGE="http://www.embl-heidelberg.de/~seqanal/"
+SRC_URI="ftp://ftp.ebi.ac.uk/pub/software/unix/clustalw/${PN}${PV}.UNIX.tar.gz"
+
+LICENSE="clustalw"
+SLOT="1"
+KEYWORDS="alpha amd64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE=""
+
+S="${WORKDIR}"/${PN}${PV}
+
+PATCHES=( "${FILESDIR}"/${PV}-as-needed.patch )
+
+src_prepare() {
+ default
+
+ sed \
+ -e "/^CC/s:cc:$(tc-getCC):g" \
+ -i makefile || die
+ sed \
+ -e "s%clustalw_help%/usr/share/doc/${PF}/clustalw_help%" \
+ -i clustalw.c || die
+}
+
+src_install() {
+ dobin clustalw
+ dodoc README clustalv.doc clustalw{.doc,.ms,_help}
+}