summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/augustus
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/augustus')
-rw-r--r--sci-biology/augustus/Manifest1
-rw-r--r--sci-biology/augustus/augustus-2.5.5.ebuild50
-rw-r--r--sci-biology/augustus/files/augustus-2.5.5-sane-build.patch156
-rw-r--r--sci-biology/augustus/metadata.xml5
4 files changed, 212 insertions, 0 deletions
diff --git a/sci-biology/augustus/Manifest b/sci-biology/augustus/Manifest
new file mode 100644
index 000000000000..cdfb577937e0
--- /dev/null
+++ b/sci-biology/augustus/Manifest
@@ -0,0 +1 @@
+DIST augustus.2.5.5.tar.gz 70826249 SHA256 2bd97784fa651addf836e2100a7d4106b43e50fe06f13c664001d4625d0eab9a SHA512 33eb05d5c90200d2fc17026743d3a25e73aa3e217b8546f0bed4c94bcb460597d853377a67896e52e45ead5d736d13ed3b2c91b31fed8216da2920c825e8c20f WHIRLPOOL 875f56f10251767fb066b5e21b0c2361c952d5cc44daa811658be8119957ffa34fd4552fde7e17384d5bc916aee5ef91982ded3999d0077cf3834d5fc20e7f1a
diff --git a/sci-biology/augustus/augustus-2.5.5.ebuild b/sci-biology/augustus/augustus-2.5.5.ebuild
new file mode 100644
index 000000000000..e58be6db6d6a
--- /dev/null
+++ b/sci-biology/augustus/augustus-2.5.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Eukaryotic gene predictor"
+HOMEPAGE="http://augustus.gobics.de/"
+SRC_URI="http://augustus.gobics.de/binaries/${PN}.${PV}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="examples"
+
+S="${WORKDIR}/${PN}.${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-sane-build.patch
+ tc-export CC CXX
+}
+
+src_compile() {
+ emake clean && emake
+}
+
+src_install() {
+ dobin bin/*
+# dobin src/{augustus,etraining,consensusFinder,curve2hints,fastBlockSearch,prepareAlign}
+
+ exeinto /usr/libexec/${PN}
+ doexe scripts/*.p*
+ insinto /usr/libexec/${PN}
+ doins scripts/*.conf
+
+ insinto /usr/share/${PN}
+ doins -r config
+
+ echo "AUGUSTUS_CONFIG_PATH=\"/usr/share/${PN}/config\"" > "${S}/99${PN}"
+ doenvd "${S}/99${PN}"
+
+ dodoc -r README.TXT HISTORY.TXT docs/*.{pdf,txt}
+
+ if use examples; then
+ insinto /usr/share/${PN}/
+ doins -r docs/tutorial examples
+ fi
+}
diff --git a/sci-biology/augustus/files/augustus-2.5.5-sane-build.patch b/sci-biology/augustus/files/augustus-2.5.5-sane-build.patch
new file mode 100644
index 000000000000..39cd0762b1c1
--- /dev/null
+++ b/sci-biology/augustus/files/augustus-2.5.5-sane-build.patch
@@ -0,0 +1,156 @@
+ Makefile | 8 +++---
+ scripts/Makefile | 6 +++-
+ scripts/aln2wig/Makefile | 8 +++---
+ scripts/compileSpliceCands/Makefile | 6 ++--
+ src/Makefile | 43 ++++++++++++++++++----------------
+ 5 files changed, 38 insertions(+), 33 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index e23a667..64610c8 100644
+--- a/Makefile
++++ b/Makefile
+@@ -3,9 +3,9 @@
+ #
+
+ all:
+- cd src && ${MAKE}
+- cd scripts && ${MAKE}
++ $(MAKE) -C src
++ $(MAKE) -C scripts
+
+ clean:
+- cd src && ${MAKE} clean
+- cd scripts && ${MAKE} clean
++ $(MAKE) -C src clean
++ $(MAKE) -C scripts clean
+diff --git a/scripts/Makefile b/scripts/Makefile
+index 6d4dd67..ab6a885 100644
+--- a/scripts/Makefile
++++ b/scripts/Makefile
+@@ -1,5 +1,7 @@
+ all :
+- cd aln2wig && ${MAKE}
++ $(MAKE) -C aln2wig
++ $(MAKE) -C compileSpliceCands
+
+ clean :
+- cd aln2wig && ${MAKE} clean
++ $(MAKE) -C aln2wig clean
++ $(MAKE) -C compileSpliceCands
+diff --git a/scripts/aln2wig/Makefile b/scripts/aln2wig/Makefile
+index 64d09f5..9752980 100644
+--- a/scripts/aln2wig/Makefile
++++ b/scripts/aln2wig/Makefile
+@@ -1,10 +1,10 @@
+-CFLAGS := -Wall -Wno-unused-result -Wno-sign-compare -ansi -pedantic -O2 -ggdb
++CFLAGS += -Wall -Wno-unused-result -Wno-sign-compare -ansi -pedantic
+
+ psl2wig : aln2wig.o
+- gcc $(CFLAGS) -o aln2wig aln2wig.o;
+- cp aln2wig ../../bin
++ $(CC) $(CFLAGS) $(LDFLAGS) -o aln2wig aln2wig.o;
++ cp aln2wig ../../bin/
+ psl2wig.o : aln2wig.c
+- gcc $(CFLAGS) -c aln2wig.c
++ $(CC) $(CFLAGS) -c aln2wig.c
+
+ all : psl2wig
+
+diff --git a/scripts/compileSpliceCands/Makefile b/scripts/compileSpliceCands/Makefile
+index cddada5..8079791 100644
+--- a/scripts/compileSpliceCands/Makefile
++++ b/scripts/compileSpliceCands/Makefile
+@@ -1,8 +1,8 @@
+ compileSpliceCands : compileSpliceCands.o list.h list.o
+- gcc -o compileSpliceCands compileSpliceCands.o list.o;
+-# cp compileSpliceCands ../../bin
++ $(CC) $(CFLAGS) $(LDFLAGS) -o compileSpliceCands compileSpliceCands.o list.o;
++ cp compileSpliceCands ../../bin/
+ compileSpliceCands.o : compileSpliceCands.c
+- gcc -Wall -pedantic -ansi -c compileSpliceCands.c
++ $(CC) $(CFLAGS) -Wall -pedantic -ansi -c compileSpliceCands.c
+
+ all : compileSpliceCands
+
+diff --git a/src/Makefile b/src/Makefile
+index 71795b6..732b953 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -6,8 +6,8 @@
+ # a strict signed-only usage strategy to avoid mistakes since we are not warned about this.
+ # - In the current version, the order of object files in $(OBJS) IS IMPORTANT (see lldouble.hh)
+ #
+-CC = g++
+-CFLAGS := -Wall -Wno-sign-compare -ansi -pedantic -O2 ${CFLAGS} -static # -pg -DDEBUG -g -ggdb -static
++CXX ?= g++
++CXXFLAGS += -Wall -Wno-sign-compare -ansi -pedantic # -pg -DDEBUG -g -ggdb -static
+ INCLS = -I../include -I.
+ LIBS = # -lcwd
+ OBJS = genbank.o properties.o pp_profile.o pp_hitseq.o pp_scoring.o statemodel.o namgene.o \
+@@ -18,45 +18,48 @@ TOBJS = commontrain.o igenictrain.o introntrain.o exontrain.o utrtrain.o # conte
+ PROGR = augustus etraining consensusFinder curve2hints fastBlockSearch prepareAlign
+ INFO = cflags
+
+-all: $(OBJS) $(TOBJS) $(DUMOBJS) $(PROGR) info
++all: $(OBJS) $(TOBJS) $(DUMOBJS) $(PROGR) info bin
+
+ .SUFFIXES:
+ .SUFFIXES: .cc .o .so
+
+ .cc.o:
+- $(CC) -c $(CFLAGS) -o $@ $< $(INCLS)
++ $(CXX) -c $(CXXFLAGS) -o $@ $< $(INCLS)
+
+-augustus: augustus.cc $(OBJS) $(DUMOBJS)
+- $(CC) $(CFLAGS) -o $@ $^ $(INCLS) $(LIBS)
++bin: $(PROGR)
++ cp $(PROGR) ../bin/
++
++augustus: augustus.o $(OBJS) $(DUMOBJS)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $^ $(INCLS) $(LIBS)
+ cp augustus ../bin/
+
+-etraining: etraining.cc $(TOBJS) $(OBJS)
+- $(CC) $(CFLAGS) -o $@ $^ $(INCLS) $(LIBS)
++etraining: etraining.o $(TOBJS) $(OBJS)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $^ $(INCLS) $(LIBS)
+ cp etraining ../bin/
+
+-evaluate: evaluate.cc $(OBJS) $(DUMOBJS)
+- $(CC) $(CFLAGS) -o $@ $^ $(INCLS) $(LIBS)
++evaluate: evaluate.o $(OBJS) $(DUMOBJS)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $^ $(INCLS) $(LIBS)
+
+-consensusFinder: consensusFinder.cc consensus.o
+- $(CC) $(CFLAGS) -o $@ $^ $(INCLS) $(LIBS)
++consensusFinder: consensusFinder.o consensus.o
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $^ $(INCLS) $(LIBS)
+
+-curve2hints: curve2hints.cc exon_seg.o
+- $(CC) $(CFLAGS) -o $@ $^ $(INCLS) $(LIBS)
++curve2hints: curve2hints.o exon_seg.o
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $^ $(INCLS) $(LIBS)
+
+-fastBlockSearch: fastBlockSearch.cc pp_fastBlockSearcher.o \
++fastBlockSearch: fastBlockSearch.o pp_fastBlockSearcher.o \
+ types.o properties.o geneticcode.o pp_profile.o lldouble.o
+- $(CC) $(CFLAGS) -o $@ $^ $(INCLS) $(LIBS)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $^ $(INCLS) $(LIBS)
+ cp fastBlockSearch ../bin/
+
+-prepareAlign: pp_prepare_align.cc
+- $(CC) $(CFLAGS) -o $@ $^
++prepareAlign: pp_prepare_align.o
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $^
+ cp prepareAlign ../bin/
+
+ info:
+- echo "$(CFLAGS)" > $(INFO)
++ echo "$(CXXFLAGS)" > $(INFO)
+
+ clean:
+- rm -f $(PROGR) $(OBJS) $(DUMOBJS) $(TOBJS) consensus.o exon_seg.o pp_fastBlockSearcher.o $(INFO)
++ rm -f $(PROGR) $(OBJS) $(DUMOBJS) $(TOBJS) consensus.o exon_seg.o pp_fastBlockSearcher.o $(INFO) ../bin/*
+
+ tidy: clean
+ rm -f *~ *.o *.rej *.orig ../include/*~ ../include/*.orig ../include/*.rej $(INFO)
diff --git a/sci-biology/augustus/metadata.xml b/sci-biology/augustus/metadata.xml
new file mode 100644
index 000000000000..f17a827e3101
--- /dev/null
+++ b/sci-biology/augustus/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+</pkgmetadata>