summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-08-04 20:34:11 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-08-04 20:34:11 +0300
commit2f312c8ac535978d117c6111c29fddb772a5219a (patch)
tree4a336092e5f2275237bd7ee42026323bd3e90559 /sci-astronomy
parentdev-lang/nasm: drop IUSE="lto" (diff)
downloadgentoo-2f312c8ac535978d117c6111c29fddb772a5219a.tar.gz
gentoo-2f312c8ac535978d117c6111c29fddb772a5219a.tar.bz2
gentoo-2f312c8ac535978d117c6111c29fddb772a5219a.zip
sci-astronomy/esomidas: treeclean
Closes: https://bugs.gentoo.org/935545 (pkgremoved) Closes: https://bugs.gentoo.org/682338 (pkgremoved) Closes: https://bugs.gentoo.org/727978 (pkgremoved) Closes: https://bugs.gentoo.org/731752 (pkgremoved) Closes: https://bugs.gentoo.org/771855 (pkgremoved) Closes: https://bugs.gentoo.org/877841 (pkgremoved) Closes: https://bugs.gentoo.org/880611 (pkgremoved) Closes: https://bugs.gentoo.org/898102 (pkgremoved) Closes: https://bugs.gentoo.org/919217 (pkgremoved) Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/esomidas/Manifest1
-rw-r--r--sci-astronomy/esomidas/esomidas-17.02-r1.ebuild151
-rw-r--r--sci-astronomy/esomidas/files/esomidas-17.02-gentoo-setup.patch12
-rw-r--r--sci-astronomy/esomidas/files/esomidas-17.02-output_to_stdout.patch42
-rw-r--r--sci-astronomy/esomidas/files/esomidas-17.02-rpc.patch33
-rw-r--r--sci-astronomy/esomidas/metadata.xml19
6 files changed, 0 insertions, 258 deletions
diff --git a/sci-astronomy/esomidas/Manifest b/sci-astronomy/esomidas/Manifest
deleted file mode 100644
index ef15dd6a4e32..000000000000
--- a/sci-astronomy/esomidas/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST esomidas-17.02.tar.gz 60771186 BLAKE2B 75e184d61ab2ec9eb30ea83c35feea329bd4dec9afa04b68bc7be22ef0f88d1d0aa0e4a79c1111ce57846e042b26ef394374c9db2d12547dfa481d75e06deadf SHA512 7e4c6a8d8349a9e1647e48571bf5e04abd239c24020ffdf5984a0598b837061ca7765e31209869a4e302e1f85c3494852a22541149c10cc916376048e40b6324
diff --git a/sci-astronomy/esomidas/esomidas-17.02-r1.ebuild b/sci-astronomy/esomidas/esomidas-17.02-r1.ebuild
deleted file mode 100644
index e39f3110cc14..000000000000
--- a/sci-astronomy/esomidas/esomidas-17.02-r1.ebuild
+++ /dev/null
@@ -1,151 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit fortran-2 toolchain-funcs flag-o-matic
-
-# MIDVERS is actually used by MIDAS configuration scripts
-export MIDVERS="17FEBpl1.2"
-
-DESCRIPTION="European Southern Observatory Munich Image Data Analysis System"
-HOMEPAGE="http://www.eso.org/projects/esomidas/"
-SRC_URI="ftp://ftp.eso.org/pub/midaspub/17FEB/sources/${MIDVERS}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0/8"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="+libtirpc"
-
-RDEPEND="
- sys-libs/readline:0=
- x11-libs/motif:0=
- x11-libs/libX11:=
- x11-libs/libXt:=
- !libtirpc? ( sys-libs/glibc[rpc(-)] )
- libtirpc? ( net-libs/libtirpc )
-"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MIDVERS}"
-
-PATCHES=(
- "${FILESDIR}/${P}-output_to_stdout.patch"
- "${FILESDIR}/${P}-gentoo-setup.patch"
- "${FILESDIR}/${P}-rpc.patch"
-)
-
-src_prepare() {
- default
- # variables for all phases and midas internal build system
- export MIDASHOME="${WORKDIR}"
- export MID_HOME="${S}"
- export MID_HOME0="/usr/$(get_libdir)/esomidas/${MIDVERS}"
- export MID_INSTALL="${MID_HOME}/install/unix"
- export MID_SYS="${MID_HOME}/system/unix/"
- export MID_WORK="${MIDASHOME}/midwork"
-
- # sadly this enforces static linking
- if use libtirpc ; then
- RPC_OPT="-I/usr/include/tirpc"
- RPC_LIB="-ltirpc"
- else
- RPC_OPT=""
- RPC_LIB=""
- fi
-
- # create a gentoo option file
- mkdir ${MID_INSTALL}/systems/Gentoo || die
- cat >> ${MID_INSTALL}/systems/Gentoo/make_options <<-EOF
- CC=$(tc-getCC)
- LDCC=$(tc-getCC)
- F77=$(tc-getFC)
- FC=$(tc-getFC)
- LD77_CMD=$(tc-getFC)
- AR=$(tc-getAR)
- RANLIB=$(tc-getRANLIB)
- F_OPT=
- C_OPT=
- E_OPT=$(use amd64 && echo -Z)
- SYS=
- SH_OPT=-fPIC
- SH_CMD=${MIDASHOME}/${MIDVERS}/local/make_shared
- GUI_OPT=-DPATH_MAX=1024
- STRIP=echo
- EDITFLAGS=-DVOID_SIGHANDLER -DHAVE_ALLOCA -DHAVE_ALLOCA_H -DHAVE_GETPW_DECLS -DHAVE_DIRENT_H -DHAVE_STRING_H -DLinux -DHAVE_UNISTD_H -DHAVE_STDLIB_H
- EDITLIBS=-lreadline
- UIMX=uimxR5
- INSTALL_FLAG=auto
- RPC_OPT=${RPC_OPT}
- RPC_LIB=${RPC_LIB}
- EOF
- sed -e "s|gcc|$(tc-getCC) \${LDFLAGS}|" \
- ${MID_INSTALL}/systems/Linux/make_shared \
- > ${MID_INSTALL}/systems/Gentoo/make_shared || die
- sed -e 's|PC/Linux|Gentoo|' \
- ${MID_INSTALL}/systems/Linux/setup \
- > ${MID_INSTALL}/systems/Gentoo/setup || die
-
- # gentoo readline avoids exporting the xmalloc,xrealloc and xfree
- append-cppflags -Dxrealloc=_rl_realloc -Dxmalloc=_rl_malloc -Dxfree=_rl_free
-}
-
-src_configure() {
- ${MID_INSTALL}/select all || die "packages selection failed"
- ${MID_INSTALL}/preinstall -a || die "preinstallation failed"
- ${MID_INSTALL}/install2 || die "configuration failed"
- chmod 755 ${MID_HOME}/local/make_shared
- append-fflags -fallow-argument-mismatch
- append-cflags -fcommon
-}
-
-src_compile() {
- CMND_YES=2 ${MID_INSTALL}/install3 -a || die "compilation failed"
- [[ -x ${MID_HOME}/monit/midasgo.exe ]] || die "somewhere compilation failed"
- emake -C monit syskeys.unix
- ${MID_SYS}/inmidas -m ${MID_WORK} -j "@ compile.all"
- ${MID_SYS}/inmidas -m ${MID_WORK} -j "@ ascii_bin no ; bye"
-}
-
-src_test() {
- local test_dir="${WORKDIR}/test_tmp"
- mkdir ${test_dir} && cd ${test_dir}
- ${MID_SYS}/inmidas -m ${MID_WORK} -j "@ vericopy ; @@ veriall -nodisplay ; bye" || die
- test -f ${MID_WORK}/veriall_* || die "tests failed somewhere"
- rm -rf ${test_dir}
-}
-
-src_install() {
- yes | ${MID_SYS}/cleanmidas
- find ${MID_HOME} \( \
- -name "*.a" -o \
- -name "makefile" -o \
- -name "default.mk" -o \
- -name "*.h" -o \
- -name "*.inc" -o \
- -name COPYING -o \
- -name "*~" -o \
- -name "*.mod" \) -delete
- rm -rf ${MID_HOME}/libsrc/ftoc*
- find ${MID_HOME} -type d -empty -delete
-
- sed -e "s:^MIDVERS0=.*:MIDVERS0=${MIDVERS}:" \
- -e "s:^MIDASHOME0=.*:MIDASHOME0=/usr/$(get_libdir)/esomidas:" \
- -i ${MID_HOME}/system/unix/{inmidas,helpmidas,drs}
-
- cd "${WORKDIR}"
- dodir /usr/$(get_libdir)/esomidas
- mv "${S}" "${ED}"${MID_HOME0}
- chmod 0644 "${ED}"${MID_HOME0}/contrib/baches/*/*.fit \
- "${ED}"${MID_HOME0}/contrib/baches/*/*.fmt \
- "${ED}"${MID_HOME0}/contrib/baches/*/*.datorg \
- "${ED}"${MID_HOME0}/contrib/baches/*/*.prg \
- "${ED}"${MID_HOME0}/contrib/baches/*/*.README
- find "${ED}"${MID_HOME0} -name \*.sh | xargs chmod 0755
- chmod 0755 "${ED}"${MID_HOME0}/util/bench/brun
-
- dosym ${MID_HOME0}/system/unix/inmidas /usr/bin/inmidas
- dosym ${MID_HOME0}/system/unix/gomidas /usr/bin/gomidas
- dosym ${MID_HOME0}/system/ftoc-new ${MID_HOME0}/system/good-ftoc
-}
diff --git a/sci-astronomy/esomidas/files/esomidas-17.02-gentoo-setup.patch b/sci-astronomy/esomidas/files/esomidas-17.02-gentoo-setup.patch
deleted file mode 100644
index f6fb0515ee74..000000000000
--- a/sci-astronomy/esomidas/files/esomidas-17.02-gentoo-setup.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/install/unix/preinstall 2017-06-29 23:49:01.295996178 +0000
-+++ b/install/unix/preinstall 2017-06-29 23:50:21.835445329 +0000
-@@ -124,6 +124,9 @@
- if [ -d "Debian" -a -f "/etc/debian_version" ]; then
- system="Debian"
-
-+elif [ -d "Gentoo" -a -f "/etc/gentoo-release" ]; then
-+ system="Gentoo"
-+
- elif [ "$uname" = "Darwin" ]; then
- system="Darwin"
-
diff --git a/sci-astronomy/esomidas/files/esomidas-17.02-output_to_stdout.patch b/sci-astronomy/esomidas/files/esomidas-17.02-output_to_stdout.patch
deleted file mode 100644
index bd24c3801d99..000000000000
--- a/sci-astronomy/esomidas/files/esomidas-17.02-output_to_stdout.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From: Ole Streicher <debian@liska.ath.cx>
-Date: Wed, 1 Mar 2017 09:31:31 +0100
-Subject: Run compilation in foreground and write log to stdout instead of a
- file.
-
----
- install/unix/install3 | 14 ++------------
- 1 file changed, 2 insertions(+), 12 deletions(-)
-
-diff --git a/install/unix/install3 b/install/unix/install3
-index ef2a415..1cc0b4e 100755
---- a/install/unix/install3
-+++ b/install/unix/install3
-@@ -112,8 +112,6 @@ fi
-
- echo ""
- echo "WARNING: MIDAS installation will delete all dependent files."
--echo " It will run in background and the output will be sent to"
--echo " the file <$MID_HOME/tmp/install.$$>"
- echo ""
- echo "Do you want to continue [yn]? (y): " $SV_NONL
- unset answ
-@@ -138,17 +136,9 @@ fi
-
- # do we have the 'time' command?
- if [ $CMND_YES = 2 ] ; then
-- /bin/bash $MID_INSTALL/install -i > $MID_HOME/tmp/install.$$ 2>&1 &
-+ /bin/bash $MID_INSTALL/install -i
- else
-- time /bin/bash $MID_INSTALL/install -i > $MID_HOME/tmp/install.$$ 2>&1 &
-+ time /bin/bash $MID_INSTALL/install -i
- fi
-
--echo "Running install in background"
--echo "Results are coming in $MID_HOME/tmp/install.$$"
--if [ "$1" = "-a" ]; then
-- echo "Waiting for MIDAS installation to finish..." $SV_NONL
-- wait
-- echo "Finished."
-- echo ""
--fi
- exit 0
diff --git a/sci-astronomy/esomidas/files/esomidas-17.02-rpc.patch b/sci-astronomy/esomidas/files/esomidas-17.02-rpc.patch
deleted file mode 100644
index d56ec03346c9..000000000000
--- a/sci-astronomy/esomidas/files/esomidas-17.02-rpc.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff -ruN 17FEBpl1.2.orig/lib/makefile 17FEBpl1.2/lib/makefile
---- 17FEBpl1.2.orig/lib/makefile 2017-04-26 11:44:02.000000000 +0200
-+++ 17FEBpl1.2/lib/makefile 2017-09-25 21:08:51.359595847 +0200
-@@ -58,7 +58,7 @@
- ## Ubuntu version 13.10 on
- ##
- ## $(SH_CMD) -o $(LIBMIDAS_SH) *.o $(DEV_NULL)
-- $(SH_CMD) -o $(LIBMIDAS_SH) *.o -lm $(F2C_LIBS) $(DEV_NULL)
-+ $(SH_CMD) -o $(LIBMIDAS_SH) *.o -lm $(F2C_LIBS) $(RPC_LIB) $(DEV_NULL)
-
- # for the AltLinux distro we had to change the line above to:
- # $(SH_CMD) -o $(LIBMIDAS_SH) *.o -lm $(DEV_NULL)
-diff -ruN 17FEBpl1.2.orig/libsrc/os/unix/makefile 17FEBpl1.2/libsrc/os/unix/makefile
---- 17FEBpl1.2.orig/libsrc/os/unix/makefile 2017-04-26 11:44:32.000000000 +0200
-+++ 17FEBpl1.2/libsrc/os/unix/makefile 2017-09-25 21:08:48.747583816 +0200
-@@ -19,7 +19,7 @@
-
- include ../../../local/default.mk
-
--CFLAGS += $(C_OPT) $(DEBUG) $(MEM_OPT) $(SH_OPT) $(OSSYS) $(SYS) -I$(INC)
-+CFLAGS += $(C_OPT) $(DEBUG) $(MEM_OPT) $(SH_OPT) $(OSSYS) $(SYS) -I$(INC) $(RPC_OPT)
-
- LIB = $(LIBDIR)/libos.a
-
-@@ -43,7 +43,7 @@
- # testos.exe only for checking the linking process, in cannot be executed...
-
- testos.exe: testos.o $(LIB)
-- $(LDCC) testos.o $(LIB) $(MLIB) $(SLIB) -o $@
-+ $(LDCC) testos.o $(LIB) $(MLIB) $(SLIB) $(RPC_LIB) -o $@
- $(STRIP) $@
-
- $(LIB): $(OBJ)
diff --git a/sci-astronomy/esomidas/metadata.xml b/sci-astronomy/esomidas/metadata.xml
deleted file mode 100644
index 00ef471241c4..000000000000
--- a/sci-astronomy/esomidas/metadata.xml
+++ /dev/null
@@ -1,19 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>sci-astronomy@gentoo.org</email>
- <name>Gentoo Astronomy Project</name>
-</maintainer>
-<longdescription lang="en">
- The ESO-MIDAS system provides general tools for image processing and data
- reduction with emphasis on astronomical applications including imaging and
- special reduction packages for ESO instrumentation at La Silla and the VLT at
- Paranal. In addition it contains applications packages for stellar and
- surface photometry, image sharpening and decomposition, statistics and
- various others.
-</longdescription>
-<use>
- <flag name="libtirpc">Build against <pkg>net-libs/libtirpc</pkg> for RPC support</flag>
-</use>
-</pkgmetadata>