summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2020-02-18 09:49:24 -0500
committerRick Farina <zerochaos@gentoo.org>2020-02-18 09:49:24 -0500
commit57c83db7084fe3737637adef13cc8ee8996dd15d (patch)
tree93e29fe4c73b064eac156b00a9ac9154eec886f8 /net-wireless/wpa_supplicant
parentgames-action/openclonk: drop outdated compiler check, bug #705254 (diff)
downloadgentoo-57c83db7084fe3737637adef13cc8ee8996dd15d.tar.gz
gentoo-57c83db7084fe3737637adef13cc8ee8996dd15d.tar.bz2
gentoo-57c83db7084fe3737637adef13cc8ee8996dd15d.zip
net-wireless/wpa_supplicant: please pkgcheck
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless/wpa_supplicant')
-rw-r--r--net-wireless/wpa_supplicant/wpa_supplicant-2.9-r2.ebuild16
-rw-r--r--net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild16
2 files changed, 16 insertions, 16 deletions
diff --git a/net-wireless/wpa_supplicant/wpa_supplicant-2.9-r2.ebuild b/net-wireless/wpa_supplicant/wpa_supplicant-2.9-r2.ebuild
index 13942c996c1c..3705130f5574 100644
--- a/net-wireless/wpa_supplicant/wpa_supplicant-2.9-r2.ebuild
+++ b/net-wireless/wpa_supplicant/wpa_supplicant-2.9-r2.ebuild
@@ -59,9 +59,9 @@ RDEPEND="${CDEPEND}
DOC_CONTENTS="
If this is a clean installation of wpa_supplicant, you
have to create a configuration file named
- ${EROOT%/}/etc/wpa_supplicant/wpa_supplicant.conf
+ ${EROOT}/etc/wpa_supplicant/wpa_supplicant.conf
An example configuration file is available for reference in
- ${EROOT%/}/usr/share/doc/${PF}/
+ ${EROOT}/usr/share/doc/${PF}/
"
S="${WORKDIR}/${P}/${PN}"
@@ -445,10 +445,10 @@ src_install() {
pkg_postinst() {
readme.gentoo_print_elog
- if [[ -e "${EROOT%/}"/etc/wpa_supplicant.conf ]] ; then
+ if [[ -e "${EROOT}"/etc/wpa_supplicant.conf ]] ; then
echo
- ewarn "WARNING: your old configuration file ${EROOT%/}/etc/wpa_supplicant.conf"
- ewarn "needs to be moved to ${EROOT%/}/etc/wpa_supplicant/wpa_supplicant.conf"
+ ewarn "WARNING: your old configuration file ${EROOT}/etc/wpa_supplicant.conf"
+ ewarn "needs to be moved to ${EROOT}/etc/wpa_supplicant/wpa_supplicant.conf"
fi
if use bindist; then
@@ -466,11 +466,11 @@ pkg_postinst() {
# Mea culpa, feel free to remove that after some time --mgorny.
local fn
for fn in wpa_supplicant{,@wlan0}.service; do
- if [[ -e "${EROOT%/}"/etc/systemd/system/network.target.wants/${fn} ]]
+ if [[ -e "${EROOT}"/etc/systemd/system/network.target.wants/${fn} ]]
then
ebegin "Moving ${fn} to multi-user.target"
- mv "${EROOT%/}"/etc/systemd/system/network.target.wants/${fn} \
- "${EROOT%/}"/etc/systemd/system/multi-user.target.wants/ || die
+ mv "${EROOT}"/etc/systemd/system/network.target.wants/${fn} \
+ "${EROOT}"/etc/systemd/system/multi-user.target.wants/ || die
eend ${?} \
"Please try to re-enable ${fn}"
fi
diff --git a/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild b/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild
index 67a54e06ba61..c91b6d2f5624 100644
--- a/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild
+++ b/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild
@@ -59,9 +59,9 @@ RDEPEND="${CDEPEND}
DOC_CONTENTS="
If this is a clean installation of wpa_supplicant, you
have to create a configuration file named
- ${EROOT%/}/etc/wpa_supplicant/wpa_supplicant.conf
+ ${EROOT}/etc/wpa_supplicant/wpa_supplicant.conf
An example configuration file is available for reference in
- ${EROOT%/}/usr/share/doc/${PF}/
+ ${EROOT}/usr/share/doc/${PF}/
"
S="${WORKDIR}/${P}/${PN}"
@@ -442,10 +442,10 @@ src_install() {
pkg_postinst() {
readme.gentoo_print_elog
- if [[ -e "${EROOT%/}"/etc/wpa_supplicant.conf ]] ; then
+ if [[ -e "${EROOT}"/etc/wpa_supplicant.conf ]] ; then
echo
- ewarn "WARNING: your old configuration file ${EROOT%/}/etc/wpa_supplicant.conf"
- ewarn "needs to be moved to ${EROOT%/}/etc/wpa_supplicant/wpa_supplicant.conf"
+ ewarn "WARNING: your old configuration file ${EROOT}/etc/wpa_supplicant.conf"
+ ewarn "needs to be moved to ${EROOT}/etc/wpa_supplicant/wpa_supplicant.conf"
fi
if use bindist; then
@@ -463,11 +463,11 @@ pkg_postinst() {
# Mea culpa, feel free to remove that after some time --mgorny.
local fn
for fn in wpa_supplicant{,@wlan0}.service; do
- if [[ -e "${EROOT%/}"/etc/systemd/system/network.target.wants/${fn} ]]
+ if [[ -e "${EROOT}"/etc/systemd/system/network.target.wants/${fn} ]]
then
ebegin "Moving ${fn} to multi-user.target"
- mv "${EROOT%/}"/etc/systemd/system/network.target.wants/${fn} \
- "${EROOT%/}"/etc/systemd/system/multi-user.target.wants/ || die
+ mv "${EROOT}"/etc/systemd/system/network.target.wants/${fn} \
+ "${EROOT}"/etc/systemd/system/multi-user.target.wants/ || die
eend ${?} \
"Please try to re-enable ${fn}"
fi