summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-02-25 19:27:14 -0800
committerMatt Turner <mattst88@gentoo.org>2020-02-25 19:35:43 -0800
commit2294f62841656970a6a9164115df73fc41cd279a (patch)
treebbdb3c1f9a17bb6ea5d6e6a835c6e01e179be8e6 /net-wireless/urh
parentsys-libs/musl: Version bump 1.2.0 (diff)
downloadgentoo-2294f62841656970a6a9164115df73fc41cd279a.tar.gz
gentoo-2294f62841656970a6a9164115df73fc41cd279a.tar.bz2
gentoo-2294f62841656970a6a9164115df73fc41cd279a.zip
Revert dev-python/pyzmq py2 and net-wireless/urh update
This commit reverts a revert of python2 support removal for dev-python/pyzmq. The original commit that remove py2 support was 3635fb573254 (dev-python/pyzmq: Remove py2), committed January 28th. Since then presumably a large number of dependencies of pyzmq have also dropped python2 support, because after commit c3bb20728e45 (Revert "Revert "dev-python/pyzmq: Remove py2"") from February 25 pkgcheck scan says: NonsolvableDepsInStable: version 16.0.2: nonsolvable depset(depend) keyword(amd64) stable profile (default/linux/amd64/17.0) (76 total): ... ... NonsolvableDepsInStable: version 17.1.0: nonsolvable depset(depend) keyword(amd64) stable profile (default/linux/amd64/17.0) (57 total): ... So it doesn't appear to be a trivial task to restore py2 support to pyzmq. Unfortunately this will break net-wireless/urh (both in terms of the software and in terms of the deptree). To keep the deptree in good shape commit f1b680936d23 (net-wireless/urh: fix deps, probably) must also be reverted. This reverts commit c3bb20728e45505d9b4a48164f37bb3288577d67. This reverts commit f1b680936d23084dc28bcab64e2cc4103a420303. Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-wireless/urh')
-rw-r--r--net-wireless/urh/urh-2.8.3.ebuild (renamed from net-wireless/urh/urh-2.8.3-r1.ebuild)4
-rw-r--r--net-wireless/urh/urh-9999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/net-wireless/urh/urh-2.8.3-r1.ebuild b/net-wireless/urh/urh-2.8.3.ebuild
index c5cc8e3ff712..1c4f6ddf86f1 100644
--- a/net-wireless/urh/urh-2.8.3-r1.ebuild
+++ b/net-wireless/urh/urh-2.8.3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=6
PYTHON_COMPAT=( python3_6 )
inherit distutils-r1 eutils
@@ -26,7 +26,7 @@ DEPEND="${PYTHON_DEPS}
net-wireless/gnuradio[zeromq]
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/pyzmq[python_targets_python2_7]
+ dev-python/pyzmq[${PYTHON_USEDEP}]
dev-python/cython[${PYTHON_USEDEP}]
bladerf? ( net-wireless/bladerf:= )
hackrf? ( net-libs/libhackrf:= )
diff --git a/net-wireless/urh/urh-9999.ebuild b/net-wireless/urh/urh-9999.ebuild
index c5cc8e3ff712..1c4f6ddf86f1 100644
--- a/net-wireless/urh/urh-9999.ebuild
+++ b/net-wireless/urh/urh-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=6
PYTHON_COMPAT=( python3_6 )
inherit distutils-r1 eutils
@@ -26,7 +26,7 @@ DEPEND="${PYTHON_DEPS}
net-wireless/gnuradio[zeromq]
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/pyzmq[python_targets_python2_7]
+ dev-python/pyzmq[${PYTHON_USEDEP}]
dev-python/cython[${PYTHON_USEDEP}]
bladerf? ( net-wireless/bladerf:= )
hackrf? ( net-libs/libhackrf:= )