summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-09-23 11:59:27 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-09-23 12:00:07 +0200
commitdcc8efa65dcc8dc4c8f142403d554dda3d970869 (patch)
tree1b262c3483fcfd9056e171f55bad7d6b4bece4bd /net-vpn/riseup-vpn/files
parentdev-util/bpftool: Remove old 5.14.2 (diff)
downloadgentoo-dcc8efa65dcc8dc4c8f142403d554dda3d970869.tar.gz
gentoo-dcc8efa65dcc8dc4c8f142403d554dda3d970869.tar.bz2
gentoo-dcc8efa65dcc8dc4c8f142403d554dda3d970869.zip
net-vpn/riseup-vpn: respect user setting for AR
Closes: https://bugs.gentoo.org/814017 Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'net-vpn/riseup-vpn/files')
-rw-r--r--net-vpn/riseup-vpn/files/riseup-vpn-respect-AR.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-vpn/riseup-vpn/files/riseup-vpn-respect-AR.patch b/net-vpn/riseup-vpn/files/riseup-vpn-respect-AR.patch
new file mode 100644
index 000000000000..431ab1376c65
--- /dev/null
+++ b/net-vpn/riseup-vpn/files/riseup-vpn-respect-AR.patch
@@ -0,0 +1,38 @@
+diff --git a/gui/build.sh b/gui/build.sh
+index 56e3d66..9e519a6 100755
+--- a/gui/build.sh
++++ b/gui/build.sh
+@@ -63,13 +63,13 @@ function buildGoLib {
+ if [ "$XBUILD" == "no" ]
+ then
+ echo "[+] Building Go library with standard Go compiler"
+- CGO_ENABLED=1 GOOS=$GOOS CC=$CC CGO_CFLAGS=$CGO_CFLAGS CGO_LDFLAGS=$CGO_LDFLAGS go build -buildmode=c-archive -o $TARGET_GOLIB $SOURCE_GOLIB
++ CGO_ENABLED=1 GOOS=$GOOS CC=$CC CGO_CFLAGS=$CGO_CFLAGS CGO_LDFLAGS=$CGO_LDFLAGS go build -buildmode=c-archive -ldflags="-extar=$AR -extld=$LD -extldflags=$LDFLAGS" -o $TARGET_GOLIB $SOURCE_GOLIB
+ fi
+ if [ "$XBUILD" == "$WIN64" ]
+ then
+ echo "[+] Building Go library with mxe"
+ echo "[+] Using cc:" $CC
+- CC=$CC CGO_ENABLED=1 GOOS=windows GOARCH=amd64 go build -buildmode=c-archive -o $TARGET_GOLIB $SOURCE_GOLIB
++ CC=$CC CGO_ENABLED=1 GOOS=windows GOARCH=amd64 go build -buildmode=c-archive -ldflags="-extar=$AR -extld=$LD -extldflags=$LDFLAGS" -o $TARGET_GOLIB $SOURCE_GOLIB
+ fi
+ }
+
+@@ -77,7 +77,7 @@ function buildQmake {
+ echo "[+] Now building Qml app with Qt qmake"
+ echo "[+] Using qmake in:" $QMAKE
+ mkdir -p $QTBUILD
+- $QMAKE -o "$QTBUILD/Makefile" CONFIG+=release VENDOR_PATH=${VENDOR_PATH} $PROJECT
++ $QMAKE -early QMAKE_CC=$CC QMAKE_CXX=$CXX QMAKE_LINK=$CXX -o "$QTBUILD/Makefile" CONFIG+=release VENDOR_PATH=${VENDOR_PATH} $PROJECT
+ #CONFIG=+force_debug_info CONFIG+=debug CONFIG+=debug_and_release
+ }
+
+@@ -115,7 +115,7 @@ function buildDefault {
+ buildQmake
+
+ make -C $QTBUILD clean
+- make -C $QTBUILD -j4 all
++ make -C $QTBUILD $MAKEFLAGS all
+
+ renameOutput
+ echo "[+] Done."