summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-12-30 23:53:15 +0500
committerJoonas Niilola <juippis@gentoo.org>2024-11-02 14:45:59 +0200
commit8a2d60758f44016de8977df0346f2b5485dd2741 (patch)
tree201053ae06348f8534adc485d225e2d628114471 /net-nntp
parentsys-auth/yubico-piv-tool: drop 2.5.2 (diff)
downloadgentoo-8a2d60758f44016de8977df0346f2b5485dd2741.tar.gz
gentoo-8a2d60758f44016de8977df0346f2b5485dd2741.tar.bz2
gentoo-8a2d60758f44016de8977df0346f2b5485dd2741.zip
net-nntp/tin: add 2.6.3
Patches related to Modern C Porting were upstreamed in 2.6.3, and GnuTLS build failure was fixed too. Closes: https://bugs.gentoo.org/929998 Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in> Closes: https://github.com/gentoo/gentoo/pull/38898 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/tin/Manifest1
-rw-r--r--net-nntp/tin/tin-2.6.3.ebuild122
2 files changed, 123 insertions, 0 deletions
diff --git a/net-nntp/tin/Manifest b/net-nntp/tin/Manifest
index 557d1afd2fbd..734d2ec2dfbf 100644
--- a/net-nntp/tin/Manifest
+++ b/net-nntp/tin/Manifest
@@ -1 +1,2 @@
DIST tin-2.6.2.tar.xz 1598732 BLAKE2B 0e5bac9a711fb69e64d64b4f0c070d456f38f727e7b7aa794ad5ada8695c2174023964b8f07d2e7d6add51cf0c7c3102965bef653a7e873275747145cb70dbe2 SHA512 4c9e0edb3268d57fb89d9d53a90e8a5ba73da7c1da63c834224bed0f763502a7c3dd325351d3e57b1ddcb57494a84228cc38f227c49300b759fad8d112b1cac1
+DIST tin-2.6.3.tar.xz 1639192 BLAKE2B dba26c5e5fe0e331e069a22ce3241c00e7e01f582d00a38e55e2fe33c93f98d99c47e9d04e0660b40535a8b11e63789bc91df1b22dacd62405ee716a003c07dd SHA512 e8b474849e3330475e92b7c578ffe2f29f022303be266d39493e58b7227d9a5ee3915812c1806f52358c07f91d6119810498db906d2da7ffe035feba0e340a42
diff --git a/net-nntp/tin/tin-2.6.3.ebuild b/net-nntp/tin/tin-2.6.3.ebuild
new file mode 100644
index 000000000000..0b301a45df40
--- /dev/null
+++ b/net-nntp/tin/tin-2.6.3.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature toolchain-funcs
+
+DESCRIPTION="A threaded NNTP and spool based UseNet newsreader"
+HOMEPAGE="http://www.tin.org/"
+SRC_URI="ftp://ftp.tin.org/pub/news/clients/tin/stable/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="cancel-locks debug gnutls gpg libtls nls sasl socks5 ssl"
+
+RDEPEND="
+ dev-libs/icu:=
+ dev-libs/libpcre2:=
+ dev-libs/uulib
+ sys-libs/ncurses:=
+ virtual/libiconv
+ cancel-locks? ( >=net-libs/canlock-3.0:= )
+ gpg? ( app-crypt/gnupg )
+ nls? ( virtual/libintl )
+ sasl? ( net-misc/gsasl[client] )
+ socks5? ( net-proxy/dante )
+ ssl? (
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? (
+ libtls? ( dev-libs/libretls:= )
+ !libtls? ( dev-libs/openssl:= )
+ )
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-alternatives/yacc
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ # Windows only (bug #900278)
+ memset_s
+)
+
+DOCS=(
+ README{,.MAC,.WIN}
+ doc/{CHANGES{,.old},CREDITS,TODO,WHATSNEW,filtering}
+)
+
+src_configure() {
+ tc-export AR CC RANLIB
+ tc-export_build_env
+
+ # The build incorrectly discards its local -I if $CPPFLAGS is set.
+ if [[ -n ${BUILD_CPPFLAGS} ]]; then
+ BUILD_CPPFLAGS+=' -I$(INCDIR)'
+ fi
+
+ local myeconfargs=(
+ $(use_enable cancel-locks)
+ $(use_with cancel-locks canlock)
+
+ $(use_enable debug)
+ $(use_enable gpg pgp-gpg)
+ $(use_enable nls)
+ $(use_with socks5 socks)
+ --disable-mime-strict-charset
+ --enable-nntp
+ --enable-prototypes
+ --without-pcre
+ --with-pcre2-config
+ --with-coffee # easter egg :)
+ --with-nntp-default-server="${TIN_DEFAULT_SERVER:-${NNTPSERVER:-news.gmane.io}}"
+ --with-screen=ncursesw
+ )
+
+ if use ssl; then
+ if use gnutls; then
+ myeconfargs+=( --with-nntps=gnutls )
+ elif use libtls; then
+ myeconfargs+=( --with-nntps=libtls )
+ else
+ myeconfargs+=( --with-nntps=openssl )
+ fi
+ fi
+
+ myeconfargs+=(
+ # set default paths for utilities
+ --with-editor="${EPREFIX}"/usr/libexec/editor
+ --with-gpg="${EPREFIX}"/usr/bin/gpg
+ --with-ispell="${EPREFIX}"/usr/bin/aspell
+ --with-mailer="${EPREFIX}"/bin/mail
+ --with-sum="${EPREFIX}"/usr/bin/sum
+
+ # set default paths for directories
+ --with-libdir="${EPREFIX}"/var/lib/news
+ --with-spooldir="${EPREFIX}"/var/spool/news
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ # To build from the root dir you have to call `make build`, not just `make`.
+ emake build
+}
+
+src_install() {
+ default
+
+ emake DESTDIR="${D}" install_sysdefs
+ emake -C src DESTDIR="${D}" install_nls_man
+
+ dodoc doc/{*.sample,*.txt}
+}
+
+pkg_postinst() {
+ optfeature "spell checker support" app-text/aspell
+}