summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-nntp/pan
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-nntp/pan')
-rw-r--r--net-nntp/pan/Manifest1
-rw-r--r--net-nntp/pan/files/pan-0.139-pan.desktop.patch31
-rw-r--r--net-nntp/pan/metadata.xml5
-rw-r--r--net-nntp/pan/pan-0.139.ebuild49
4 files changed, 86 insertions, 0 deletions
diff --git a/net-nntp/pan/Manifest b/net-nntp/pan/Manifest
new file mode 100644
index 000000000000..ac377db5571a
--- /dev/null
+++ b/net-nntp/pan/Manifest
@@ -0,0 +1 @@
+DIST pan-0.139.tar.bz2 1523907 SHA256 bf5f320f997f582d7ac823e3e854393307161a92e7014d2135e6e2674d144bb9 SHA512 7c6c5f3f54de475e0b5778cc33b6c46f18cb1100d89eab6ea2a6279492cb95a85226ccd6dba1abb43092b78f7cb100cea3215edb21c7813d624e84104b119a81 WHIRLPOOL b8c05cdabff893895370128dad53e19e29a348f3921c394af1a26210ebd9b89e4772dfb926685a549fc9d667c6cdc39fdf32b043a8761488f9f3a77d52aa52df
diff --git a/net-nntp/pan/files/pan-0.139-pan.desktop.patch b/net-nntp/pan/files/pan-0.139-pan.desktop.patch
new file mode 100644
index 000000000000..1b1de5c4b3db
--- /dev/null
+++ b/net-nntp/pan/files/pan-0.139-pan.desktop.patch
@@ -0,0 +1,31 @@
+From 1dba05f87839a6fa347414a800824812f2642554 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Heinrich=20M=C3=BCller?= <henmull@src.gnome.org>
+Date: Wed, 25 Jul 2012 19:36:44 +0200
+Subject: [PATCH] https://bugzilla.gnome.org/show_bug.cgi?id=680468
+
+---
+ pan.desktop.in | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/pan.desktop.in b/pan.desktop.in
+index 4660140..4bbeca5 100644
+--- a/pan.desktop.in
++++ b/pan.desktop.in
+@@ -1,10 +1,10 @@
+ [Desktop Entry]
+-Encoding=UTF-8
+-_Name=Pan Newsreader
++_Name=Pan
++_GenericName=Newsreader
+ _Comment=Read and Post Usenet Articles
+ Exec=pan
+-Icon=pan.png
++Icon=pan
+ Terminal=false
+ Type=Application
+-Categories=GTK;Application;Network;News
++Categories=GTK;Network;News;
+ StartupNotify=false
+--
+1.8.0
+
diff --git a/net-nntp/pan/metadata.xml b/net-nntp/pan/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/net-nntp/pan/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>
diff --git a/net-nntp/pan/pan-0.139.ebuild b/net-nntp/pan/pan-0.139.ebuild
new file mode 100644
index 000000000000..77d2bbfba935
--- /dev/null
+++ b/net-nntp/pan/pan-0.139.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="A newsreader for GNOME"
+HOMEPAGE="http://pan.rebelbase.com/"
+SRC_URI="http://pan.rebelbase.com/download/releases/${PV}/source/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 hppa ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
+IUSE="dbus gnome-keyring libnotify spell ssl"
+
+RDEPEND=">=dev-libs/glib-2.26:2
+ >=x11-libs/gtk+-2.16:2
+ dev-libs/gmime:2.6
+ gnome-keyring? ( >=gnome-base/libgnome-keyring-3.2 )
+ libnotify? ( >=x11-libs/libnotify-0.4.1 )
+ spell? (
+ >=app-text/enchant-1.6
+ >=app-text/gtkspell-2.0.7:2 )
+ ssl? ( >=net-libs/gnutls-3 )"
+
+DEPEND="${RDEPEND}
+ app-text/gnome-doc-utils
+ >=dev-util/intltool-0.35.5
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ # in next release
+ epatch "${FILESDIR}/${P}-pan.desktop.patch"
+}
+
+src_configure() {
+ econf \
+ --without-gtk3 \
+ $(use_with dbus) \
+ $(use_enable gnome-keyring gkr) \
+ $(use_with spell gtkspell) \
+ $(use_enable libnotify) \
+ $(use_with ssl gnutls)
+}