summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-15 03:56:58 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-15 04:01:26 +0200
commit46f70b9f68acecc8e7475b8b62559b04ffb62806 (patch)
treeb5245cde7ce9d6f46e6b23b95322dd9e977d7d79 /net-news
parentdev-python/mcbootflash: Bump to 9.0.1 (diff)
downloadgentoo-46f70b9f68acecc8e7475b8b62559b04ffb62806.tar.gz
gentoo-46f70b9f68acecc8e7475b8b62559b04ffb62806.tar.bz2
gentoo-46f70b9f68acecc8e7475b8b62559b04ffb62806.zip
net-news/rssguard: Bump to 4.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-news')
-rw-r--r--net-news/rssguard/Manifest1
-rw-r--r--net-news/rssguard/rssguard-4.7.0.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/net-news/rssguard/Manifest b/net-news/rssguard/Manifest
index 88f1620080d8..6050dd9861d8 100644
--- a/net-news/rssguard/Manifest
+++ b/net-news/rssguard/Manifest
@@ -1 +1,2 @@
DIST rssguard-4.6.6.gh.tar.gz 23432162 BLAKE2B f9febdc9d91ebfd4f8e8ade9de7b9ba6748bea9f5fa0e3ced0c4eaa908daedcbc2ae31c77e472418a05a8aca7fc30c7d56ab19aa144df40ea14a4530ac520e3d SHA512 82dbc1e5cbc527a965d17afe77aea978908544c2f8997a134749374e6acaf287de90c6be9a8e818c1097f826b54af94731f5f39fa9232ff8ee2491ac99e24063
+DIST rssguard-4.7.0.gh.tar.gz 23412811 BLAKE2B 5a2b07cc1812ee283fdc9c94cdfef613e8455e2b48738c24907c36892a996b6481aa6cfd6ebdf93145fdc457788afffd0249cf491926c65bbf8ba51f3818e3b8 SHA512 a43760bcfdd097d18aa11bb9efd0708c4a0d9bdf91c3628a7fc5a1cdb71dcbd3426440435e6a96e05856cffa84411e61f330d79856d68f474cf1288272388791
diff --git a/net-news/rssguard/rssguard-4.7.0.ebuild b/net-news/rssguard/rssguard-4.7.0.ebuild
new file mode 100644
index 000000000000..3625148b6cb5
--- /dev/null
+++ b/net-news/rssguard/rssguard-4.7.0.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake optfeature xdg
+
+DESCRIPTION="Simple (yet powerful) news feed reader"
+HOMEPAGE="https://github.com/martinrotter/rssguard/"
+SRC_URI="
+ https://github.com/martinrotter/rssguard/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="|| ( LGPL-3 GPL-2+ ) AGPL-3+ BSD GPL-3+ MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libmpv mysql qt6 qtmultimedia +sqlite webengine"
+REQUIRED_USE="
+ || ( mysql sqlite )
+ ?? ( libmpv qtmultimedia )
+"
+
+BDEPEND="
+ !qt6? ( dev-qt/linguist-tools:5 )
+ qt6? ( dev-qt/qttools:6[linguist] )
+"
+DEPEND="
+ sys-libs/zlib:=
+ libmpv? ( media-video/mpv:= )
+ !qt6? (
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5[gstreamer]
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsql:5[mysql?,sqlite?]
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ libmpv? (
+ dev-qt/qtopengl:5
+ )
+ qtmultimedia? (
+ dev-qt/qtmultimedia:5
+ dev-qt/qtopengl:5
+ )
+ webengine? ( dev-qt/qtwebengine:5[widgets(+)] )
+ )
+ qt6? (
+ dev-qt/qtbase:6[concurrent,dbus,gui,mysql?,network,sql,sqlite?,ssl,widgets]
+ dev-qt/qtdeclarative:6
+ dev-qt/qtmultimedia:6[gstreamer]
+ dev-qt/qt5compat:6
+ media-libs/libglvnd
+ libmpv? (
+ dev-qt/qtbase:6[opengl]
+ )
+ qtmultimedia? (
+ dev-qt/qtbase:6[opengl]
+ dev-qt/qtmultimedia:6
+ )
+ webengine? ( dev-qt/qtwebengine:6[widgets(+)] )
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_WITH_QT6=$(usex qt6)
+ -DNO_LITE=$(usex webengine)
+ -DREVISION_FROM_GIT=OFF
+ -DNO_UPDATE_CHECK=ON
+ -DENABLE_COMPRESSED_SITEMAP=ON
+ -DENABLE_MEDIAPLAYER_QTMULTIMEDIA=$(usex qtmultimedia)
+ -DENABLE_MEDIAPLAYER_LIBMPV=$(usex libmpv)
+ # recommended
+ -DMEDIAPLAYER_FORCE_OPENGL=ON
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "ad blocking functionality" "net-libs/nodejs[npm]"
+}