summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-04 04:27:34 +0000
committerSam James <sam@gentoo.org>2022-03-04 23:58:35 +0000
commit5057266615533ccea68038db9f018fd715851286 (patch)
treed1d049ba5c909d717c0bf8e22fbc7d095e6d09bd /net-news/amphetadesk
parentsys-block/tw_cli: drop 10.2.2.1 (diff)
downloadgentoo-5057266615533ccea68038db9f018fd715851286.tar.gz
gentoo-5057266615533ccea68038db9f018fd715851286.tar.bz2
gentoo-5057266615533ccea68038db9f018fd715851286.zip
net-news/amphetadesk: update EAPI 6 -> 8
Signed-off-by: Sam James <sam@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/24400 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-news/amphetadesk')
-rw-r--r--net-news/amphetadesk/amphetadesk-0.93.1-r1.ebuild23
1 files changed, 11 insertions, 12 deletions
diff --git a/net-news/amphetadesk/amphetadesk-0.93.1-r1.ebuild b/net-news/amphetadesk/amphetadesk-0.93.1-r1.ebuild
index 59142dc72d49..4fd7f473b1c0 100644
--- a/net-news/amphetadesk/amphetadesk-0.93.1-r1.ebuild
+++ b/net-news/amphetadesk/amphetadesk-0.93.1-r1.ebuild
@@ -1,36 +1,35 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
DESCRIPTION="AmphetaDesk is a free syndicated news aggregator"
HOMEPAGE="http://www.disobey.com/amphetadesk/"
SRC_URI="mirror://sourceforge/sourceforge/amphetadesk/${PN}-src-v${PV}.tar.gz"
+S="${WORKDIR}"/${PN}-src-v${PV}
+
LICENSE="Artistic"
SLOT="0"
KEYWORDS="~amd64 ~ppc x86"
-IUSE=""
-DEPEND="dev-lang/perl
- dev-perl/libwww-perl
+
+RDEPEND="dev-lang/perl
dev-libs/expat
+ dev-perl/libwww-perl
dev-perl/XML-Parser
virtual/perl-IO-Compress"
-S=${WORKDIR}/${PN}-src-v${PV}
src_install() {
- dodir /usr/share/amphetadesk
- cp "${S}"/AmphetaDesk.pl "${D}"/usr/share/amphetadesk/AmphetaDesk.pl
+ insinto /usr/share/amphetadesk
+ doins "${S}"/AmphetaDesk.pl
+ doins -R "${S}"/{data,docs,lib,templates}
+
dodoc README.txt
- cp -R "${S}"/data "${D}"/usr/share/amphetadesk
- cp -R "${S}"/docs "${D}"/usr/share/amphetadesk
- cp -R "${S}"/lib "${D}"/usr/share/amphetadesk
- cp -R "${S}"/templates "${D}"/usr/share/amphetadesk
newinitd "${FILESDIR}"/amphetadesk.initd amphetadesk
}
pkg_postinst() {
# fixes bug #25066 thanks to kloeri
- /etc/init.d/depscan.sh
+ [[ -x /etc/init.d/depscan.sh ]] && /etc/init.d/depscan.sh
einfo "AmphetaDesk should be started and stopped with the runscript located at "
einfo "'/etc/init.d/amphetadesk'. You can access AmphetaDesk after it has been"