summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-19 05:28:09 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-19 06:16:45 +0200
commite46c36a948fdf425957f9bc4534ee34faeb076cf (patch)
tree3664d6986bb80778371c42c07fd086a84c286056 /net-misc
parentnet-misc/tuba: Remove old (diff)
downloadgentoo-e46c36a948fdf425957f9bc4534ee34faeb076cf.tar.gz
gentoo-e46c36a948fdf425957f9bc4534ee34faeb076cf.tar.bz2
gentoo-e46c36a948fdf425957f9bc4534ee34faeb076cf.zip
net-misc/tuba: Bump to 0.8.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/tuba/Manifest1
-rw-r--r--net-misc/tuba/tuba-0.8.2.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/net-misc/tuba/Manifest b/net-misc/tuba/Manifest
index 621ee9b1dffb..ed012e1186c2 100644
--- a/net-misc/tuba/Manifest
+++ b/net-misc/tuba/Manifest
@@ -1,2 +1,3 @@
DIST Tuba-0.6.3.gh.tar.gz 1124191 BLAKE2B b5a7107c94d9adf89fc02224891c12b71fc2b640e962006fbfcf1d0673e5f3f73b11423b6d66e8952e2aef122ade6a57607cced5d4707bd91193157fd561ce11 SHA512 b987b9b8434a0abd086a3197154b27bd4a0bca69df07bcec26c59a2da51cf447943e7a05a83529a99670f2b1b7ea1a7dce1da39148844d23706940f3a0a423d8
DIST Tuba-0.8.1.gh.tar.gz 1737171 BLAKE2B b7bd9b0b6559a108886c46927ebdfb08e533c72fe63bfcb17f46c6aba3b637c99e324c83037a26024094516b659c247f2b6a61390313a4503ad593a4db97a39b SHA512 8e37e806ada3ad507761fbbf7f028f87c83e9e25fc3bd5a922fd9e6b0334c4c86b6c988ac337e5889f7ab05fd62e36044a9934b589583d1eabb2efbfae4f6a5d
+DIST Tuba-0.8.2.gh.tar.gz 1751598 BLAKE2B 9fb0a32d7731ca406a6f79223c862fbe0b75493ace5dc2d83cdab111e955ded2f1b42c31542e38b027245df29ba6a84d88014cafdba0214bdb22910c933989bd SHA512 5d00843ae54c7f32adf5bdbecf0798730f797f778aea55bdc6fff1bf7fdb3b386544a209bd621a92774dcbe25d26503ca9da73211355866452069b6fa4542360
diff --git a/net-misc/tuba/tuba-0.8.2.ebuild b/net-misc/tuba/tuba-0.8.2.ebuild
new file mode 100644
index 000000000000..e75bb85f2c86
--- /dev/null
+++ b/net-misc/tuba/tuba-0.8.2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils meson optfeature vala
+
+MY_P=${P^}
+DESCRIPTION="Browse the Fediverse (GTK client)"
+HOMEPAGE="
+ https://tuba.geopjr.dev/
+ https://github.com/GeopJr/Tuba/
+"
+SRC_URI="
+ https://github.com/GeopJr/Tuba/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-3 CC-BY-SA-4.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+# TODO: optional dep on libspelling-1
+DEPEND="
+ app-crypt/libsecret[introspection,vala]
+ >=dev-libs/glib-2.76.0:2
+ dev-libs/icu:=
+ >=dev-libs/json-glib-1.4.4[introspection]
+ >=dev-libs/libgee-0.8.5:0.8[introspection]
+ dev-libs/libxml2
+ >=gui-libs/gtk-4.13.4:4[gstreamer,introspection]
+ >=gui-libs/libadwaita-1.5:1[introspection,vala]
+ >=gui-libs/gtksourceview-5.6.0:5[introspection,vala]
+ net-libs/libsoup:3.0[introspection,vala]
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ $(vala_depend)
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ # disable calling updaters (see pkg_post*)
+ -Ddistro=true
+ # not packaged
+ -Dclapper=false
+ )
+
+ vala_setup
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ dosym dev.geopjr.Tuba /usr/bin/tuba
+}
+
+pkg_postinst() {
+ optfeature "WebP image support" gui-libs/gdk-pixbuf-loader-webp
+
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}