summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-05-27 11:37:37 -0400
committerMike Gilbert <floppym@gentoo.org>2017-05-27 11:39:16 -0400
commitdd4dc053a9b31b318de3ed1a91d5dbda602d92b8 (patch)
tree1df609c2ec7fa3399c83efba1ea68a7b7efa440e /net-misc
parentdev-python/autopep8: Version bump to 1.3.2 (diff)
downloadgentoo-dd4dc053a9b31b318de3ed1a91d5dbda602d92b8.tar.gz
gentoo-dd4dc053a9b31b318de3ed1a91d5dbda602d92b8.tar.bz2
gentoo-dd4dc053a9b31b318de3ed1a91d5dbda602d92b8.zip
net-misc/networkmanager: fixup deps and tidy ebuild
Package-Manager: Portage-2.3.6_p1, Repoman-2.3.2_p69
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/networkmanager/networkmanager-1.8.0.ebuild82
1 files changed, 34 insertions, 48 deletions
diff --git a/net-misc/networkmanager/networkmanager-1.8.0.ebuild b/net-misc/networkmanager/networkmanager-1.8.0.ebuild
index ba6cd27f53fb..1ce1cc72ebb5 100644
--- a/net-misc/networkmanager/networkmanager-1.8.0.ebuild
+++ b/net-misc/networkmanager/networkmanager-1.8.0.ebuild
@@ -16,9 +16,7 @@ HOMEPAGE="https://wiki.gnome.org/Projects/NetworkManager"
LICENSE="GPL-2+"
SLOT="0" # add subslot if libnm-util.so.2 or libnm-glib.so.4 bumps soname version
-IUSE="audit bluetooth connection-sharing consolekit +dhclient elogind gnutls \
-+introspection json kernel_linux +nss +modemmanager ncurses ofono +ppp resolvconf \
-selinux systemd teamd test vala +wext +wifi"
+IUSE="audit bluetooth connection-sharing consolekit +dhclient elogind gnutls +introspection json kernel_linux +nss +modemmanager ncurses ofono +ppp resolvconf selinux systemd teamd test vala +wext +wifi"
REQUIRED_USE="
modemmanager? ( ppp )
@@ -40,11 +38,11 @@ COMMON_DEPEND="
>=dev-libs/libnl-3.2.8:3=[${MULTILIB_USEDEP}]
>=sys-auth/polkit-0.106
net-libs/libndp
- >=net-libs/libsoup-2.40:2.4=
+ net-misc/curl
net-misc/iputils
sys-apps/util-linux[${MULTILIB_USEDEP}]
sys-libs/readline:0=
- >=virtual/libgudev-165:=[${MULTILIB_USEDEP}]
+ >=virtual/libudev-175:=[${MULTILIB_USEDEP}]
audit? ( sys-process/audit )
bluetooth? ( >=net-wireless/bluez-5 )
connection-sharing? (
@@ -66,7 +64,10 @@ COMMON_DEPEND="
resolvconf? ( net-dns/openresolv )
selinux? ( sys-libs/libselinux )
systemd? ( >=sys-apps/systemd-209:0= )
- teamd? ( >=net-misc/libteam-1.9 )
+ teamd? (
+ dev-libs/jansson
+ >=net-misc/libteam-1.9
+ )
"
RDEPEND="${COMMON_DEPEND}
wifi? ( >=net-wireless/wpa_supplicant-0.7.3-r3[dbus] )
@@ -92,17 +93,13 @@ DEPEND="${COMMON_DEPEND}
"
python_check_deps() {
- local rv=0
if use introspection; then
- has_version "dev-python/pygobject:3[${PYTHON_USEDEP}]"
- (( rv |= $? ))
+ has_version "dev-python/pygobject:3[${PYTHON_USEDEP}]" || return
fi
if use test; then
has_version "dev-python/dbus-python[${PYTHON_USEDEP}]" &&
has_version "dev-python/pygobject:3[${PYTHON_USEDEP}]"
- (( rv |= $? ))
fi
- return ${rv}
}
sysfs_deprecated_check() {
@@ -151,43 +148,20 @@ src_prepare() {
}
multilib_src_configure() {
- local myconf=()
-
- # Same hack as net-dialup/pptpd to get proper plugin dir for ppp, bug #519986
- if use ppp; then
- local PPPD_VER=`best_version net-dialup/ppp`
- PPPD_VER=${PPPD_VER#*/*-} #reduce it to ${PV}-${PR}
- PPPD_VER=${PPPD_VER%%[_-]*} # main version without beta/pre/patch/revision
- myconf+=( --with-pppd-plugin-dir=/usr/$(get_libdir)/pppd/${PPPD_VER} )
- fi
-
- # unit files directory needs to be passed only when systemd is enabled,
- # otherwise systemd support is not disabled completely, bug #524534
- use systemd && myconf+=( --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" )
-
- if multilib_is_native_abi; then
- # work-around man out-of-source brokenness, must be done before configure
- mkdir man || die
- find "${S}"/man -name '*.?' -exec ln -s {} man/ ';' || die
- fi
-
- # ifnet plugin always disabled until someone volunteers to actively
- # maintain and fix it
- # Also disable dhcpcd support as it's also completely unmaintained
- # and facing bugs like #563938 and many others
- #
- # We need --with-libnm-glib (and dbus-glib dep) as reverse deps are
- # still not ready for removing that lib
- myconf=(
+ local myconf=(
--disable-more-warnings
--disable-static
--localstatedir=/var
--disable-lto
--disable-config-plugin-ibft
+ # ifnet plugin always disabled until someone volunteers to actively
+ # maintain and fix it
--disable-ifnet
--disable-qt
--without-netconfig
--with-dbus-sys-dir=/etc/dbus-1/system.d
+ # We need --with-libnm-glib (and dbus-glib dep) as reverse deps are
+ # still not ready for removing that lib
--with-libnm-glib
--with-nmcli=yes
--with-udev-dir="$(get_udevdir)"
@@ -199,11 +173,14 @@ multilib_src_configure() {
--with-suspend-resume=$(multilib_native_usex systemd systemd $(multilib_native_usex elogind elogind consolekit))
$(multilib_native_use_with audit libaudit)
$(multilib_native_use_enable bluetooth bluez5-dun)
+ $(use_with dhclient)
+ # Also disable dhcpcd support as it's also completely unmaintained
+ # and facing bugs like #563938 and many others
+ --without-dhcpcd
$(multilib_native_use_enable introspection)
$(multilib_native_use_enable json json-validation)
$(multilib_native_use_enable ppp)
- $(use_with dhclient)
- --without-dhcpcd
+ --without-libpsl
$(multilib_native_use_with modemmanager modem-manager-1)
$(multilib_native_use_with ncurses nmtui)
$(multilib_native_use_with ofono)
@@ -216,18 +193,27 @@ multilib_src_configure() {
--without-valgrind
$(multilib_native_use_with wext)
$(multilib_native_use_enable wifi)
- "${myconf[@]}"
)
- ECONF_SOURCE=${S} runstatedir="/run" gnome2_src_configure "${myconf[@]}"
+ # Same hack as net-dialup/pptpd to get proper plugin dir for ppp, bug #519986
+ if use ppp; then
+ local PPPD_VER=`best_version net-dialup/ppp`
+ PPPD_VER=${PPPD_VER#*/*-} #reduce it to ${PV}-${PR}
+ PPPD_VER=${PPPD_VER%%[_-]*} # main version without beta/pre/patch/revision
+ myconf+=( --with-pppd-plugin-dir=/usr/$(get_libdir)/pppd/${PPPD_VER} )
+ fi
+
+ # unit files directory needs to be passed only when systemd is enabled,
+ # otherwise systemd support is not disabled completely, bug #524534
+ use systemd && myconf+=( --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" )
- # work-around gtk-doc out-of-source brokedness
if multilib_is_native_abi; then
- local d
- for d in api libnm libnm-util libnm-glib; do
- ln -s "${S}"/docs/${d}/html docs/${d}/html || die
- done
+ # work-around man out-of-source brokenness, must be done before configure
+ ln -s "${S}/docs" docs || die
+ ln -s "${S}/man" man || die
fi
+
+ ECONF_SOURCE=${S} runstatedir="/run" gnome2_src_configure "${myconf[@]}"
}
multilib_src_compile() {