summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-03-12 01:18:28 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-03-12 01:18:51 +0100
commit618fd06f5926830e967ab4650e1cf96f0adc4f35 (patch)
tree83972940729ca52febcd7009c1802a0db2fd8a95 /net-misc
parentnet-misc/gallery-dl: drop old 1.24.3 (diff)
downloadgentoo-618fd06f5926830e967ab4650e1cf96f0adc4f35.tar.gz
gentoo-618fd06f5926830e967ab4650e1cf96f0adc4f35.tar.bz2
gentoo-618fd06f5926830e967ab4650e1cf96f0adc4f35.zip
net-misc/gallery-dl: bump to 1.25.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/gallery-dl/Manifest1
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.25.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/gallery-dl/Manifest b/net-misc/gallery-dl/Manifest
index 7309b1cb09aa..89e0a23e4841 100644
--- a/net-misc/gallery-dl/Manifest
+++ b/net-misc/gallery-dl/Manifest
@@ -1,3 +1,4 @@
DIST gallery-dl-1.24.2.gh.tar.gz 509230 BLAKE2B e0be565c00d4c81b613bdc3fe9983a5a7cc7a1f131750ec79f16e3b38d134f49ef8fb8f9585767c1abdb3c3d3abc4681f5546460373d53da0646f7fd73a3d47b SHA512 2b8780d9ebf868635f76315a5f7a426ed72b4db4e7a12f97ebc86520fa6d5908f39fb26e876cbc46e8249b083f3bf5dc4d38a3c2ddb27873c473c80bac0af415
DIST gallery-dl-1.24.4.gh.tar.gz 518668 BLAKE2B 73ef2894d1355716001a5b82c43547d8156a646136b9a87e91ab0c51c4c238509da077e6ca79e8701a65c3e846aaa4adeac8d3f8cdfb50e140e815f56b55d358 SHA512 19285f9db2eba95252f13af176c314a318fd71503913ce6b54e4b31d0c41b1ca79498289531ca0b9d67630395c8212ba497c5c2a838f554c24d1672c5c16caf3
DIST gallery-dl-1.24.5.gh.tar.gz 525743 BLAKE2B 6b8611242bbb6a6dc76508ec452c3618fe75d6ffdc3185b5f246e5568f32861647649d63e9479b187f086aeb4ea4f567567fc387bbe1df0cb4994a00d4ba76f1 SHA512 648707e5be450501aa66f34b89aae1cf7b80c93bee5105c9eeae4fa19e34df41b231066a23113e963119105050e6aed8e654d10d107086ab5a815095dcf562c2
+DIST gallery-dl-1.25.0.gh.tar.gz 540793 BLAKE2B e02daf0b2deb8196fc587a3fd17e4bb8b0d14ca67c6384e120d3fadaa261b5d9143885c2717d0e98dc0467285a7ebfa9f9bc5da7ad5bd39a239a6975e0a900eb SHA512 e0cc041343130acf47f0ab4b7b7ac0ac42389bc457748404b9b0bc17f8a8690b225ab30c0c3d523925138608508417ecc4052981a5615d0747a2a064f6236ed4
diff --git a/net-misc/gallery-dl/gallery-dl-1.25.0.ebuild b/net-misc/gallery-dl/gallery-dl-1.25.0.ebuild
new file mode 100644
index 000000000000..9dcd7bdbba2f
--- /dev/null
+++ b/net-misc/gallery-dl/gallery-dl-1.25.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite,ssl,xml(+)"
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Download image galleries and collections from several image hosting sites"
+HOMEPAGE="https://github.com/mikf/gallery-dl"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mikf/${PN}.git"
+else
+ SRC_URI="https://github.com/mikf/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+# tests require network access
+RESTRICT="test"
+
+RDEPEND=">=dev-python/requests-2.11.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py
+
+python_compile_all() {
+ emake PYTHON=${EPYTHON} data/completion/{,_}gallery-dl man
+}
+
+pkg_postinst() {
+ optfeature "Pixiv Ugoira to WebM conversion" media-video/ffmpeg
+ optfeature "video downloads" net-misc/yt-dlp
+}