summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-08 05:22:31 +0000
committerSam James <sam@gentoo.org>2023-03-08 05:22:45 +0000
commit63fc2ba529edd89eb6221807a2a93a9bea64f83d (patch)
treeec2bc4a184fbccde3b6bd1d5c0fc067fb4f6e0a3 /net-misc/udpcast/udpcast-20211207-r1.ebuild
parentdev-python/translate-toolkit: Reselect fixed test (diff)
downloadgentoo-63fc2ba529edd89eb6221807a2a93a9bea64f83d.tar.gz
gentoo-63fc2ba529edd89eb6221807a2a93a9bea64f83d.tar.bz2
gentoo-63fc2ba529edd89eb6221807a2a93a9bea64f83d.zip
net-misc/udpcast: restore FEC
Closes: https://bugs.gentoo.org/900230 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/udpcast/udpcast-20211207-r1.ebuild')
-rw-r--r--net-misc/udpcast/udpcast-20211207-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/udpcast/udpcast-20211207-r1.ebuild b/net-misc/udpcast/udpcast-20211207-r1.ebuild
new file mode 100644
index 000000000000..11fb3b0fac1e
--- /dev/null
+++ b/net-misc/udpcast/udpcast-20211207-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="Multicast file transfer tool"
+HOMEPAGE="https://www.udpcast.linux.lu/"
+SRC_URI="https://www.udpcast.linux.lu/download/${P}.tar.gz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="hardened"
+
+BDEPEND="dev-lang/perl"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-musl.patch
+)
+
+src_configure() {
+ # bug #900230
+ append-cppflags -DBB_FEATURE_UDPCAST_FEC
+
+ use hardened || append-cppflags -DUSE_ASSEMBLER
+
+ default
+}
+
+src_install() {
+ default
+ dodoc *.txt
+}