summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarlson2k (Evgeny Grin) <k2k@narod.ru>2022-02-18 16:13:14 +0300
committerSam James <sam@gentoo.org>2022-03-08 13:17:58 +0000
commit1cc56fae05662314257f70a7a768ab82737ca31a (patch)
treea038f89cebe2afd33a726ba38ff8426b1702a046 /net-misc/r8125
parentwww-apps/hugo: Remove old ebuild (diff)
downloadgentoo-1cc56fae05662314257f70a7a768ab82737ca31a.tar.gz
gentoo-1cc56fae05662314257f70a7a768ab82737ca31a.tar.bz2
gentoo-1cc56fae05662314257f70a7a768ab82737ca31a.zip
net-misc/r8125: new package for Realtek r8125 driver
This package is vendor drivers for Realtek RTL8125 network cards. While Linux kernel has support for these card, vendor driver provides more features, which are not available in in-tree driver. Closes: https://bugs.gentoo.org/736400 Closes: https://bugs.gentoo.org/834576 Signed-off-by: Karlson2k (Evgeny Grin) <k2k@narod.ru> Closes: https://github.com/gentoo/gentoo/pull/24250 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/r8125')
-rw-r--r--net-misc/r8125/Manifest1
-rw-r--r--net-misc/r8125/metadata.xml20
-rw-r--r--net-misc/r8125/r8125-9.007.01.ebuild38
3 files changed, 59 insertions, 0 deletions
diff --git a/net-misc/r8125/Manifest b/net-misc/r8125/Manifest
new file mode 100644
index 000000000000..e8457bed63e4
--- /dev/null
+++ b/net-misc/r8125/Manifest
@@ -0,0 +1 @@
+DIST r8125-9.007.01.tar.bz2 88973 BLAKE2B fda3be9bded138bb6ee6b131c4d89d2dc777153eb1d003f11803d412d28957c944f220452762ca92ebb1cbfe2d5e7bdc0f9944517a0bb58ed0f3f112986c21ee SHA512 753c328d5a962366ea1bd495ca3860309bc6ff8b2f3fb367a9f184441dd7c507d0eb4d63cc9b23851d0287e75ad2d602caee5ffed911691349cf8d0f37477a5c
diff --git a/net-misc/r8125/metadata.xml b/net-misc/r8125/metadata.xml
new file mode 100644
index 000000000000..a0cb8723713f
--- /dev/null
+++ b/net-misc/r8125/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>k2k@narod.ru</email>
+ <name>Evgeny Grin</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>Official Realtek r8125 vendor linux driver. The following cards are currently supported:
+RTL8125 RTL8125A RTL8125B(S)(G)</longdescription>
+ <use>
+ <flag name="multi-tx-q">Enable Multiple Tx Queue (&#34;RSS&#34; for sending)</flag>
+ <flag name="ptp">Enable Precision Time Protocol support</flag>
+ <flag name="rss">Enable Receive Side Scaling (RSS)</flag>
+ <flag name="use-firmware">Support automatic firmware loading</flag>
+ </use>
+</pkgmetadata>
diff --git a/net-misc/r8125/r8125-9.007.01.ebuild b/net-misc/r8125/r8125-9.007.01.ebuild
new file mode 100644
index 000000000000..7389ba42cca3
--- /dev/null
+++ b/net-misc/r8125/r8125-9.007.01.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info linux-mod
+
+DESCRIPTION="r8125 vendor driver for Realtek RTL8125 PCI-E NICs"
+HOMEPAGE="https://www.realtek.com/en/component/zoo/category/network-interface-controllers-10-100-1000m-gigabit-ethernet-pci-express-software"
+
+# The alternative direct URL for the file from the link above with description
+# "2.5G Ethernet LINUX driver r8125 for kernel up to 5.6" to avoid CAPTCHA
+SRC_URI="http://rtitwww.realtek.com/rtdrivers/cn/nic1/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+MODULE_NAMES="r8125(net:${S}/src)"
+BUILD_TARGETS="modules"
+IUSE="multi-tx-q ptp rss use-firmware"
+
+CONFIG_CHECK="~!R8169"
+WARNING_R8169="CONFIG_R8169 is enabled. ${PN} will not be loaded unless kernel driver Realtek 8169 PCI Gigabit Ethernet (CONFIG_R8169) is DISABLED."
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KERNELDIR=${KV_DIR}"
+ BUILD_PARAMS+=" ENABLE_PTP_SUPPORT=$(usex ptp y n)"
+ BUILD_PARAMS+=" ENABLE_RSS_SUPPORT=$(usex rss y n)"
+ BUILD_PARAMS+=" ENABLE_MULTIPLE_TX_QUEUE=$(usex multi-tx-q y n)"
+ BUILD_PARAMS+=" ENABLE_USE_FIRMWARE_FILE=$(usex use-firmware y n)"
+}
+
+src_install() {
+ linux-mod_src_install
+ einstalldocs
+}