summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-10-10 15:13:48 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-10-10 15:13:48 +0200
commitab36c5dacec3cd210440834fe2de5766ee32e8cf (patch)
tree75e3a5f1e9677780ff3238b409bcb53030b08c51 /net-misc/lksctp-tools/lksctp-tools-1.0.18-r1.ebuild
parentsys-kernel/gentoo-sources: Linuxpatch 4.9.132 (diff)
downloadgentoo-ab36c5dacec3cd210440834fe2de5766ee32e8cf.tar.gz
gentoo-ab36c5dacec3cd210440834fe2de5766ee32e8cf.tar.bz2
gentoo-ab36c5dacec3cd210440834fe2de5766ee32e8cf.zip
net-misc/lksctp-tools: fix installation of /usr/include/netinet/sctp.h
Closes: https://bugs.gentoo.org/667512 Package-Manager: Portage-2.3.50, Repoman-2.3.11 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'net-misc/lksctp-tools/lksctp-tools-1.0.18-r1.ebuild')
-rw-r--r--net-misc/lksctp-tools/lksctp-tools-1.0.18-r1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/net-misc/lksctp-tools/lksctp-tools-1.0.18-r1.ebuild b/net-misc/lksctp-tools/lksctp-tools-1.0.18-r1.ebuild
new file mode 100644
index 000000000000..8dff226ebe28
--- /dev/null
+++ b/net-misc/lksctp-tools/lksctp-tools-1.0.18-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit flag-o-matic autotools linux-info multilib-minimal
+
+DESCRIPTION="Tools for Linux Kernel Stream Control Transmission Protocol implementation"
+HOMEPAGE="http://lksctp.sourceforge.net/"
+SRC_URI="https://github.com/sctp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( GPL-2+ LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="kernel_linux static-libs"
+
+# This is only supposed to work with Linux to begin with.
+DEPEND=">=sys-kernel/linux-headers-2.6"
+RDEPEND=""
+
+REQUIRED_USE="kernel_linux"
+
+CONFIG_CHECK="~IP_SCTP"
+WARNING_IP_SCTP="CONFIG_IP_SCTP:\tis not set when it should be."
+
+DOCS=( AUTHORS ChangeLog INSTALL NEWS README ROADMAP )
+
+PATCHES=( "${FILESDIR}"/${P}-install-sctp.h.patch )
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ append-flags -fno-strict-aliasing
+
+ local myeconfargs=(
+ --docdir="${EPREFIX%/}"/usr/share/doc/${PF}
+ --enable-shared
+ $(use_enable static-libs static)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ default
+
+ dodoc doc/*txt
+ newdoc src/withsctp/README README.withsctp
+
+ find "${ED}" -name '*.la' -delete || die
+ if ! use static-libs ; then
+ find "${ED}" -name "*.a" -delete || die
+ fi
+}