summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Seichter <github@seichter.de>2020-02-14 12:03:48 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-02-25 08:04:47 +0200
commit20ab017d937b2c2ef418b9ad261f435d182e538b (patch)
treeeb8aac42c0f1a89d52fd1acd9e69311b21321599 /net-misc/httpie
parentmedia-video/openshot: remove redundant longdescription (diff)
downloadgentoo-20ab017d937b2c2ef418b9ad261f435d182e538b.tar.gz
gentoo-20ab017d937b2c2ef418b9ad261f435d182e538b.tar.bz2
gentoo-20ab017d937b2c2ef418b9ad261f435d182e538b.zip
net-misc/httpie: Bump to version 2.0.0
This ebuild also adds support for Python 3.7. Closes: https://bugs.gentoo.org/709438 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Ralph Seichter <gentoo@seichter.de> Closes: https://github.com/gentoo/gentoo/pull/14658 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-misc/httpie')
-rw-r--r--net-misc/httpie/Manifest1
-rw-r--r--net-misc/httpie/httpie-2.0.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/httpie/Manifest b/net-misc/httpie/Manifest
index bd9a04f9dcf2..0ad06b6c9184 100644
--- a/net-misc/httpie/Manifest
+++ b/net-misc/httpie/Manifest
@@ -1 +1,2 @@
DIST httpie-1.0.3.tar.gz 1745537 BLAKE2B 82279804bf10c1882a163f7b361917c9013a5d4ec9ace934f4d89a8c42d18575863cec57768bb4ccfed3b9913a7f2cba593f398a36f87d045a68f21c7237e381 SHA512 80e540dcb92a55fb8b3c5dd56f380cb1795e4296827591853070a5b775c1f87cd881758d9dd0bdfeff383d06ce8ffafe68ec0269e3d269473e528952a769ecb7
+DIST httpie-2.0.0.tar.gz 1752529 BLAKE2B 212e7a142f3efdf1bf238d6eb7e472579a8a8248950caf19ec584eba4f903de09b08433805105a61714046857d32b662f54cde927d20db2a2a1ab81bc99bc753 SHA512 ddac5206107241c9fdc2d2697a31fc7a123c3a01c2ccbd0aad8d52e1472f093b201e422522972cce992bfb2fc7d32ffc6380d457112c83ab643008086f9a7f2d
diff --git a/net-misc/httpie/httpie-2.0.0.ebuild b/net-misc/httpie/httpie-2.0.0.ebuild
new file mode 100644
index 000000000000..12211f339e9b
--- /dev/null
+++ b/net-misc/httpie/httpie-2.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_6 python3_7 )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Modern command line HTTP client"
+HOMEPAGE="https://httpie.org/ https://pypi.org/project/httpie/"
+SRC_URI="https://github.com/jakubroztocil/httpie/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.22.0[${PYTHON_USEDEP}]"
+DEPEND="test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ newbashcomp extras/httpie-completion.bash http
+ insinto /usr/share/fish/vendor_completions.d
+ newins extras/httpie-completion.fish http.fish
+ distutils-r1_python_install_all
+}