summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2024-06-22 18:39:26 -0700
committerJason Zaman <perfinion@gentoo.org>2024-06-22 19:50:52 -0700
commitbb10aad0aed0af2b4a150b454c46c95303eb6613 (patch)
treef825df470aa0243fabdb3da6d0dc84ebad29fa16 /net-misc/gensio
parentapp-crypt/pinentry: Keyword 1.3.0-r3 sparc, #927247 (diff)
downloadgentoo-bb10aad0aed0af2b4a150b454c46c95303eb6613.tar.gz
gentoo-bb10aad0aed0af2b4a150b454c46c95303eb6613.tar.bz2
gentoo-bb10aad0aed0af2b4a150b454c46c95303eb6613.zip
net-misc/gensio: new package, add 2.8.5
Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'net-misc/gensio')
-rw-r--r--net-misc/gensio/Manifest1
-rw-r--r--net-misc/gensio/files/gensio-2.8.5-install-dir.patch16
-rw-r--r--net-misc/gensio/gensio-2.8.5.ebuild75
-rw-r--r--net-misc/gensio/metadata.xml17
4 files changed, 109 insertions, 0 deletions
diff --git a/net-misc/gensio/Manifest b/net-misc/gensio/Manifest
new file mode 100644
index 000000000000..4d862c8842cf
--- /dev/null
+++ b/net-misc/gensio/Manifest
@@ -0,0 +1 @@
+DIST gensio-2.8.5.tar.gz 1550476 BLAKE2B 4a000101a31ce0e1b9ee47e786a3a552b5b2e5863de67491bcfea0a61e55132220b5a62c6e40bb17aeae66ea57b651611e776b1446c6b1c3ac74452238295d95 SHA512 820bceca89085f830d0bdf05147ffa591f63a635311757d0af22a5a0284065e9b50e3bb4bea64bba1114c563e448d11e7f425c311b8f577d7f0f2d17944c9549
diff --git a/net-misc/gensio/files/gensio-2.8.5-install-dir.patch b/net-misc/gensio/files/gensio-2.8.5-install-dir.patch
new file mode 100644
index 000000000000..ddea0cb55402
--- /dev/null
+++ b/net-misc/gensio/files/gensio-2.8.5-install-dir.patch
@@ -0,0 +1,16 @@
+--- gensio-2.8.5.orig/lib/Makefile.am 2024-06-18 21:45:20.427838306 -0700
++++ gensio-2.8.5/lib/Makefile.am 2024-06-18 21:46:09.360860952 -0700
+@@ -385,6 +385,7 @@
+ endif
+
+ install-exec-hook:
++ @(install -d $(DESTDIR)$(gensiolibexecdir))
+ @(cd $(DESTDIR)$(gensiolibexecdir) && $(RM) -f $(gensiolibexec_LTLIBRARIES))
+ @(cd $(DESTDIR)$(gensiolibexecdir) && $(RM) -f $(xgensio_libs))
+
+@@ -392,4 +393,5 @@
+ # libtool will not remove the .so or .dll files since the .la file is
+ # no longer there. We have to do that by hand.
+ uninstall-hook:
++ @(install -d $(DESTDIR)$(gensiolibexecdir))
+ @(cd $(DESTDIR)$(gensiolibexecdir) && $(RM) -f $(xgensio_solibs))
diff --git a/net-misc/gensio/gensio-2.8.5.ebuild b/net-misc/gensio/gensio-2.8.5.ebuild
new file mode 100644
index 000000000000..738d126edafe
--- /dev/null
+++ b/net-misc/gensio/gensio-2.8.5.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+DESCRIPTION="General Stream I/O"
+HOMEPAGE="https://sourceforge.net/projects/ser2net"
+SRC_URI="https://downloads.sourceforge.net/ser2net/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug tcpd"
+
+DEPEND="
+ tcpd? ( sys-apps/tcp-wrappers )
+"
+RDEPEND="${DEPEND}"
+
+# Test suite requires a kernel module
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.8.5-install-dir.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-file-stdio \
+ --without-link-ssl-with-main \
+ --with-uucp-locking \
+ --with-flock-locking \
+ --without-broken-pselect \
+ --with-pthreads \
+ --without-glib \
+ --without-cplusplus \
+ --without-python \
+ --without-go \
+ --without-swig \
+ --without-all-gensios \
+ --without-moduleinstall \
+ --with-net=yes \
+ --with-udp=yes \
+ --with-sctp=no \
+ --with-stdio=yes \
+ --with-pty=yes \
+ --with-serialdev=yes \
+ --with-telnet=yes \
+ --without-tcl \
+ --without-openipmi \
+ --without-ipmisol \
+ --without-mdns \
+ --without-dnssd \
+ --without-alsa \
+ --without-winsound \
+ --without-portaudio \
+ --without-certauth \
+ --without-udev \
+ --without-ssl \
+ --enable-doc \
+ --disable-internal-trace \
+ $(use_with tcpd tcp-wrappers) \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}
diff --git a/net-misc/gensio/metadata.xml b/net-misc/gensio/metadata.xml
new file mode 100644
index 000000000000..846d0822488b
--- /dev/null
+++ b/net-misc/gensio/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>perfinion@gentoo.org</email>
+ <name>Jason Zaman</name>
+ </maintainer>
+
+ <longdescription>
+ A library to abstract stream I/O like serial port, TCP, telnet, UDP, SSL, IPMI SOL, etc.
+ </longdescription>
+
+ <upstream>
+ <remote-id type="sourceforge">ser2net</remote-id>
+ <remote-id type="github">cminyard/gensio</remote-id>
+ </upstream>
+</pkgmetadata>