summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2016-02-01 10:33:49 +0800
committerYixun Lan <dlan@gentoo.org>2016-02-01 10:34:16 +0800
commitfac90e73adb58748e835184fdf5a6d6c309341d7 (patch)
tree0f7f4fc5c6d280a4a9c2d0f106b39a6b489062a6 /net-misc/connman
parentMerge remote-tracking branch 'github/pr/760'. (diff)
downloadgentoo-fac90e73adb58748e835184fdf5a6d6c309341d7.tar.gz
gentoo-fac90e73adb58748e835184fdf5a6d6c309341d7.tar.bz2
gentoo-fac90e73adb58748e835184fdf5a6d6c309341d7.zip
net-misc/connman: version bump 1.31, bug 572550
bump EAPI to 6, drop base.eclass, no more customized systemd unit files thanks Ben Kohler for contribution Package-Manager: portage-2.2.26
Diffstat (limited to 'net-misc/connman')
-rw-r--r--net-misc/connman/Manifest1
-rw-r--r--net-misc/connman/connman-1.31.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/net-misc/connman/Manifest b/net-misc/connman/Manifest
index ea14314be496..c6e0a324ff26 100644
--- a/net-misc/connman/Manifest
+++ b/net-misc/connman/Manifest
@@ -1,3 +1,4 @@
DIST connman-1.27.tar.xz 646520 SHA256 13997824c076af150c68d6d79e48277216e8192278a5c6615cfd4905d65600f5 SHA512 a904d280e16093574b955a23396395fd80640ff5ba767849f5ebae7cea3b10897fb13521376bcd8963cfed091bb0600134205e286d3935a292fcd81be1d2a886 WHIRLPOOL 257b7e38fc773353a905044d7f0540bd2d2b1f3a154daba90e22cd9f8339cf4624f8fa8f4eafbc92bc6e895afeb9b4129ca1a533387828e1746508573a6018e1
DIST connman-1.29.tar.xz 653324 SHA256 2a5a69693566f7fd59b2e677fa89356ada6d709998aa665caef8707b1e7a8594 SHA512 19f623dd23c6312f29bbd570dcb22d31154ffcd16ee66ed2280df3d9d844301f18538418363222d99eabdc33da0021488ed66ba2e4f88df30646004b724538ee WHIRLPOOL 9439cadeb20b72c922b1426da213f8567fe7b0da45f9a4abf270c38687a9d9161a8ee14250623344864d612e130e6f28926918468aaf4346a9e5ff41e6ad22bb
DIST connman-1.30.tar.xz 660952 SHA256 5c5e464bacc9c27ed4e7269fb9b5059f07947f5be26433b59212133663ffa991 SHA512 cc51c9d5ea1732e2408c1e1dfbbab8fc31250df1a584b6a16ac890c80dbb81636b6d62490088ea3090919f1bfa37f33532f404310bd0932e93b21af5f330af44 WHIRLPOOL a485caeba4b74037ca5746df27e6d26c9f34de56a0c8471220d1e40fd7c04ba96e3bd9dbf5ac20772f12af1900b4341f3cdf2aef39adc200adaee8b36eb75888
+DIST connman-1.31.tar.xz 668120 SHA256 88fcf0b6df334796b90e2fd2e434d6f5b36cd6f13b886a119b8c90276b72b8e2 SHA512 f9871ead096ead37d3bc524fb143ec8c88125e9c18b5eb1f451581b9a2061719e90361e5b7f3e09901701707d977c42c630457b0ead8e76e04e964a7542c7bbd WHIRLPOOL 0e7f73e1d83a862fb33d2a3b6983c00b2305fea95803836d5dadbb31a8a55d19e2a21447e5e5654b04b0320929eaef2eba99b5921ab4a6fbf2d89e3befbe81b4
diff --git a/net-misc/connman/connman-1.31.ebuild b/net-misc/connman/connman-1.31.ebuild
new file mode 100644
index 000000000000..feaa43563d66
--- /dev/null
+++ b/net-misc/connman/connman-1.31.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+inherit systemd
+
+DESCRIPTION="Provides a daemon for managing internet connections"
+HOMEPAGE="https://01.org/connman"
+SRC_URI="mirror://kernel/linux/network/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="bluetooth debug doc examples +ethernet l2tp ofono openvpn openconnect pptp policykit tools vpnc +wifi wispr"
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=sys-apps/dbus-1.2.24
+ >=net-firewall/iptables-1.4.8
+ bluetooth? ( net-wireless/bluez )
+ l2tp? ( net-dialup/xl2tpd )
+ ofono? ( net-misc/ofono )
+ openconnect? ( net-misc/openconnect )
+ openvpn? ( net-misc/openvpn )
+ policykit? ( sys-auth/polkit )
+ pptp? ( net-dialup/pptpclient )
+ vpnc? ( net-misc/vpnc )
+ wifi? ( >=net-wireless/wpa_supplicant-2.0[dbus] )
+ wispr? ( net-libs/gnutls )"
+
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.39"
+
+PATCHES=( "${FILESDIR}/${PN}-1.16-execinfo-assumptions.patch" )
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --enable-client \
+ --enable-datafiles \
+ --enable-loopback=builtin \
+ $(use_enable examples test) \
+ $(use_enable ethernet ethernet builtin) \
+ $(use_enable wifi wifi builtin) \
+ $(use_enable bluetooth bluetooth builtin) \
+ $(use_enable l2tp l2tp builtin) \
+ $(use_enable ofono ofono builtin) \
+ $(use_enable openconnect openconnect builtin) \
+ $(use_enable openvpn openvpn builtin) \
+ $(use_enable policykit polkit builtin) \
+ $(use_enable pptp pptp builtin) \
+ $(use_enable vpnc vpnc builtin) \
+ $(use_enable wispr wispr builtin) \
+ $(use_enable debug) \
+ $(use_enable tools) \
+ --disable-iospm \
+ --disable-hh2serial-gps
+}
+
+src_install() {
+ default
+ dobin client/connmanctl
+
+ if use doc; then
+ dodoc doc/*.txt
+ fi
+ keepdir /var/lib/${PN}
+ newinitd "${FILESDIR}"/${PN}.initd2 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}