summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicholas Vinson <nvinson234@gmail.com>2016-04-27 07:00:42 -0700
committerSam Jorna <wraeth@gentoo.org>2016-04-29 17:29:38 +1000
commitf600ad8e74a53e37d8e1657789959523a2c6e84d (patch)
tree153ceb0e164dcef4e52c5f4838955b2e48e94147 /net-misc/connman
parentnet-misc/connman: Version bump to 1.32 (diff)
downloadgentoo-f600ad8e74a53e37d8e1657789959523a2c6e84d.tar.gz
gentoo-f600ad8e74a53e37d8e1657789959523a2c6e84d.tar.bz2
gentoo-f600ad8e74a53e37d8e1657789959523a2c6e84d.zip
net-misc/connman remove outdated versions
Closes: https://github.com/gentoo/gentoo/pull/1373
Diffstat (limited to 'net-misc/connman')
-rw-r--r--net-misc/connman/connman-1.31-r1.ebuild74
-rw-r--r--net-misc/connman/files/connman-1.31-iptables-1.6.0.patch36
2 files changed, 0 insertions, 110 deletions
diff --git a/net-misc/connman/connman-1.31-r1.ebuild b/net-misc/connman/connman-1.31-r1.ebuild
deleted file mode 100644
index 2b1ee4634177..000000000000
--- a/net-misc/connman/connman-1.31-r1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="6"
-inherit systemd
-
-DESCRIPTION="Provides a daemon for managing internet connections"
-HOMEPAGE="https://01.org/connman"
-SRC_URI="mirror://kernel/linux/network/${PN}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
-IUSE="bluetooth debug doc examples +ethernet l2tp ofono openvpn openconnect pptp policykit tools vpnc +wifi wispr"
-
-RDEPEND=">=dev-libs/glib-2.16
- >=sys-apps/dbus-1.2.24
- >=net-firewall/iptables-1.4.8
- bluetooth? ( net-wireless/bluez )
- l2tp? ( net-dialup/xl2tpd )
- ofono? ( net-misc/ofono )
- openconnect? ( net-misc/openconnect )
- openvpn? ( net-misc/openvpn )
- policykit? ( sys-auth/polkit )
- pptp? ( net-dialup/pptpclient )
- vpnc? ( net-misc/vpnc )
- wifi? ( >=net-wireless/wpa_supplicant-2.0[dbus] )
- wispr? ( net-libs/gnutls )"
-
-DEPEND="${RDEPEND}
- >=sys-kernel/linux-headers-2.6.39"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.16-execinfo-assumptions.patch"
- "${FILESDIR}/${PN}-1.31-iptables-1.6.0.patch"
- "${FILESDIR}/${PN}-1.31-xtables.patch"
-)
-
-src_configure() {
- econf \
- --localstatedir=/var \
- --enable-client \
- --enable-datafiles \
- --enable-loopback=builtin \
- $(use_enable examples test) \
- $(use_enable ethernet ethernet builtin) \
- $(use_enable wifi wifi builtin) \
- $(use_enable bluetooth bluetooth builtin) \
- $(use_enable l2tp l2tp builtin) \
- $(use_enable ofono ofono builtin) \
- $(use_enable openconnect openconnect builtin) \
- $(use_enable openvpn openvpn builtin) \
- $(use_enable policykit polkit builtin) \
- $(use_enable pptp pptp builtin) \
- $(use_enable vpnc vpnc builtin) \
- $(use_enable wispr wispr builtin) \
- $(use_enable debug) \
- $(use_enable tools) \
- --disable-iospm \
- --disable-hh2serial-gps
-}
-
-src_install() {
- default
- dobin client/connmanctl
-
- if use doc; then
- dodoc doc/*.txt
- fi
- keepdir /var/lib/${PN}
- newinitd "${FILESDIR}"/${PN}.initd2 ${PN}
- newconfd "${FILESDIR}"/${PN}.confd ${PN}
-}
diff --git a/net-misc/connman/files/connman-1.31-iptables-1.6.0.patch b/net-misc/connman/files/connman-1.31-iptables-1.6.0.patch
deleted file mode 100644
index 30131e690bb1..000000000000
--- a/net-misc/connman/files/connman-1.31-iptables-1.6.0.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From acea08a0e4234a4c1a87bedc087c73ff36de0c7b Mon Sep 17 00:00:00 2001
-From: Wu Zheng <wu.zheng@intel.com>
-Date: Thu, 28 Jan 2016 18:04:17 +0800
-Subject: iptables: Add missing function item of xtables to match iptables 1.6
-
-The struct of xtables_globals has been modified in iptables 1.6.
-If connman runs with iptables 1.6, it can crash.
-
-Program received signal SIGSEGV, Segmentation fault.
-0x00000000 in ?? ()
-0xb7dea89c in xtables_find_target () from /usr/lib/libxtables.so.11
-0xb7deac1c in ?? () from /usr/lib/libxtables.so.11
-0xb7dea793 in xtables_find_target () from /usr/lib/libxtables.so.11
-
-The the missing function item of xtables is added to xtables_globals.
----
- src/iptables.c | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/src/iptables.c b/src/iptables.c
-index bc0c763..5ef757a 100644
---- a/src/iptables.c
-+++ b/src/iptables.c
-@@ -1566,6 +1566,9 @@ struct xtables_globals iptables_globals = {
- .option_offset = 0,
- .opts = iptables_opts,
- .orig_opts = iptables_opts,
-+#if XTABLES_VERSION_CODE > 10
-+ .compat_rev = xtables_compatible_revision,
-+#endif
- };
-
- static struct xtables_target *prepare_target(struct connman_iptables *table,
---
-cgit v0.12
-