summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicholas Vinson <nvinson234@gmail.com>2016-10-08 12:09:05 -0700
committerYixun Lan <dlan@gentoo.org>2016-10-11 16:59:02 +0800
commit6b88e653f4cc941302f16d1bf7a85412657a478b (patch)
tree9bac05342c4f014cab08d4e019a9967ef312224b /net-misc/connman
parentsys-fs/e2fsprogs: Stable for HPPA (bug #596788). (diff)
downloadgentoo-6b88e653f4cc941302f16d1bf7a85412657a478b.tar.gz
gentoo-6b88e653f4cc941302f16d1bf7a85412657a478b.tar.bz2
gentoo-6b88e653f4cc941302f16d1bf7a85412657a478b.zip
net-misc/connman: Fix polkit check, resolv.conf overwrite issue
Fixes the broken pollkit detection error Fixes the issue of /etc/resolv.conf being overwritten unconditionally Removes the unneeded hunks from the connman-1.32-execinfo-assumptions.patch Gentoo-bug: #591596 Gentoo-bug: #596270 Gentoo-bug: #596276 Closes: https://github.com/gentoo/gentoo/pull/2515 Package-Manager: portage-2.3.1 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'net-misc/connman')
-rw-r--r--net-misc/connman/connman-1.33-r1.ebuild82
-rw-r--r--net-misc/connman/files/connman-1.32-execinfo-assumptions.patch25
-rw-r--r--net-misc/connman/files/connman-1.33-polkit-configure-check-fix.patch15
-rw-r--r--net-misc/connman/files/connman-1.33-resolv-conf-overwrite.patch6
4 files changed, 103 insertions, 25 deletions
diff --git a/net-misc/connman/connman-1.33-r1.ebuild b/net-misc/connman/connman-1.33-r1.ebuild
new file mode 100644
index 000000000000..6e1388919460
--- /dev/null
+++ b/net-misc/connman/connman-1.33-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+inherit autotools systemd
+
+DESCRIPTION="Provides a daemon for managing internet connections"
+HOMEPAGE="https://01.org/connman"
+SRC_URI="mirror://kernel/linux/network/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="bluetooth debug doc examples +ethernet l2tp ofono openvpn openconnect pptp policykit tools vpnc +wifi wispr"
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=sys-apps/dbus-1.2.24
+ >=net-firewall/iptables-1.4.8
+ bluetooth? ( net-wireless/bluez )
+ l2tp? ( net-dialup/xl2tpd )
+ ofono? ( net-misc/ofono )
+ openconnect? ( net-misc/openconnect )
+ openvpn? ( net-misc/openvpn )
+ policykit? ( sys-auth/polkit )
+ pptp? ( net-dialup/pptpclient )
+ vpnc? ( net-misc/vpnc )
+ wifi? ( >=net-wireless/wpa_supplicant-2.0[dbus] )
+ wispr? ( net-libs/gnutls )"
+
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.39
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.31-xtables.patch"
+ "${FILESDIR}/${PN}-1.33-polkit-configure-check-fix.patch"
+ "${FILESDIR}/${PN}-1.33-resolv-conf-overwrite.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --with-systemdunitdir=$(systemd_get_systemunitdir) \
+ --with-tmpfilesdir=${EPRIFEX}/usr/lib/tmpfiles.d \
+ --enable-client \
+ --enable-datafiles \
+ --enable-loopback=builtin \
+ $(use_enable examples test) \
+ $(use_enable ethernet ethernet builtin) \
+ $(use_enable wifi wifi builtin) \
+ $(use_enable bluetooth bluetooth builtin) \
+ $(use_enable l2tp l2tp builtin) \
+ $(use_enable ofono ofono builtin) \
+ $(use_enable openconnect openconnect builtin) \
+ $(use_enable openvpn openvpn builtin) \
+ $(use_enable policykit polkit builtin) \
+ $(use_enable pptp pptp builtin) \
+ $(use_enable vpnc vpnc builtin) \
+ $(use_enable wispr wispr builtin) \
+ $(use_enable debug) \
+ $(use_enable tools) \
+ --disable-iospm \
+ --disable-hh2serial-gps
+}
+
+src_install() {
+ default
+ dobin client/connmanctl
+
+ if use doc; then
+ dodoc doc/*.txt
+ fi
+ keepdir /var/lib/${PN}
+ newinitd "${FILESDIR}"/${PN}.initd2 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}
diff --git a/net-misc/connman/files/connman-1.32-execinfo-assumptions.patch b/net-misc/connman/files/connman-1.32-execinfo-assumptions.patch
index eb8e4fc0c131..c27e89610cd9 100644
--- a/net-misc/connman/files/connman-1.32-execinfo-assumptions.patch
+++ b/net-misc/connman/files/connman-1.32-execinfo-assumptions.patch
@@ -1,28 +1,3 @@
-diff -uNr a/config.h.in b/config.h.in
---- a/config.h.in 2013-07-02 17:41:03.715261748 +0000
-+++ b/config.h.in 2013-07-02 17:41:21.707260667 +0000
-@@ -3,6 +3,9 @@
- /* Define to 1 if you have the <dlfcn.h> header file. */
- #undef HAVE_DLFCN_H
-
-+/* Define to 1 if you have the <execinfo.h> header file. */
-+#undef HAVE_EXECINFO_H
-+
- /* Define to 1 if you have the <inttypes.h> header file. */
- #undef HAVE_INTTYPES_H
-
-diff -uNr a/configure.ac b/configure.ac
---- a/configure.ac 2013-07-02 17:41:03.715261748 +0000
-+++ b/configure.ac 2013-07-02 17:41:21.719260666 +0000
-@@ -181,6 +181,8 @@
- AC_CHECK_FUNC(signalfd, dummy=yes,
- AC_MSG_ERROR(signalfd support is required))
-
-+AC_CHECK_HEADERS([execinfo.h], [], [])
-+
- AC_CHECK_LIB(dl, dlopen, dummy=yes,
- AC_MSG_ERROR(dynamic linking loader is required))
-
diff -uNr a/src/backtrace.c b/src/backtrace.c
--- a/src/backtrace.c 2013-07-02 17:41:03.727261747 +0000
+++ b/src/backtrace.c 2013-07-02 17:42:12.717257603 +0000
diff --git a/net-misc/connman/files/connman-1.33-polkit-configure-check-fix.patch b/net-misc/connman/files/connman-1.33-polkit-configure-check-fix.patch
new file mode 100644
index 000000000000..57ef5e8ccbac
--- /dev/null
+++ b/net-misc/connman/files/connman-1.33-polkit-configure-check-fix.patch
@@ -0,0 +1,15 @@
+--- connman-1.33/configure.ac.old 2016-10-09 11:26:43.137856416 -0700
++++ connman-1.33/configure.ac 2016-10-09 11:26:52.819722799 -0700
+@@ -281,11 +281,11 @@ AM_CONDITIONAL(NMCOMPAT, test "${enable_
+
+ AC_ARG_ENABLE(polkit, AC_HELP_STRING([--enable-polkit],
+ [enable PolicyKit support]),
+ [enable_polkit=${enableval}], [enable_polkit="no"])
+ if (test "${enable_polkit}" != "no"); then
+- POLKIT_DATADIR="`$PKG_CONFIG --variable=actiondir polkit`"
++ POLKIT_DATADIR="`$PKG_CONFIG --variable=actiondir polkit-gobject-1`"
+ POLKIT_DATADIR=""
+ if (test -z "${POLKIT_DATADIR}"); then
+ POLKIT_DATADIR="${datadir}/polkit-1/actions"
+ fi
+ AC_SUBST(POLKIT_DATADIR)
diff --git a/net-misc/connman/files/connman-1.33-resolv-conf-overwrite.patch b/net-misc/connman/files/connman-1.33-resolv-conf-overwrite.patch
new file mode 100644
index 000000000000..49bb8ba3c5a1
--- /dev/null
+++ b/net-misc/connman/files/connman-1.33-resolv-conf-overwrite.patch
@@ -0,0 +1,6 @@
+--- connman-1.33/scripts/connman_resolvconf.conf.in.old 2016-10-09 11:27:20.425341843 -0700
++++ connman-1.33/scripts/connman_resolvconf.conf.in 2016-10-09 11:27:10.662476565 -0700
+@@ -1,2 +1,2 @@
+ d @runstatedir@/connman - - - -
+-L+ /etc/resolv.conf - - - - @runstatedir@/connman/resolv.conf
++L /etc/resolv.conf - - - - @runstatedir@/connman/resolv.conf