summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/kuvert
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/kuvert')
-rw-r--r--net-mail/kuvert/Manifest1
-rw-r--r--net-mail/kuvert/files/kuvert-1.1.8-idea.patch20
-rw-r--r--net-mail/kuvert/kuvert-2.0.4.ebuild44
-rw-r--r--net-mail/kuvert/metadata.xml5
4 files changed, 70 insertions, 0 deletions
diff --git a/net-mail/kuvert/Manifest b/net-mail/kuvert/Manifest
new file mode 100644
index 000000000000..d757bd73a7f2
--- /dev/null
+++ b/net-mail/kuvert/Manifest
@@ -0,0 +1 @@
+DIST kuvert_2.0.4.tar.gz 118352 SHA256 f04abf78c538dc24d1900f1a009f27cd92a5cc9659002229fdd6de7b2c62b983
diff --git a/net-mail/kuvert/files/kuvert-1.1.8-idea.patch b/net-mail/kuvert/files/kuvert-1.1.8-idea.patch
new file mode 100644
index 000000000000..d714e4eb4773
--- /dev/null
+++ b/net-mail/kuvert/files/kuvert-1.1.8-idea.patch
@@ -0,0 +1,20 @@
+--- kuvert.orig 2004-09-03 21:29:11.871880016 +0100
++++ kuvert 2004-09-03 21:28:59.299791264 +0100
+@@ -1179,7 +1179,7 @@
+ $cmd.="|$config{gpgpath} -q -t --batch --armor --detach-sign --passphrase-fd 0 --status-fd 1 --default-key";
+ if ($type eq "std")
+ {
+- $cmd.=" $config{stdkey} --rfc1991 --cipher-algo idea --digest-algo md5 --compress-algo 1";
++ $cmd.=" $config{stdkey} --rfc1991 --digest-algo md5 --compress-algo 1";
+ }
+ else
+ {
+@@ -1296,7 +1296,7 @@
+
+ # and finally encrypt all this for the wanted recipients.
+ unlink($outfile);
+- $cmd="$config{gpgpath} --no-literal --batch --encrypt --rfc1991 --cipher-algo idea "
++ $cmd="$config{gpgpath} --no-literal --batch --encrypt --rfc1991"
+ .($config{alwaystrust}?"--always-trust ":"")
+ ."--armor -o $outfile -r "
+ .join(" -r ",@recips)
diff --git a/net-mail/kuvert/kuvert-2.0.4.ebuild b/net-mail/kuvert/kuvert-2.0.4.ebuild
new file mode 100644
index 000000000000..768ced50c4c4
--- /dev/null
+++ b/net-mail/kuvert/kuvert-2.0.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit toolchain-funcs
+
+MY_P=${P/-/_}
+
+DESCRIPTION="An MTA wrapper that automatically signs and/or encrypts
+outgoing mail"
+HOMEPAGE="http://www.snafu.priv.at/mystuff/kuvert/"
+SRC_URI="http://www.snafu.priv.at/mystuff/kuvert/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 ~ppc"
+IUSE=""
+SLOT="0"
+
+S="${WORKDIR}/${PN}"
+
+DEPEND=""
+RDEPEND="app-crypt/gnupg
+ sys-apps/keyutils
+ dev-perl/MailTools
+ dev-perl/MIME-tools
+ dev-perl/Authen-SASL
+ dev-perl/File-Slurp
+ dev-perl/Net-Server-Mail
+ virtual/perl-IO
+ virtual/perl-File-Temp
+ virtual/perl-Time-HiRes
+ dev-lang/perl
+ virtual/perl-libnet
+ virtual/mta"
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc dot-kuvert README THANKS TODO
+}
diff --git a/net-mail/kuvert/metadata.xml b/net-mail/kuvert/metadata.xml
new file mode 100644
index 000000000000..196134491c70
--- /dev/null
+++ b/net-mail/kuvert/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+</pkgmetadata>