summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbrahmajit das <listout@protonmail.com>2022-08-24 02:12:53 +0530
committerSam James <sam@gentoo.org>2022-09-01 03:05:39 +0100
commite0f44742d199c1806c2d1d6d0497f75fb65b2b9c (patch)
treedc613ca999f863d9ee206895954b4909af20c916 /net-libs
parentmedia-libs/opencolorio: Fix strtol_l on musl (diff)
downloadgentoo-e0f44742d199c1806c2d1d6d0497f75fb65b2b9c.tar.gz
gentoo-e0f44742d199c1806c2d1d6d0497f75fb65b2b9c.tar.bz2
gentoo-e0f44742d199c1806c2d1d6d0497f75fb65b2b9c.zip
net-libs/libbtbb: Fix unknown type u_char on musl
Build fails with error: unknown type name u_char Closes: https://bugs.gentoo.org/829245 Closes: https://bugs.gentoo.org/715758 Signed-off-by: brahmajit das <listout@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/26549 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libbtbb/files/libbtbb-2020.12.1-musl-u-char.patch14
-rw-r--r--net-libs/libbtbb/libbtbb-2020.12.1-r1.ebuild4
2 files changed, 18 insertions, 0 deletions
diff --git a/net-libs/libbtbb/files/libbtbb-2020.12.1-musl-u-char.patch b/net-libs/libbtbb/files/libbtbb-2020.12.1-musl-u-char.patch
new file mode 100644
index 000000000000..7065e000477d
--- /dev/null
+++ b/net-libs/libbtbb/files/libbtbb-2020.12.1-musl-u-char.patch
@@ -0,0 +1,14 @@
+# Fix unknown type name 'u_char' on musl
+# Closes: https://bugs.gentoo.org/829245
+# Closes: https://bugs.gentoo.org/715758
+# Upstream PR: https://github.com/greatscottgadgets/libbtbb/pull/64
+--- a/lib/src/pcap.c
++++ b/lib/src/pcap.c
+@@ -27,6 +27,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <assert.h>
++#include <sys/types.h>
+
+ typedef enum {
+ PCAP_OK = 0,
diff --git a/net-libs/libbtbb/libbtbb-2020.12.1-r1.ebuild b/net-libs/libbtbb/libbtbb-2020.12.1-r1.ebuild
index c6a7e694e720..ccc78dfda1b0 100644
--- a/net-libs/libbtbb/libbtbb-2020.12.1-r1.ebuild
+++ b/net-libs/libbtbb/libbtbb-2020.12.1-r1.ebuild
@@ -23,6 +23,10 @@ LICENSE="GPL-2"
SLOT="0/${PV}"
IUSE="static-libs"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2020.12.1-musl-u-char.patch
+)
+
src_configure() {
local mycmakeargs=(
-DENABLE_PYTHON=OFF