summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFilip Kobierski <fkobi@pm.me>2024-08-28 17:47:52 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-08-30 10:25:29 +0300
commitc6fb0d7f4590b73d7f9e91fd3a18409065b2513a (patch)
tree15cbae62709f87450177c9fe3b8dbecb06cbbc54 /net-libs
parentnet-libs/gloox: drop 1.0.24-r0 (diff)
downloadgentoo-c6fb0d7f4590b73d7f9e91fd3a18409065b2513a.tar.gz
gentoo-c6fb0d7f4590b73d7f9e91fd3a18409065b2513a.tar.bz2
gentoo-c6fb0d7f4590b73d7f9e91fd3a18409065b2513a.zip
net-libs/gloox: add 1.0.28 with xhtmlim USE flag
- add virtual/pkgconfig to BDEPEND Thanks juippis! Signed-off-by: Filip Kobierski <fkobi@pm.me> Closes: https://github.com/gentoo/gentoo/pull/38217 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gloox/Manifest1
-rw-r--r--net-libs/gloox/gloox-1.0.28.ebuild53
-rw-r--r--net-libs/gloox/metadata.xml3
3 files changed, 57 insertions, 0 deletions
diff --git a/net-libs/gloox/Manifest b/net-libs/gloox/Manifest
index 6f894687f9ed..595f947f50a5 100644
--- a/net-libs/gloox/Manifest
+++ b/net-libs/gloox/Manifest
@@ -1 +1,2 @@
DIST gloox-1.0.24.tar.bz2 727442 BLAKE2B 57e8916ddf057c115350e005a027e3a81684269f688dd80126bf3753a8dd71a8d64a86e1eb59de2886a6657ad1dac5f9431549db79f314173f49233044b52cb5 SHA512 e3ddb331a57e635b8da5d8cd36a89fa9521599301d1108a025a3526a02df5bf73555d54bccd3706fdffd857134716b23df6bf57a59a17be4f6a7873a810268ee
+DIST gloox-1.0.28.tar.bz2 728337 BLAKE2B dcbabba6707fb92c8e1619ff4d4568a723c448aca2dd1fdd8fb0ca1d96e0e9f07f5848a64447c22d03a7d2ac7c80702bbdbc4d11249da1801c31e71bd17fabf3 SHA512 8be06963a54957d53bb285482d2ad01569fb281fcb53b03a29dc4444e1915f2f7d81e3fec1288f127bc09ca37d1c0beb4cb8e4f7079becb32dc223e3ceb50e00
diff --git a/net-libs/gloox/gloox-1.0.28.ebuild b/net-libs/gloox/gloox-1.0.28.ebuild
new file mode 100644
index 000000000000..4f9c9456987e
--- /dev/null
+++ b/net-libs/gloox/gloox-1.0.28.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_P="${P/_/-}"
+DESCRIPTION="A portable high-level Jabber/XMPP client library for C++"
+HOMEPAGE="https://camaya.net/gloox/"
+SRC_URI="https://camaya.net/download/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3"
+# Check upstream changelog: https://camaya.net/gloox/changelog/
+SLOT="0/18"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug gnutls idn ssl static-libs test +xhtmlim zlib"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ idn? ( net-dns/libidn:= )
+ gnutls? ( net-libs/gnutls:= )
+ ssl? ( dev-libs/openssl:0= )
+ zlib? ( sys-libs/zlib )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --without-examples # not installed anyway so don't build them
+ $(usex debug "--enable-debug" '')
+ $(use_enable static-libs static)
+ $(use_enable xhtmlim)
+ $(use_with idn libidn)
+ $(use_with gnutls)
+ $(use_with ssl openssl)
+ $(use_with test tests)
+ $(use_with zlib)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name "*.la" -delete || die
+}
diff --git a/net-libs/gloox/metadata.xml b/net-libs/gloox/metadata.xml
index 8ae7ea99aee3..f8414a9a0073 100644
--- a/net-libs/gloox/metadata.xml
+++ b/net-libs/gloox/metadata.xml
@@ -5,4 +5,7 @@
<upstream>
<changelog>https://camaya.net/gloox/changelog/</changelog>
</upstream>
+ <use>
+ <flag name="xhtmlim">expose internal NodeList for optional XHTML-IM rendering without external parser</flag>
+ </use>
</pkgmetadata>