summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-16 02:44:50 +0000
committerSam James <sam@gentoo.org>2022-01-16 02:45:48 +0000
commitaa8c75638bbc8e9d35f33478ab3b0e18b83f19dc (patch)
tree32d6845ee5f37eba6cea13d0b3dcefefab68bd60 /net-libs
parentmedia-video/handbrake: drop 1.3.3-r4, 1.3.3-r5 (diff)
downloadgentoo-aa8c75638bbc8e9d35f33478ab3b0e18b83f19dc.tar.gz
gentoo-aa8c75638bbc8e9d35f33478ab3b0e18b83f19dc.tar.bz2
gentoo-aa8c75638bbc8e9d35f33478ab3b0e18b83f19dc.zip
net-libs/webkit-gtk: test if linker supports --no-keep-memory
For example, mold doesn't. Closes: https://bugs.gentoo.org/831282 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.34.3.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.34.3.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.34.3.ebuild
index ad4b0169d88f..a6cb56d76a50 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.34.3.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.34.3.ebuild
@@ -184,7 +184,7 @@ src_configure() {
# Try to use less memory, bug #469942 (see Fedora .spec for reference)
# --no-keep-memory doesn't work on ia64, bug #502492
if ! use ia64; then
- append-ldflags "-Wl,--no-keep-memory"
+ append-ldflags $(test-flags-CCLD "-Wl,--no-keep-memory")
fi
# Ruby situation is a bit complicated. See bug 513888