summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWANG Xuerui <xen0n@gentoo.org>2022-10-05 16:39:01 +0800
committerSam James <sam@gentoo.org>2022-10-28 16:57:12 +0100
commita5c7606a4cf5173622127ea833cdf7880aa786a9 (patch)
treea95ccea2c1a96f95fc19854157ca56b3b4ab3a13 /net-libs
parentdev-lang/jsonnet: fix build on gcc-13 (diff)
downloadgentoo-a5c7606a4cf5173622127ea833cdf7880aa786a9.tar.gz
gentoo-a5c7606a4cf5173622127ea833cdf7880aa786a9.tar.bz2
gentoo-a5c7606a4cf5173622127ea833cdf7880aa786a9.zip
net-libs/nodejs: fix build on gcc-13
Closes: https://bugs.gentoo.org/865981 Closes: https://github.com/gentoo/gentoo/pull/27654 Signed-off-by: WANG Xuerui <xen0n@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nodejs/files/nodejs-gcc-13.patch27
-rw-r--r--net-libs/nodejs/nodejs-14.20.1.ebuild1
-rw-r--r--net-libs/nodejs/nodejs-16.17.1.ebuild1
-rw-r--r--net-libs/nodejs/nodejs-18.10.0.ebuild1
-rw-r--r--net-libs/nodejs/nodejs-18.9.1.ebuild1
5 files changed, 31 insertions, 0 deletions
diff --git a/net-libs/nodejs/files/nodejs-gcc-13.patch b/net-libs/nodejs/files/nodejs-gcc-13.patch
new file mode 100644
index 000000000000..13427a6b7407
--- /dev/null
+++ b/net-libs/nodejs/files/nodejs-gcc-13.patch
@@ -0,0 +1,27 @@
+https://chromium-review.googlesource.com/c/v8/v8/+/3934140
+adjusted to layout of the node project
+From: WANG Xuerui <git@xen0n.name>
+Date: Tue, 4 Oct 2022 17:21:03 +0800
+Subject: [PATCH] [base] Fix build with gcc-13
+
+See https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes.
+--- a/deps/v8/src/base/logging.h
++++ b/deps/v8/src/base/logging.h
+@@ -5,6 +5,7 @@
+ #ifndef V8_BASE_LOGGING_H_
+ #define V8_BASE_LOGGING_H_
+
++#include <cstdint>
+ #include <cstring>
+ #include <sstream>
+ #include <string>
+--- a/deps/v8/src/inspector/v8-string-conversions.h
++++ b/deps/v8/src/inspector/v8-string-conversions.h
+@@ -5,6 +5,7 @@
+ #ifndef V8_INSPECTOR_V8_STRING_CONVERSIONS_H_
+ #define V8_INSPECTOR_V8_STRING_CONVERSIONS_H_
+
++#include <cstdint>
+ #include <string>
+
+ // Conversion routines between UT8 and UTF16, used by string-16.{h,cc}. You may
diff --git a/net-libs/nodejs/nodejs-14.20.1.ebuild b/net-libs/nodejs/nodejs-14.20.1.ebuild
index ec4700ccab22..c2dfc7980d1c 100644
--- a/net-libs/nodejs/nodejs-14.20.1.ebuild
+++ b/net-libs/nodejs/nodejs-14.20.1.ebuild
@@ -55,6 +55,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-12.22.5-shared_c-ares_nameser_h.patch
"${FILESDIR}"/${PN}-14.15.0-fix_ppc64_crashes.patch
"${FILESDIR}"/${PN}-14.19.0-global-npm-config.patch
+ "${FILESDIR}"/${PN}-gcc-13.patch
)
pkg_pretend() {
diff --git a/net-libs/nodejs/nodejs-16.17.1.ebuild b/net-libs/nodejs/nodejs-16.17.1.ebuild
index c1fd507566a4..9492c22083ac 100644
--- a/net-libs/nodejs/nodejs-16.17.1.ebuild
+++ b/net-libs/nodejs/nodejs-16.17.1.ebuild
@@ -51,6 +51,7 @@ DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${PN}-12.22.5-shared_c-ares_nameser_h.patch
"${FILESDIR}"/${PN}-15.2.0-global-npm-config.patch
+ "${FILESDIR}"/${PN}-gcc-13.patch
)
pkg_pretend() {
diff --git a/net-libs/nodejs/nodejs-18.10.0.ebuild b/net-libs/nodejs/nodejs-18.10.0.ebuild
index 3ffd13f46228..fec5881c4739 100644
--- a/net-libs/nodejs/nodejs-18.10.0.ebuild
+++ b/net-libs/nodejs/nodejs-18.10.0.ebuild
@@ -51,6 +51,7 @@ DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${PN}-12.22.5-shared_c-ares_nameser_h.patch
"${FILESDIR}"/${PN}-15.2.0-global-npm-config.patch
+ "${FILESDIR}"/${PN}-gcc-13.patch
)
# These are measured on a loong machine with -ggdb on, and only checked
diff --git a/net-libs/nodejs/nodejs-18.9.1.ebuild b/net-libs/nodejs/nodejs-18.9.1.ebuild
index 9d98aef6f3b6..c4fe0dccc534 100644
--- a/net-libs/nodejs/nodejs-18.9.1.ebuild
+++ b/net-libs/nodejs/nodejs-18.9.1.ebuild
@@ -51,6 +51,7 @@ DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${PN}-12.22.5-shared_c-ares_nameser_h.patch
"${FILESDIR}"/${PN}-15.2.0-global-npm-config.patch
+ "${FILESDIR}"/${PN}-gcc-13.patch
)
# These are measured on a loong machine with -ggdb on, and only checked