summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2024-03-10 18:53:35 +0100
committerGuilherme Amadio <amadio@gentoo.org>2024-03-10 18:53:35 +0100
commit95ac3cc2e868f2f724a2c66adc5849cea2b99e35 (patch)
treee13e9378f2ef74de0478c95418f80d828c68ce3f /net-libs
parentnet-fs/cvmfs: fix path for pidof, bug 917748 (diff)
downloadgentoo-95ac3cc2e868f2f724a2c66adc5849cea2b99e35.tar.gz
gentoo-95ac3cc2e868f2f724a2c66adc5849cea2b99e35.tar.bz2
gentoo-95ac3cc2e868f2f724a2c66adc5849cea2b99e35.zip
net-libs/pacparser: fix compilation with GCC 14, bug 919375
Closes: https://bugs.gentoo.org/919375 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/pacparser/pacparser-1.4.2.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/net-libs/pacparser/pacparser-1.4.2.ebuild b/net-libs/pacparser/pacparser-1.4.2.ebuild
index e3cd424765ae..87e64cf6c25f 100644
--- a/net-libs/pacparser/pacparser-1.4.2.ebuild
+++ b/net-libs/pacparser/pacparser-1.4.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -27,6 +27,8 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
src_prepare() {
default
+ sed -e 's/^SMCFLAGS.*/SMCFLAGS = -DHAVE_VA_COPY -DVA_COPY=va_copy -DHAVE_VA_LIST_AS_ARRAY/' \
+ -i src/Makefile || die
sed -e '/CC = gcc/d' \
-i src/spidermonkey/js/src/config/Linux_All.mk || die
@@ -37,8 +39,7 @@ src_prepare() {
src_compile() {
# Upstream parallel compilation bug, do that first to work around
- emake -C src/spidermonkey
- emake -C src
+ emake -C src -j1
use python && python_foreach_impl emake -C src pymod
}