summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 19:43:17 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:12:13 +0100
commit67ff77e87f243a28e94620a89843a8b631591ae8 (patch)
treedd055105c9e5c668c622229b4a6950a341da0210 /net-libs
parentdev-util/mutrace: port to EAPI 7 (diff)
downloadgentoo-67ff77e87f243a28e94620a89843a8b631591ae8.tar.gz
gentoo-67ff77e87f243a28e94620a89843a8b631591ae8.tar.bz2
gentoo-67ff77e87f243a28e94620a89843a8b631591ae8.zip
net-libs/gsnmp: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gsnmp/gsnmp-0.3.0.ebuild20
1 files changed, 12 insertions, 8 deletions
diff --git a/net-libs/gsnmp/gsnmp-0.3.0.ebuild b/net-libs/gsnmp/gsnmp-0.3.0.ebuild
index e38b808d2f68..03183265f562 100644
--- a/net-libs/gsnmp/gsnmp-0.3.0.ebuild
+++ b/net-libs/gsnmp/gsnmp-0.3.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit autotools epatch ltprune
+inherit autotools
DESCRIPTION="An SNMP library based on glib and gnet"
HOMEPAGE="https://github.com/schoenw/gsnmp"
@@ -19,14 +19,18 @@ DEPEND="
net-libs/gnet
"
RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
-DOCS="README"
+DOCS=( README )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-g_access.patch
+ "${FILESDIR}"/${P}-pkg_config.patch
+ "${FILESDIR}"/${P}-underquoting.patch
+)
src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-g_access.patch \
- "${FILESDIR}"/${P}-pkg_config.patch \
- "${FILESDIR}"/${P}-underquoting.patch
+ default
eautoreconf
}
@@ -38,5 +42,5 @@ src_configure() {
src_install() {
default
- prune_libtool_files
+ find "${ED}" -name '*.la' -delete || die
}