summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-01-19 20:47:40 +0200
committerMart Raudsepp <leio@gentoo.org>2020-01-19 20:48:01 +0200
commit67cc73686f1c4ea44aa0b639d2be4659c21c4c9c (patch)
tree637c8fbc91e5cb3e9e12be77218d30f07628391b /net-libs
parentdev-python/pycountry: Drop 16.11.8 (diff)
downloadgentoo-67cc73686f1c4ea44aa0b639d2be4659c21c4c9c.tar.gz
gentoo-67cc73686f1c4ea44aa0b639d2be4659c21c4c9c.tar.bz2
gentoo-67cc73686f1c4ea44aa0b639d2be4659c21c4c9c.zip
net-libs/webkit-gtk: fix USE=-jumbo-build builds on non-amd64
In some non-amd64 architectures (arm and sparc at least), there are missing headers in JSC. Not sure what the trigger is - maybe lack of FTL, or some other differences. Hopefully fix it by patching in the necessary includes to the places I could identify with limited armv7a cross-compiling. Closes: https://bugs.gentoo.org/704194 Package-Manager: Portage-2.3.79, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/webkit-gtk/files/2.26.2-fix-arm-non-unified-build.patch27
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.26.2.ebuild1
2 files changed, 28 insertions, 0 deletions
diff --git a/net-libs/webkit-gtk/files/2.26.2-fix-arm-non-unified-build.patch b/net-libs/webkit-gtk/files/2.26.2-fix-arm-non-unified-build.patch
new file mode 100644
index 000000000000..0f0959900df2
--- /dev/null
+++ b/net-libs/webkit-gtk/files/2.26.2-fix-arm-non-unified-build.patch
@@ -0,0 +1,27 @@
+Add missing headers required during non-unified build.
+
+Unified build happens to get them included by the other sources unified
+into same source file, thus didn't fail.
+
+diff -urNp a/Source/JavaScriptCore/bytecompiler/NodesCodegen.cpp b/Source/JavaScriptCore/bytecompiler/NodesCodegen.cpp
+--- a/Source/JavaScriptCore/bytecompiler/NodesCodegen.cpp
++++ b/Source/JavaScriptCore/bytecompiler/NodesCodegen.cpp
+@@ -30,6 +30,7 @@
+
+ #include "BuiltinNames.h"
+ #include "BytecodeGenerator.h"
++#include "BytecodeStructs.h"
+ #include "CallFrame.h"
+ #include "JIT.h"
+ #include "JSCInlines.h"
+diff -urNp a/Source/JavaScriptCore/heap/MachineStackMarker.cpp b/Source/JavaScriptCore/heap/MachineStackMarker.cpp
+--- a/Source/JavaScriptCore/heap/MachineStackMarker.cpp
++++ b/Source/JavaScriptCore/heap/MachineStackMarker.cpp
+@@ -23,6 +23,7 @@
+ #include "MachineStackMarker.h"
+
+ #include "ConservativeRoots.h"
++#include "CPU.h"
+ #include "MachineContext.h"
+ #include <setjmp.h>
+ #include <stdlib.h>
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.26.2.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.26.2.ebuild
index d8e82634b06a..455b181a4dde 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.26.2.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.26.2.ebuild
@@ -167,6 +167,7 @@ src_prepare() {
eapply "${FILESDIR}/${PN}-2.24.4-icu-65.patch" # bug 698596
eapply "${FILESDIR}/${PN}-2.24.4-eglmesaext-include.patch" # bug 699054 # https://bugs.webkit.org/show_bug.cgi?id=204108
eapply "${FILESDIR}"/${PV}-fix-noGL-build.patch # bug 704236
+ eapply "${FILESDIR}"/${PV}-fix-arm-non-unified-build.patch # bug 704194
cmake-utils_src_prepare
gnome2_src_prepare
}