summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-08-19 16:18:39 -0500
committerWilliam Hubbs <williamh@gentoo.org>2024-08-19 16:18:39 -0500
commit4fe3848c24e1238204bc713bd86c57dac59dbe84 (patch)
treecd018bbf448587b46c2128263fc49d28a75f3e68 /net-libs
parentnet-libs/nodejs: drop 18.20.3 (diff)
downloadgentoo-4fe3848c24e1238204bc713bd86c57dac59dbe84.tar.gz
gentoo-4fe3848c24e1238204bc713bd86c57dac59dbe84.tar.bz2
gentoo-4fe3848c24e1238204bc713bd86c57dac59dbe84.zip
net-libs/nodejs: drop 20.14.0, 20.15.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nodejs/Manifest2
-rw-r--r--net-libs/nodejs/nodejs-20.14.0.ebuild262
-rw-r--r--net-libs/nodejs/nodejs-20.15.0.ebuild262
3 files changed, 0 insertions, 526 deletions
diff --git a/net-libs/nodejs/Manifest b/net-libs/nodejs/Manifest
index ecf3197a07e5..d0f83a7efae7 100644
--- a/net-libs/nodejs/Manifest
+++ b/net-libs/nodejs/Manifest
@@ -1,6 +1,4 @@
DIST node-v18.20.4.tar.xz 40445740 BLAKE2B 0675f2aba1d9a9cd9aeb665ecb3a0f61b9caf39daeb6154941f84b9c423caa7a658c14b8c2c5e12d94424b2470748ec7fad28ecb10390d37f92eb7e50f8adc26 SHA512 1ccef99ebee3906f5bad3c1582f9551ced9bed15e6a047d59d1a23c6110004fb46ea4bebcf9899748c64109f78788d7365ee956444e645eaf397dabbcddda21e
-DIST node-v20.14.0.tar.xz 41795876 BLAKE2B 588c380751c12f05ccc95146f6e7f9c3eadfc77e769d836cdca1832a7739a40723fd9a7a4e59a2ab4ad087a2b2def5da76ec28077996b59ae0a6d5b2bd15d2c6 SHA512 b6148c705b2152b20c6567a9bbcbbb3925972d17273e126613b350d1d117600e2d895a93d70f793523cb903337ace9527c541a38cb10137eb81ba992778ed243
-DIST node-v20.15.0.tar.xz 41868532 BLAKE2B 07049df11e18b90ee3ebc72fdd953a64a4a925f234fcf7bfb26c472d841bd3f6f34233670d1cc67ba592eeaa714de74c6a7b89ac5a9f62a321764023a86760de SHA512 2b041ee368ca27fa1f92ec8a43237423b7e2f81dabf525e20df7b9b200a46e6d9a8c4b82beb33ec58a9351e0eea865eadfadac3d9e4d3733b1d699f0b5d4bbf3
DIST node-v20.15.1.tar.xz 41880412 BLAKE2B f113856db03a3306d50a659e21d11f585e9e78b85ce7ad9926cc778837f905c618ac762faf56e03caaa862ab0a38c5f34770cd2bfb0854d79650ee9d9b9e2bfe SHA512 2a2935490c4c629f47cc67819094904a1b91eaf0b75cbb8ebe92f5eb34b0929230932fa456bf1bec00213155ea8b6337b2e02e946fc18606543c8c71082615b9
DIST node-v20.16.0.tar.xz 41822608 BLAKE2B 90421b9bf5fad96fadee3eb6fc12461aa6a3456a5266a03f1286f977429af6992e5b1c81a72faa54b3349d46e93881fbfad8970bdebe56afde16b17a1a59dd26 SHA512 494ac16904ecb9f799789f190b869b7509bc66e99713d72723d2bf5051a8a5ca57a4f7303c732aa1fd121cff0defd238be4f656cb4d4e81cc7416b63d9c8677d
DIST node-v22.3.0.tar.xz 44517412 BLAKE2B 38ed4e6de9be48fb252b809a0174420f0f201f583ef5fb46a446d74168a25b39e1fa95ede44bfee8e7099dfe5636b3fb2bcd1ba3d626d7dfcac01dec0bd84d0a SHA512 70d1508bb576d98ef138db5618a5b07ca4412ec8a2aa35c8ff1d76fc93221bff6d7b418ff60b9194c420ad810523d5aeb0ffa662d2fa99f9cecf299317698710
diff --git a/net-libs/nodejs/nodejs-20.14.0.ebuild b/net-libs/nodejs/nodejs-20.14.0.ebuild
deleted file mode 100644
index 19cb5426039c..000000000000
--- a/net-libs/nodejs/nodejs-20.14.0.ebuild
+++ /dev/null
@@ -1,262 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-CONFIG_CHECK="~ADVISE_SYSCALLS"
-PYTHON_COMPAT=( python3_{9..12} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit bash-completion-r1 check-reqs flag-o-matic linux-info pax-utils python-any-r1 toolchain-funcs xdg-utils
-
-DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
-HOMEPAGE="https://nodejs.org/"
-LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/nodejs/node"
- SLOT="0"
-else
- SRC_URI="https://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz"
- SLOT="0/$(ver_cut 1)"
- KEYWORDS="amd64 arm arm64 ~loong ppc64 ~riscv x86 ~amd64-linux ~x64-macos"
- S="${WORKDIR}/node-v${PV}"
-fi
-
-IUSE="corepack cpu_flags_x86_sse2 debug doc +icu inspector lto +npm pax-kernel +snapshot +ssl +system-icu +system-ssl test"
-REQUIRED_USE="inspector? ( icu ssl )
- npm? ( ssl )
- system-icu? ( icu )
- system-ssl? ( ssl )
- x86? ( cpu_flags_x86_sse2 )"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=app-arch/brotli-1.0.9:=
- >=dev-libs/libuv-1.46.0:=
- >=net-dns/c-ares-1.18.1:=
- >=net-libs/nghttp2-1.41.0:=
- >=net-libs/ngtcp2-1.1.0:=
- sys-libs/zlib
- corepack? ( !sys-apps/yarn )
- system-icu? ( >=dev-libs/icu-71:= )
- system-ssl? ( >=dev-libs/openssl-1.1.1:0= )
- sys-devel/gcc:*"
-BDEPEND="${PYTHON_DEPS}
- app-alternatives/ninja
- sys-apps/coreutils
- virtual/pkgconfig
- test? ( net-misc/curl )
- pax-kernel? ( sys-apps/elfix )"
-DEPEND="${RDEPEND}"
-
-# These are measured on a loong machine with -ggdb on, and only checked
-# if debugging flags are present in CFLAGS.
-#
-# The final link consumed a little more than 7GiB alone, so 8GiB is the lower
-# limit for memory usage. Disk usage was 19.1GiB for the build directory and
-# 1.2GiB for the installed image, so we leave some room for architectures with
-# fatter binaries and set the disk requirement to 22GiB.
-CHECKREQS_MEMORY="8G"
-CHECKREQS_DISK_BUILD="22G"
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != "binary" ]]; then
- if is-flagq "-g*" && ! is-flagq "-g*0" ; then
- einfo "Checking for sufficient disk space and memory to build ${PN} with debugging CFLAGS"
- check-reqs_pkg_pretend
- fi
- fi
-}
-
-pkg_setup() {
- python-any-r1_pkg_setup
- linux-info_pkg_setup
-}
-
-src_prepare() {
- tc-export AR CC CXX PKG_CONFIG
- export V=1
- export BUILDTYPE=Release
-
- # fix compilation on Darwin
- # https://code.google.com/p/gyp/issues/detail?id=260
- sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
-
- # proper libdir, hat tip @ryanpcmcquen https://github.com/iojs/io.js/issues/504
- local LIBDIR=$(get_libdir)
- sed -i -e "s|lib/|${LIBDIR}/|g" tools/install.py || die
- sed -i -e "s/'lib'/'${LIBDIR}'/" deps/npm/lib/npm.js || die
-
- # Avoid writing a depfile, not useful
- sed -i -e "/DEPFLAGS =/d" tools/gyp/pylib/gyp/generator/make.py || die
-
- sed -i -e "/'-O3'/d" common.gypi node.gypi || die
-
- # debug builds. change install path, remove optimisations and override buildtype
- if use debug; then
- sed -i -e "s|out/Release/|out/Debug/|g" tools/install.py || die
- BUILDTYPE=Debug
- fi
-
- # We need to disable mprotect on two files when it builds Bug 694100.
- use pax-kernel && PATCHES+=( "${FILESDIR}"/${PN}-20.6.0-paxmarking.patch )
-
- default
-}
-
-src_configure() {
- xdg_environment_reset
-
- # LTO compiler flags are handled by configure.py itself
- filter-lto
- # nodejs unconditionally links to libatomic #869992
- # specifically it requires __atomic_is_lock_free which
- # is not yet implemented by sys-libs/compiler-rt (see
- # https://reviews.llvm.org/D85044?id=287068), therefore
- # we depend on gcc and force using libgcc as the support lib
- tc-is-clang && append-ldflags "--rtlib=libgcc --unwindlib=libgcc"
-
- local myconf=(
- --ninja
- --shared-brotli
- --shared-cares
- --shared-libuv
- --shared-nghttp2
- --shared-ngtcp2
- --shared-zlib
- )
- use debug && myconf+=( --debug )
- use lto && myconf+=( --enable-lto )
- if use system-icu; then
- myconf+=( --with-intl=system-icu )
- elif use icu; then
- myconf+=( --with-intl=full-icu )
- else
- myconf+=( --with-intl=none )
- fi
- use corepack || myconf+=( --without-corepack )
- use inspector || myconf+=( --without-inspector )
- use npm || myconf+=( --without-npm )
- use snapshot || myconf+=( --without-node-snapshot )
- if use ssl; then
- use system-ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store )
- else
- myconf+=( --without-ssl )
- fi
-
- local myarch=""
- case "${ARCH}:${ABI}" in
- *:amd64) myarch="x64";;
- *:arm) myarch="arm";;
- *:arm64) myarch="arm64";;
- loong:lp64*) myarch="loong64";;
- riscv:lp64*) myarch="riscv64";;
- *:ppc64) myarch="ppc64";;
- *:x32) myarch="x32";;
- *:x86) myarch="ia32";;
- *) myarch="${ABI}";;
- esac
-
- GYP_DEFINES="linux_use_gold_flags=0
- linux_use_bundled_binutils=0
- linux_use_bundled_gold=0" \
- "${EPYTHON}" configure.py \
- --prefix="${EPREFIX}"/usr \
- --dest-cpu=${myarch} \
- "${myconf[@]}" || die
-}
-
-src_compile() {
- emake -Onone
-}
-
-src_install() {
- local LIBDIR="${ED}/usr/$(get_libdir)"
- default
-
- pax-mark -m "${ED}"/usr/bin/node
-
- # set up a symlink structure that node-gyp expects..
- dodir /usr/include/node/deps/{v8,uv}
- dosym . /usr/include/node/src
- for var in deps/{uv,v8}/include; do
- dosym ../.. /usr/include/node/${var}
- done
-
- if use doc; then
- docinto html
- dodoc -r "${S}"/doc/*
- fi
-
- if use npm; then
- keepdir /etc/npm
- echo "NPM_CONFIG_GLOBALCONFIG=${EPREFIX}/etc/npm/npmrc" > "${T}"/50npm
- doenvd "${T}"/50npm
-
- # Install bash completion for `npm`
- local tmp_npm_completion_file="$(TMPDIR="${T}" mktemp -t npm.XXXXXXXXXX)"
- "${ED}/usr/bin/npm" completion > "${tmp_npm_completion_file}"
- newbashcomp "${tmp_npm_completion_file}" npm
-
- # Move man pages
- doman "${LIBDIR}"/node_modules/npm/man/man{1,5,7}/*
-
- # Clean up
- rm -f "${LIBDIR}"/node_modules/npm/{.mailmap,.npmignore,Makefile}
- rm -rf "${LIBDIR}"/node_modules/npm/{doc,html,man}
-
- local find_exp="-or -name"
- local find_name=()
- for match in "AUTHORS*" "CHANGELOG*" "CONTRIBUT*" "README*" \
- ".travis.yml" ".eslint*" ".wercker.yml" ".npmignore" \
- "*.md" "*.markdown" "*.bat" "*.cmd"; do
- find_name+=( ${find_exp} "${match}" )
- done
-
- # Remove various development and/or inappropriate files and
- # useless docs of dependend packages.
- find "${LIBDIR}"/node_modules \
- \( -type d -name examples \) -or \( -type f \( \
- -iname "LICEN?E*" \
- "${find_name[@]}" \
- \) \) -exec rm -rf "{}" \;
- fi
-
- use corepack &&
- "${D}"/usr/bin/corepack enable --install-directory "${D}"/usr/bin
-
- mv "${ED}"/usr/share/doc/node "${ED}"/usr/share/doc/${PF} || die
-}
-
-src_test() {
- local drop_tests=(
- test/parallel/test-dns-resolveany-bad-ancount.js
- test/parallel/test-dns-setserver-when-querying.js
- test/parallel/test-fs-mkdir.js
- test/parallel/test-fs-read-stream.js
- test/parallel/test-fs-utimes-y2K38.js
- test/parallel/test-fs-watch-recursive-add-file.js
- test/parallel/test-process-euid-egid.js
- test/parallel/test-process-initgroups.js
- test/parallel/test-process-setgroups.js
- test/parallel/test-process-uid-gid.js
- test/parallel/test-release-npm.js
- test/parallel/test-socket-write-after-fin-error.js
- test/parallel/test-strace-openat-openssl.js
- test/sequential/test-util-debug.js
- )
- [[ "$(nice)" -gt 10 ]] && drop_tests+=( "test/parallel/test-os.js" )
- rm -f "${drop_tests[@]}" || die "disabling tests failed"
-
- out/${BUILDTYPE}/cctest || die
- "${EPYTHON}" tools/test.py --mode=${BUILDTYPE,,} --flaky-tests=dontcare -J message parallel sequential || die
-}
-
-pkg_postinst() {
- if use npm; then
- ewarn "remember to run: source /etc/profile if you plan to use nodejs"
- ewarn " in your current shell"
- fi
-}
diff --git a/net-libs/nodejs/nodejs-20.15.0.ebuild b/net-libs/nodejs/nodejs-20.15.0.ebuild
deleted file mode 100644
index 53ca55f77715..000000000000
--- a/net-libs/nodejs/nodejs-20.15.0.ebuild
+++ /dev/null
@@ -1,262 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-CONFIG_CHECK="~ADVISE_SYSCALLS"
-PYTHON_COMPAT=( python3_{9..12} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit bash-completion-r1 check-reqs flag-o-matic linux-info pax-utils python-any-r1 toolchain-funcs xdg-utils
-
-DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
-HOMEPAGE="https://nodejs.org/"
-LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/nodejs/node"
- SLOT="0"
-else
- SRC_URI="https://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz"
- SLOT="0/$(ver_cut 1)"
- KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86 ~amd64-linux ~x64-macos"
- S="${WORKDIR}/node-v${PV}"
-fi
-
-IUSE="corepack cpu_flags_x86_sse2 debug doc +icu inspector lto +npm pax-kernel +snapshot +ssl +system-icu +system-ssl test"
-REQUIRED_USE="inspector? ( icu ssl )
- npm? ( ssl )
- system-icu? ( icu )
- system-ssl? ( ssl )
- x86? ( cpu_flags_x86_sse2 )"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=app-arch/brotli-1.0.9:=
- >=dev-libs/libuv-1.46.0:=
- >=net-dns/c-ares-1.18.1:=
- >=net-libs/nghttp2-1.41.0:=
- >=net-libs/ngtcp2-1.1.0:=
- sys-libs/zlib
- corepack? ( !sys-apps/yarn )
- system-icu? ( >=dev-libs/icu-71:= )
- system-ssl? ( >=dev-libs/openssl-1.1.1:0= )
- sys-devel/gcc:*"
-BDEPEND="${PYTHON_DEPS}
- app-alternatives/ninja
- sys-apps/coreutils
- virtual/pkgconfig
- test? ( net-misc/curl )
- pax-kernel? ( sys-apps/elfix )"
-DEPEND="${RDEPEND}"
-
-# These are measured on a loong machine with -ggdb on, and only checked
-# if debugging flags are present in CFLAGS.
-#
-# The final link consumed a little more than 7GiB alone, so 8GiB is the lower
-# limit for memory usage. Disk usage was 19.1GiB for the build directory and
-# 1.2GiB for the installed image, so we leave some room for architectures with
-# fatter binaries and set the disk requirement to 22GiB.
-CHECKREQS_MEMORY="8G"
-CHECKREQS_DISK_BUILD="22G"
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != "binary" ]]; then
- if is-flagq "-g*" && ! is-flagq "-g*0" ; then
- einfo "Checking for sufficient disk space and memory to build ${PN} with debugging CFLAGS"
- check-reqs_pkg_pretend
- fi
- fi
-}
-
-pkg_setup() {
- python-any-r1_pkg_setup
- linux-info_pkg_setup
-}
-
-src_prepare() {
- tc-export AR CC CXX PKG_CONFIG
- export V=1
- export BUILDTYPE=Release
-
- # fix compilation on Darwin
- # https://code.google.com/p/gyp/issues/detail?id=260
- sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
-
- # proper libdir, hat tip @ryanpcmcquen https://github.com/iojs/io.js/issues/504
- local LIBDIR=$(get_libdir)
- sed -i -e "s|lib/|${LIBDIR}/|g" tools/install.py || die
- sed -i -e "s/'lib'/'${LIBDIR}'/" deps/npm/lib/npm.js || die
-
- # Avoid writing a depfile, not useful
- sed -i -e "/DEPFLAGS =/d" tools/gyp/pylib/gyp/generator/make.py || die
-
- sed -i -e "/'-O3'/d" common.gypi node.gypi || die
-
- # debug builds. change install path, remove optimisations and override buildtype
- if use debug; then
- sed -i -e "s|out/Release/|out/Debug/|g" tools/install.py || die
- BUILDTYPE=Debug
- fi
-
- # We need to disable mprotect on two files when it builds Bug 694100.
- use pax-kernel && PATCHES+=( "${FILESDIR}"/${PN}-20.6.0-paxmarking.patch )
-
- default
-}
-
-src_configure() {
- xdg_environment_reset
-
- # LTO compiler flags are handled by configure.py itself
- filter-lto
- # nodejs unconditionally links to libatomic #869992
- # specifically it requires __atomic_is_lock_free which
- # is not yet implemented by sys-libs/compiler-rt (see
- # https://reviews.llvm.org/D85044?id=287068), therefore
- # we depend on gcc and force using libgcc as the support lib
- tc-is-clang && append-ldflags "--rtlib=libgcc --unwindlib=libgcc"
-
- local myconf=(
- --ninja
- --shared-brotli
- --shared-cares
- --shared-libuv
- --shared-nghttp2
- --shared-ngtcp2
- --shared-zlib
- )
- use debug && myconf+=( --debug )
- use lto && myconf+=( --enable-lto )
- if use system-icu; then
- myconf+=( --with-intl=system-icu )
- elif use icu; then
- myconf+=( --with-intl=full-icu )
- else
- myconf+=( --with-intl=none )
- fi
- use corepack || myconf+=( --without-corepack )
- use inspector || myconf+=( --without-inspector )
- use npm || myconf+=( --without-npm )
- use snapshot || myconf+=( --without-node-snapshot )
- if use ssl; then
- use system-ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store )
- else
- myconf+=( --without-ssl )
- fi
-
- local myarch=""
- case "${ARCH}:${ABI}" in
- *:amd64) myarch="x64";;
- *:arm) myarch="arm";;
- *:arm64) myarch="arm64";;
- loong:lp64*) myarch="loong64";;
- riscv:lp64*) myarch="riscv64";;
- *:ppc64) myarch="ppc64";;
- *:x32) myarch="x32";;
- *:x86) myarch="ia32";;
- *) myarch="${ABI}";;
- esac
-
- GYP_DEFINES="linux_use_gold_flags=0
- linux_use_bundled_binutils=0
- linux_use_bundled_gold=0" \
- "${EPYTHON}" configure.py \
- --prefix="${EPREFIX}"/usr \
- --dest-cpu=${myarch} \
- "${myconf[@]}" || die
-}
-
-src_compile() {
- emake -Onone
-}
-
-src_install() {
- local LIBDIR="${ED}/usr/$(get_libdir)"
- default
-
- pax-mark -m "${ED}"/usr/bin/node
-
- # set up a symlink structure that node-gyp expects..
- dodir /usr/include/node/deps/{v8,uv}
- dosym . /usr/include/node/src
- for var in deps/{uv,v8}/include; do
- dosym ../.. /usr/include/node/${var}
- done
-
- if use doc; then
- docinto html
- dodoc -r "${S}"/doc/*
- fi
-
- if use npm; then
- keepdir /etc/npm
- echo "NPM_CONFIG_GLOBALCONFIG=${EPREFIX}/etc/npm/npmrc" > "${T}"/50npm
- doenvd "${T}"/50npm
-
- # Install bash completion for `npm`
- local tmp_npm_completion_file="$(TMPDIR="${T}" mktemp -t npm.XXXXXXXXXX)"
- "${ED}/usr/bin/npm" completion > "${tmp_npm_completion_file}"
- newbashcomp "${tmp_npm_completion_file}" npm
-
- # Move man pages
- doman "${LIBDIR}"/node_modules/npm/man/man{1,5,7}/*
-
- # Clean up
- rm -f "${LIBDIR}"/node_modules/npm/{.mailmap,.npmignore,Makefile}
- rm -rf "${LIBDIR}"/node_modules/npm/{doc,html,man}
-
- local find_exp="-or -name"
- local find_name=()
- for match in "AUTHORS*" "CHANGELOG*" "CONTRIBUT*" "README*" \
- ".travis.yml" ".eslint*" ".wercker.yml" ".npmignore" \
- "*.md" "*.markdown" "*.bat" "*.cmd"; do
- find_name+=( ${find_exp} "${match}" )
- done
-
- # Remove various development and/or inappropriate files and
- # useless docs of dependend packages.
- find "${LIBDIR}"/node_modules \
- \( -type d -name examples \) -or \( -type f \( \
- -iname "LICEN?E*" \
- "${find_name[@]}" \
- \) \) -exec rm -rf "{}" \;
- fi
-
- use corepack &&
- "${D}"/usr/bin/corepack enable --install-directory "${D}"/usr/bin
-
- mv "${ED}"/usr/share/doc/node "${ED}"/usr/share/doc/${PF} || die
-}
-
-src_test() {
- local drop_tests=(
- test/parallel/test-dns-resolveany-bad-ancount.js
- test/parallel/test-dns-setserver-when-querying.js
- test/parallel/test-fs-mkdir.js
- test/parallel/test-fs-read-stream.js
- test/parallel/test-fs-utimes-y2K38.js
- test/parallel/test-fs-watch-recursive-add-file.js
- test/parallel/test-process-euid-egid.js
- test/parallel/test-process-initgroups.js
- test/parallel/test-process-setgroups.js
- test/parallel/test-process-uid-gid.js
- test/parallel/test-release-npm.js
- test/parallel/test-socket-write-after-fin-error.js
- test/parallel/test-strace-openat-openssl.js
- test/sequential/test-util-debug.js
- )
- [[ "$(nice)" -gt 10 ]] && drop_tests+=( "test/parallel/test-os.js" )
- rm -f "${drop_tests[@]}" || die "disabling tests failed"
-
- out/${BUILDTYPE}/cctest || die
- "${EPYTHON}" tools/test.py --mode=${BUILDTYPE,,} --flaky-tests=dontcare -J message parallel sequential || die
-}
-
-pkg_postinst() {
- if use npm; then
- ewarn "remember to run: source /etc/profile if you plan to use nodejs"
- ewarn " in your current shell"
- fi
-}