summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorValérian Rousset <tharvik@users.noreply.github.com>2020-12-07 00:33:42 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-12-11 09:58:10 +0200
commit277c1e84088b272b3979df0c74ab738150929590 (patch)
treece70eb638630c32b414563ad540b38a58ff57e56 /net-libs
parentnet-vpn/i2p: drop 0.9.45 (diff)
downloadgentoo-277c1e84088b272b3979df0c74ab738150929590.tar.gz
gentoo-277c1e84088b272b3979df0c74ab738150929590.tar.bz2
gentoo-277c1e84088b272b3979df0c74ab738150929590.zip
net-libs/nativebiginteger: bump to 0.9.48
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Valérian Rousset <tharvik@users.noreply.github.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nativebiginteger/Manifest1
-rw-r--r--net-libs/nativebiginteger/nativebiginteger-0.9.48.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/net-libs/nativebiginteger/Manifest b/net-libs/nativebiginteger/Manifest
index cfc3977e98ae..83886cdee053 100644
--- a/net-libs/nativebiginteger/Manifest
+++ b/net-libs/nativebiginteger/Manifest
@@ -1,2 +1,3 @@
DIST i2psource_0.9.45.tar.bz2 31921025 BLAKE2B 2d37777f77784ff93de4d7442eddf46b9a541902412bf5fb24cf96baba73851cc17d01649a7b4b41a710ccde5690036a890b8f84de00f4c615ed2e23da8fa510 SHA512 d4cf354f0a807d132fae75d4bad3e2e788e1ed03d6f625feb0f1369bb2c9e1a6e2758645acf2017c61dbc47d75e6d834b87455adbead1077f206025686548ae9
DIST i2psource_0.9.47.tar.bz2 32488438 BLAKE2B e1544475dad526e242570918c1bb967a4b713567e71201e08b73c8995743a68396b5951f477bfe8830927c0cdf7e991a25a1978d4aaf88cae3e4218ba57a8818 SHA512 7fdd9ab0b3e81aa89e73be6fa172d723c2b5a67365116a1e0e0ec948067fe4f58e3ad946a0ef4605602c0d803b98e37b2d5692a39a14cf7433d546ada204cbc9
+DIST i2psource_0.9.48.tar.bz2 33029295 BLAKE2B 8210018610d3dd8272d3c136f32048ede9446c517971be97d6588c6a1a592e9db2261077da3634fa29af28ecdb488427dd1145a731b130b75f41c3c56a8c8779 SHA512 ddfbc8f86bc2fd4012e14732493d30e292af1603d74b1f786a0ecc56a1373301ec9b3fd16fe2e37777f953053291b8efdb5510959fcf1e42d7e5f8ec87d85a8a
diff --git a/net-libs/nativebiginteger/nativebiginteger-0.9.48.ebuild b/net-libs/nativebiginteger/nativebiginteger-0.9.48.ebuild
new file mode 100644
index 000000000000..e0d376b7aa6d
--- /dev/null
+++ b/net-libs/nativebiginteger/nativebiginteger-0.9.48.ebuild
@@ -0,0 +1,71 @@
+# Copyright 2018-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit java-pkg-2 toolchain-funcs
+
+DESCRIPTION="jbigi library used by net-vpn/i2p"
+HOMEPAGE="https://geti2p.net"
+SRC_URI="https://download.i2p2.de/releases/${PV}/i2psource_${PV}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/gmp:0=
+ virtual/jdk:1.8
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/i2p-${PV}/core"
+
+PATCHES=(
+ "${FILESDIR}/${P}-asmfix.patch"
+)
+
+src_compile() {
+ local compile_lib
+ compile_lib() {
+ local name="${1}"
+ local file="${2}"
+ shift 2
+
+ "$(tc-getCC)" "${@}" ${CFLAGS} $(java-pkg_get-jni-cflags) \
+ ${LDFLAGS} -shared -fPIC "-Wl,-soname,lib${name}.so" \
+ "${file}" -o "lib${name}.so"
+ }
+
+ cd "${S}/c/jbigi/jbigi" || die "unable to cd to jbigi"
+ compile_lib jbigi src/jbigi.c -Iinclude -lgmp ||
+ die "unable to build jbigi"
+
+ if use amd64 || use x86; then
+ cd "${S}/c/jcpuid" || die "unable to cd to jcpuid"
+ compile_lib jcpuid src/jcpuid.c -Iinclude ||
+ die "unable to build jcpuid"
+ fi
+
+ if use test; then
+ cd "${S}/java/src" || die "unable to cd to java/src"
+ ejavac -encoding UTF-8 net/i2p/util/NativeBigInteger.java ||
+ die "unable to build tests"
+ fi
+}
+
+src_test() {
+ cd "${S}/java/src" || die "unable to cd to java/src"
+ "$(java-config -J)" -Djava.library.path="${S}/c/jbigi/jbigi" net/i2p/util/NativeBigInteger ||
+ die "unable to pass tests"
+}
+
+src_install() {
+ dolib.so c/jbigi/jbigi/libjbigi.so
+
+ if use amd64 || use x86; then
+ dolib.so c/jcpuid/libjcpuid.so
+ fi
+}