summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-10-27 08:46:40 -0400
committerMichael Orlitzky <mjo@gentoo.org>2024-10-27 08:47:17 -0400
commit20c369ebe5f2bcfe368d7651edaccbab06965c7e (patch)
treede7ddc4f221176b81fd556442ba22f50225d512d /net-libs
parentapp-containers/incus: add OCI optfeature (diff)
downloadgentoo-20c369ebe5f2bcfe368d7651edaccbab06965c7e.tar.gz
gentoo-20c369ebe5f2bcfe368d7651edaccbab06965c7e.tar.bz2
gentoo-20c369ebe5f2bcfe368d7651edaccbab06965c7e.zip
net-libs/webkit-gtk: patch cleanup for 2.46.x
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/webkit-gtk/files/2.46.1-riscv-buildfix.patch43
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.46.2-r410.ebuild2
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.46.2-r600.ebuild2
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.46.2.ebuild2
4 files changed, 0 insertions, 49 deletions
diff --git a/net-libs/webkit-gtk/files/2.46.1-riscv-buildfix.patch b/net-libs/webkit-gtk/files/2.46.1-riscv-buildfix.patch
deleted file mode 100644
index 7c9110280020..000000000000
--- a/net-libs/webkit-gtk/files/2.46.1-riscv-buildfix.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From 2f69282c9271c76e8783412766a50477288e5888 Mon Sep 17 00:00:00 2001
-From: Markus Volk <f_l_k@t-online.de>
-Date: Thu, 3 Oct 2024 12:34:03 +0200
-Subject: [PATCH] JavaScriptCore/jit/GPRInfo.h: fix typo in RISCV64Registers
-
-RICSV64Registers -> RISCV64Registers
-
-Signed-off-by: Markus Volk <f_l_k@t-online.de>
----
- Source/JavaScriptCore/jit/GPRInfo.h | 20 ++++++++++----------
- 1 file changed, 10 insertions(+), 10 deletions(-)
-
-diff --git a/Source/JavaScriptCore/jit/GPRInfo.h b/Source/JavaScriptCore/jit/GPRInfo.h
-index fa7bf0aac48de..df5871957b3f5 100644
---- a/Source/JavaScriptCore/jit/GPRInfo.h
-+++ b/Source/JavaScriptCore/jit/GPRInfo.h
-@@ -779,16 +779,16 @@ class GPRInfo {
- static constexpr GPRReg wasmBaseMemoryPointer = regCS3;
- static constexpr GPRReg wasmBoundsCheckingSizeRegister = regCS4;
-
-- static constexpr GPRReg regWS0 = RICSV64Registers::x6;
-- static constexpr GPRReg regWS1 = RICSV64Registers::x7;
-- static constexpr GPRReg regWA0 = RICSV64Registers::x10;
-- static constexpr GPRReg regWA1 = RICSV64Registers::x11;
-- static constexpr GPRReg regWA2 = RICSV64Registers::x12;
-- static constexpr GPRReg regWA3 = RICSV64Registers::x13;
-- static constexpr GPRReg regWA4 = RICSV64Registers::x14;
-- static constexpr GPRReg regWA5 = RICSV64Registers::x15;
-- static constexpr GPRReg regWA6 = RICSV64Registers::x16;
-- static constexpr GPRReg regWA7 = RICSV64Registers::x17;
-+ static constexpr GPRReg regWS0 = RISCV64Registers::x6;
-+ static constexpr GPRReg regWS1 = RISCV64Registers::x7;
-+ static constexpr GPRReg regWA0 = RISCV64Registers::x10;
-+ static constexpr GPRReg regWA1 = RISCV64Registers::x11;
-+ static constexpr GPRReg regWA2 = RISCV64Registers::x12;
-+ static constexpr GPRReg regWA3 = RISCV64Registers::x13;
-+ static constexpr GPRReg regWA4 = RISCV64Registers::x14;
-+ static constexpr GPRReg regWA5 = RISCV64Registers::x15;
-+ static constexpr GPRReg regWA6 = RISCV64Registers::x16;
-+ static constexpr GPRReg regWA7 = RISCV64Registers::x17;
-
- static constexpr GPRReg patchpointScratchRegister = RISCV64Registers::x30; // Should match dataTempRegister
-
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.46.2-r410.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.46.2-r410.ebuild
index d7ad93f005eb..2b20ac28e17d 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.46.2-r410.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.46.2-r410.ebuild
@@ -150,8 +150,6 @@ pkg_setup() {
src_prepare() {
cmake_src_prepare
gnome2_src_prepare
-
- eapply "${FILESDIR}/2.46.1-riscv-buildfix.patch"
}
src_configure() {
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.46.2-r600.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.46.2-r600.ebuild
index 8c4f3556c6b3..9943c5467da0 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.46.2-r600.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.46.2-r600.ebuild
@@ -161,8 +161,6 @@ pkg_setup() {
src_prepare() {
cmake_src_prepare
gnome2_src_prepare
-
- eapply "${FILESDIR}/2.46.1-riscv-buildfix.patch"
}
src_configure() {
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.46.2.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.46.2.ebuild
index ae809ea078f4..c7591b6bc2df 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.46.2.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.46.2.ebuild
@@ -150,8 +150,6 @@ pkg_setup() {
src_prepare() {
cmake_src_prepare
gnome2_src_prepare
-
- eapply "${FILESDIR}/2.46.1-riscv-buildfix.patch"
}
src_configure() {