summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/libnftnl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/libnftnl')
-rw-r--r--net-libs/libnftnl/Manifest1
-rw-r--r--net-libs/libnftnl/libnftnl-1.0.3.ebuild58
-rw-r--r--net-libs/libnftnl/metadata.xml13
3 files changed, 72 insertions, 0 deletions
diff --git a/net-libs/libnftnl/Manifest b/net-libs/libnftnl/Manifest
new file mode 100644
index 000000000000..6bece668805c
--- /dev/null
+++ b/net-libs/libnftnl/Manifest
@@ -0,0 +1 @@
+DIST libnftnl-1.0.3.tar.bz2 356264 SHA256 cf0ae7eab6a6866192a1fbd6b370a8a2cbe2066fe3975ab44939fd50747c27f7 SHA512 6fba3f3a0c3d98e0c3200edbd45910e326f0864383dc695fa77580d47d3fe541c50518f62d2dbfc50b2378b9b311aec28b3321ef18f59a321e0a3f0817952181 WHIRLPOOL 70219737c4d865bdfe9f58803377d3a10619198cb486623d03d30a43b0d159ded9d625505cb0209fe30585dbe3413d136d2fdd6552a6ce2339151bedb1c94c9a
diff --git a/net-libs/libnftnl/libnftnl-1.0.3.ebuild b/net-libs/libnftnl/libnftnl-1.0.3.ebuild
new file mode 100644
index 000000000000..d74a39499681
--- /dev/null
+++ b/net-libs/libnftnl/libnftnl-1.0.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit base linux-info toolchain-funcs
+
+DESCRIPTION="Netlink API to the in-kernel nf_tables subsystem"
+HOMEPAGE="http://netfilter.org/projects/nftables/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="examples json static-libs test xml"
+SRC_URI="http://netfilter.org/projects/${PN}/files/${P}.tar.bz2"
+
+RDEPEND=">=net-libs/libmnl-1.0.0
+ xml? ( >=dev-libs/mini-xml-2.6 )
+ json? ( >=dev-libs/jansson-2.3 )"
+DEPEND="virtual/pkgconfig
+ ${RDEPEND}"
+
+REQUIRED_USE="test? ( json xml )"
+
+pkg_setup() {
+ if kernel_is ge 3 13; then
+ CONFIG_CHECK="~NF_TABLES"
+ linux-info_pkg_setup
+ else
+ eerror "This package requires kernel version 3.13 or newer to work properly."
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with xml xml-parsing) \
+ $(use_with json json-parsing)
+}
+
+src_install() {
+ default
+ gen_usr_ldscript -a nftnl
+ prune_libtool_files
+
+ if use examples; then
+ find examples/ -name 'Makefile*' -delete
+ dodoc -r examples/
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
+
+src_test() {
+ default
+ cd tests || die
+ ./test-script.sh || die
+}
diff --git a/net-libs/libnftnl/metadata.xml b/net-libs/libnftnl/metadata.xml
new file mode 100644
index 000000000000..905b54ef6c40
--- /dev/null
+++ b/net-libs/libnftnl/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+<maintainer>
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+</maintainer>
+<use>
+ <flag name="json">Supports parsing of JSON</flag>
+</use>
+</pkgmetadata>
+