summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/libgcal
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/libgcal')
-rw-r--r--net-libs/libgcal/Manifest1
-rw-r--r--net-libs/libgcal/libgcal-0.9.6-r1.ebuild54
-rw-r--r--net-libs/libgcal/metadata.xml10
3 files changed, 65 insertions, 0 deletions
diff --git a/net-libs/libgcal/Manifest b/net-libs/libgcal/Manifest
new file mode 100644
index 000000000000..ff2505849e14
--- /dev/null
+++ b/net-libs/libgcal/Manifest
@@ -0,0 +1 @@
+DIST libgcal-0.9.6.tar.bz2 555942 SHA256 3197d76c462438d0a761c47d199e402b9d9f05f86a7f9c304313a79ecc5a1503 SHA512 be2e0592a19531fa202017e529dad765a1bd6f9205ffdaba33bfd32231ad5eafb0237081fda8c5bbbe605e07204fc7895e2168b72718dde6cc660c97c08bbf26 WHIRLPOOL f4a4f7df4da7e231af6cd292a4f642017d5fd734eb4c16bdefbb45cad5a32fe0f5ba3f53d4277c250a8782c56acd03e5499f093e662d193a9ad3f2eb80b1791b
diff --git a/net-libs/libgcal/libgcal-0.9.6-r1.ebuild b/net-libs/libgcal/libgcal-0.9.6-r1.ebuild
new file mode 100644
index 000000000000..b0e8a441f2bc
--- /dev/null
+++ b/net-libs/libgcal/libgcal-0.9.6-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="C/C++ interface to the Google Data API"
+HOMEPAGE="http://code.google.com/p/libgcal/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc test"
+
+# Some tests fail
+RESTRICT="test"
+
+RDEPEND="
+ dev-libs/libxml2:2
+ >=net-misc/curl-7.18.2
+"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ test? ( dev-libs/check )
+"
+
+DOCS=( README )
+
+src_configure() {
+ mycmakeargs=(
+ -DENABLE_TESTS=OFF
+ $(cmake-utils_use debug CURL_DEBUG)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ use doc && cmake-utils_src_compile docs
+}
+
+src_install() {
+ use doc && HTML_DOCS=( "${BUILD_DIR}/docs/doxygen/html/" )
+ cmake-utils_src_install
+}
+
+src_test() {
+ mycmakeargs+=(-DENABLE_TESTS=ON)
+ cmake-utils_src_configure
+ cmake-utils_src_make test
+}
diff --git a/net-libs/libgcal/metadata.xml b/net-libs/libgcal/metadata.xml
new file mode 100644
index 000000000000..f4bf8ee894eb
--- /dev/null
+++ b/net-libs/libgcal/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">libgcal</remote-id>
+ </upstream>
+</pkgmetadata>