summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-09-04 10:21:31 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-09-04 10:21:31 +0200
commitc015275cd583654152f83a08d77f77c3a7c43666 (patch)
treed4d034c66b5ec197d5c15b2cce7b407da7568815 /net-im
parentdev-python/spyder-line-profiler: add 0.4.0 (diff)
downloadgentoo-c015275cd583654152f83a08d77f77c3a7c43666.tar.gz
gentoo-c015275cd583654152f83a08d77f77c3a7c43666.tar.bz2
gentoo-c015275cd583654152f83a08d77f77c3a7c43666.zip
net-im/whatsie: add 4.15.3
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/whatsie/Manifest1
-rw-r--r--net-im/whatsie/whatsie-4.15.3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/net-im/whatsie/Manifest b/net-im/whatsie/Manifest
index 156690b52d83..0068892ae3ce 100644
--- a/net-im/whatsie/Manifest
+++ b/net-im/whatsie/Manifest
@@ -1,2 +1,3 @@
DIST whatsie-4.14.2.tar.gz 21146777 BLAKE2B 3d923b9d4b109cbc894481fed9723fe84d992663ea953218cd4b128317aebe2fb8a60608d351cc9f4cfc5a976713ce2a3a642a122276068ed63a96e6cf656603 SHA512 b0b6ab0fab30723ee64b723f79776b6953229502e22f4c5e9fb809aa198e369ee05398abca218680adeea1acfcafd0026e13e424458fedad2c0260c2d956fffb
DIST whatsie-4.15.0.tar.gz 21146977 BLAKE2B fc8d3aba5776681efe761ce495419b793c54abd7bc1aadef2bbddb9356ccadfcd4b3937d5640e363e0fa5580a19fe4ea84e8d1d79ea44de5b1311d176d1b8495 SHA512 7e06a2ed60df8bd7714a2b768b05a2b6ff0038eb9b84b1c98977b99b48b0720837010df9adc37617102787dd86d51d6793bfa2b7c7fd0cc9e481a7585c7e7050
+DIST whatsie-4.15.3.tar.gz 21139889 BLAKE2B 54576dfeeb527f801582ad2d94c24b5d5437ed15eca2b3a2dced73d026725f07eb52d1a837c307ee25cf20ac631a9dd2750f9577da580604da56bc5878462dbb SHA512 6bc493b050b4d092a9e075d399cea169873dba6ca4c8db925e3fab82b8c19074713828619a8f699c7917559f9eb052b13bc4935b7a376fcac3017988269014ec
diff --git a/net-im/whatsie/whatsie-4.15.3.ebuild b/net-im/whatsie/whatsie-4.15.3.ebuild
new file mode 100644
index 000000000000..8919b85b6d47
--- /dev/null
+++ b/net-im/whatsie/whatsie-4.15.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils xdg
+
+DESCRIPTION="Qt Based WhatsApp Client"
+HOMEPAGE="https://github.com/keshavbhatt/whatsie"
+SRC_URI="https://github.com/keshavbhatt/whatsie/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P}/src"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+QT_MIN="5.15"
+
+DEPEND="
+ x11-libs/libX11
+ x11-libs/libxcb:=
+ >=dev-qt/qtcore-${QT_MIN}:5
+ >=dev-qt/qtgui-${QT_MIN}:5
+ >=dev-qt/qtnetwork-${QT_MIN}:5
+ >=dev-qt/qtpositioning-${QT_MIN}:5
+ >=dev-qt/qtwebengine-${QT_MIN}:5[widgets]
+ >=dev-qt/qtwidgets-${QT_MIN}:5
+"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ einstalldocs
+ INSTALL_ROOT="${ED}" emake install
+}