summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2024-08-31 21:25:46 +0200
committerSven Wegener <swegener@gentoo.org>2024-08-31 22:52:10 +0200
commit470570c15a2d14afda43a1b1c99c502335bb1016 (patch)
tree0303ec8a23628ce2e0041f06d1a72ff4ba1b3b70 /net-fs/samba
parentmedia-sound/qastools: Stabilize 1.4.0 x86, #938713 (diff)
downloadgentoo-470570c15a2d14afda43a1b1c99c502335bb1016.tar.gz
gentoo-470570c15a2d14afda43a1b1c99c502335bb1016.tar.bz2
gentoo-470570c15a2d14afda43a1b1c99c502335bb1016.zip
net-fs/samba: optimize python modules
Signed-off-by: Sven Wegener <swegener@gentoo.org>
Diffstat (limited to 'net-fs/samba')
-rw-r--r--net-fs/samba/samba-4.18.10.ebuild2
-rw-r--r--net-fs/samba/samba-4.18.11.ebuild2
-rw-r--r--net-fs/samba/samba-4.18.8.ebuild2
-rw-r--r--net-fs/samba/samba-4.18.9.ebuild2
-rw-r--r--net-fs/samba/samba-4.19.4.ebuild2
-rw-r--r--net-fs/samba/samba-4.19.6.ebuild2
-rw-r--r--net-fs/samba/samba-4.19.7.ebuild2
-rw-r--r--net-fs/samba/samba-4.20.0.ebuild2
-rw-r--r--net-fs/samba/samba-4.20.1.ebuild2
-rw-r--r--net-fs/samba/samba-4.20.2.ebuild2
10 files changed, 20 insertions, 0 deletions
diff --git a/net-fs/samba/samba-4.18.10.ebuild b/net-fs/samba/samba-4.18.10.ebuild
index be5091996562..d7569cd2b07f 100644
--- a/net-fs/samba/samba-4.18.10.ebuild
+++ b/net-fs/samba/samba-4.18.10.ebuild
@@ -369,6 +369,8 @@ multilib_src_install() {
dosym nmb.service "$(systemd_get_systemunitdir)/nmbd.service"
dosym smb.service "$(systemd_get_systemunitdir)/smbd.service"
dosym winbind.service "$(systemd_get_systemunitdir)/winbindd.service"
+
+ use python && python_optimize
fi
if use pam && use winbind ; then
diff --git a/net-fs/samba/samba-4.18.11.ebuild b/net-fs/samba/samba-4.18.11.ebuild
index 853948ccc18f..87b7ff0dc625 100644
--- a/net-fs/samba/samba-4.18.11.ebuild
+++ b/net-fs/samba/samba-4.18.11.ebuild
@@ -369,6 +369,8 @@ multilib_src_install() {
dosym nmb.service "$(systemd_get_systemunitdir)/nmbd.service"
dosym smb.service "$(systemd_get_systemunitdir)/smbd.service"
dosym winbind.service "$(systemd_get_systemunitdir)/winbindd.service"
+
+ use python && python_optimize
fi
if use pam && use winbind ; then
diff --git a/net-fs/samba/samba-4.18.8.ebuild b/net-fs/samba/samba-4.18.8.ebuild
index 6d1877fa6e7b..523c89d53286 100644
--- a/net-fs/samba/samba-4.18.8.ebuild
+++ b/net-fs/samba/samba-4.18.8.ebuild
@@ -369,6 +369,8 @@ multilib_src_install() {
dosym nmb.service "$(systemd_get_systemunitdir)/nmbd.service"
dosym smb.service "$(systemd_get_systemunitdir)/smbd.service"
dosym winbind.service "$(systemd_get_systemunitdir)/winbindd.service"
+
+ use python && python_optimize
fi
if use pam && use winbind ; then
diff --git a/net-fs/samba/samba-4.18.9.ebuild b/net-fs/samba/samba-4.18.9.ebuild
index 1acb8412bd5c..e81477e18784 100644
--- a/net-fs/samba/samba-4.18.9.ebuild
+++ b/net-fs/samba/samba-4.18.9.ebuild
@@ -369,6 +369,8 @@ multilib_src_install() {
dosym nmb.service "$(systemd_get_systemunitdir)/nmbd.service"
dosym smb.service "$(systemd_get_systemunitdir)/smbd.service"
dosym winbind.service "$(systemd_get_systemunitdir)/winbindd.service"
+
+ use python && python_optimize
fi
if use pam && use winbind ; then
diff --git a/net-fs/samba/samba-4.19.4.ebuild b/net-fs/samba/samba-4.19.4.ebuild
index 9903c474ab38..5ced32d13bd1 100644
--- a/net-fs/samba/samba-4.19.4.ebuild
+++ b/net-fs/samba/samba-4.19.4.ebuild
@@ -368,6 +368,8 @@ multilib_src_install() {
dosym nmb.service "$(systemd_get_systemunitdir)/nmbd.service"
dosym smb.service "$(systemd_get_systemunitdir)/smbd.service"
dosym winbind.service "$(systemd_get_systemunitdir)/winbindd.service"
+
+ use python && python_optimize
fi
if use pam && use winbind ; then
diff --git a/net-fs/samba/samba-4.19.6.ebuild b/net-fs/samba/samba-4.19.6.ebuild
index 119e2c01cff1..bc332efe7f29 100644
--- a/net-fs/samba/samba-4.19.6.ebuild
+++ b/net-fs/samba/samba-4.19.6.ebuild
@@ -368,6 +368,8 @@ multilib_src_install() {
dosym nmb.service "$(systemd_get_systemunitdir)/nmbd.service"
dosym smb.service "$(systemd_get_systemunitdir)/smbd.service"
dosym winbind.service "$(systemd_get_systemunitdir)/winbindd.service"
+
+ use python && python_optimize
fi
if use pam && use winbind ; then
diff --git a/net-fs/samba/samba-4.19.7.ebuild b/net-fs/samba/samba-4.19.7.ebuild
index 0911ede7e865..488e63e216c4 100644
--- a/net-fs/samba/samba-4.19.7.ebuild
+++ b/net-fs/samba/samba-4.19.7.ebuild
@@ -368,6 +368,8 @@ multilib_src_install() {
dosym nmb.service "$(systemd_get_systemunitdir)/nmbd.service"
dosym smb.service "$(systemd_get_systemunitdir)/smbd.service"
dosym winbind.service "$(systemd_get_systemunitdir)/winbindd.service"
+
+ use python && python_optimize
fi
if use pam && use winbind ; then
diff --git a/net-fs/samba/samba-4.20.0.ebuild b/net-fs/samba/samba-4.20.0.ebuild
index 5cdececc5c61..cc11ee9dd01a 100644
--- a/net-fs/samba/samba-4.20.0.ebuild
+++ b/net-fs/samba/samba-4.20.0.ebuild
@@ -368,6 +368,8 @@ multilib_src_install() {
dosym nmb.service "$(systemd_get_systemunitdir)/nmbd.service"
dosym smb.service "$(systemd_get_systemunitdir)/smbd.service"
dosym winbind.service "$(systemd_get_systemunitdir)/winbindd.service"
+
+ use python && python_optimize
fi
if use pam && use winbind ; then
diff --git a/net-fs/samba/samba-4.20.1.ebuild b/net-fs/samba/samba-4.20.1.ebuild
index 5cdececc5c61..cc11ee9dd01a 100644
--- a/net-fs/samba/samba-4.20.1.ebuild
+++ b/net-fs/samba/samba-4.20.1.ebuild
@@ -368,6 +368,8 @@ multilib_src_install() {
dosym nmb.service "$(systemd_get_systemunitdir)/nmbd.service"
dosym smb.service "$(systemd_get_systemunitdir)/smbd.service"
dosym winbind.service "$(systemd_get_systemunitdir)/winbindd.service"
+
+ use python && python_optimize
fi
if use pam && use winbind ; then
diff --git a/net-fs/samba/samba-4.20.2.ebuild b/net-fs/samba/samba-4.20.2.ebuild
index 55f811279821..83e64361a156 100644
--- a/net-fs/samba/samba-4.20.2.ebuild
+++ b/net-fs/samba/samba-4.20.2.ebuild
@@ -368,6 +368,8 @@ multilib_src_install() {
dosym nmb.service "$(systemd_get_systemunitdir)/nmbd.service"
dosym smb.service "$(systemd_get_systemunitdir)/smbd.service"
dosym winbind.service "$(systemd_get_systemunitdir)/winbindd.service"
+
+ use python && python_optimize
fi
if use pam && use winbind ; then